cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Cisco Community Designated VIP Class of 2020

1717
Views
5
Helpful
15
Replies
Highlighted
Beginner

Transform the CUCM IP(source alias)

Hi everybody,

somebody tells me, since X7.2 the VCS is able to change the CUCM-IP from an incoming CUCM call.

Is this working? How? I'm not able to do this.

My problem is, endpoints who are located at the cucm and calls via VCSE, are not able to display the correct SIP-Domain.

The only show all the time the private CUCM IP as source.b How can i fix it.

Kind regards

Jens

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
Beginner

Transform the CUCM IP(source alias)

Hi Ahmad

with your example it didn't match on the first entry, I modified it a little, now it works:

xmlns:taa="http://www.tandberg.net/cpl-extensions"

xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"

xsi:schemaLocation="urn:ietf:params:xml:ns:cpl cpl.xsd">

   

       

            video1@company.com">

           

       

       

            video2@company.com">

           

       

   

Many thanks to everyone

Peter

View solution in original post

15 REPLIES 15
Cisco Employee

Transform the CUCM IP(source alias)

Hi Jens,

can you elaborate more on your setup??  are you looking to force the media through the VCS-E ???

From VCS x7.2 you can force the encryption on the zones/subzones and hence the VCS always stayed in call not only signaling but it also takes the media in this case.

Rgds

Alok

Transform the CUCM IP(source alias)

I believe he want to change the source alias - e.g. right now when he makes a call from a CUCM registered endpoint it would have 12345@10.1.1.1 as the source alias, he wants to transform this to 12345@sip-domain.com.

I also want to be able to do the same thing!

Beginner

Transform the CUCM IP(source alias)

Yes, thats correct.

If my endpoint is calling somewhere in the internet, I can see 1234@10.1.1.1 as source alias is coming from the SIP Trunk (CUCM <-> VCSC).

The call goes through the traversal Zone and the Expressway(public IP 1.1.1.1).

On the called internet endpoint I can see that 1234@10.1.1.1 is calling, but the displayed name should be vcon1@company.com.

Is there any solution? A cisco guy has told me, that since X7.2 this is possible.

But all testing was not successful.

Cisco Employee

Organization Top Level Domain

.

Beginner

Re: Transform the CUCM IP(source alias)

Hi,

the transformation of the source alias can be done via a cpl script. Who looks like in this thread.

https://supportforums.cisco.com/message/3710851#3710851

Because of this I have build the folowing script.

 

   

     

        1@domain.com">

       

     

   

 

But the transform do not work, the debug looks like.

Detail="CPL: "

Detail="CPL:   "

Detail="CPL: trying to match 12345@1.1.1.1 "

Detail="CPL:

matched "

Detail="CPL: 1@domain.com" diversion="" dest-url-for-message="" sip-route-set="" dest-service=""> added 6698765@domain.com to location set "

Has anybody an idea where the problem is?

Beginner

Transform the CUCM IP(source alias)

Hi Jens,

I'm facing the same problem - have you found a solution?

Regards

Peter

Enthusiast

Transform the CUCM IP(source alias)

I have a different suggestion:

You could configure the Enterprise Parameter "Organization Top Level Domain" and set up the sip trunk to use fqdn names. So you will get the internal domain from cucm to show up on your endpoints.

Regards, Paul
Enthusiast

Transform the CUCM IP(source alias)

Regarding the cpl: I did not test it, but maybe not all SIP Contact headers are updated with the CPL.

Regards, Paul
Beginner

Transform the CUCM IP(source alias)

Hi,

@peter: The configuration of the cpl i have shown is correct, but the VCS is actually not able to replace the source header.

only the destination header is supported. This feature should be available in one of the next releases.

@Paul: Yes this is one opinion to set the "Organization Top Level Domain", but in my customer enviroment is it not possible.

Enthusiast

Transform the CUCM IP(source alias)

Hi,

please try this instead (this is not really regex, it's just matching single address of 12345@1.1.1.1):

   

       

            12345@domain.com">

           

       

   

regards, Ahmad

Beginner

Transform the CUCM IP(source alias)

Hi,

can this be done via "VCS-Configuration --> Call Policy" or via "VCS-Configuration --> Dialplan --> Policy Service" ?

Actually I have only tried via the first way and it is not working.

At the second way I get all the time an "Loopback" error.

regards Jens

Enthusiast

Re: Transform the CUCM IP(source alias)

Hi Jens,

I have done it via the first option (i.e. CPL script uploaded to the server, of course the header of xml is not there which should be added).

if you need to address more source headers, just copy paste like this:

   

       

            12345@domain.com">

           

       

   

   

       

            12444@domain.com">

           

       

   

if you are getting loopback error then you have conflict in your search rule, you need to review that.

if you need further in depth assistance, please open a TAC case.

regards,

Ahmad

Beginner

Transform the CUCM IP(source alias)

Hi Ahmad

with your example it didn't match on the first entry, I modified it a little, now it works:

xmlns:taa="http://www.tandberg.net/cpl-extensions"

xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"

xsi:schemaLocation="urn:ietf:params:xml:ns:cpl cpl.xsd">

   

       

            video1@company.com">

           

       

       

            video2@company.com">

           

       

   

Many thanks to everyone

Peter

View solution in original post

Enthusiast

Re: Transform the CUCM IP(source alias)

Hi Peter,

yes I am aware of the issue of "not matching with the first entry in the script" (it's a software bug and under investigation).

if your inquiry is answered, please mark it as "answered".

Thanks, Ahmad

CreatePlease to create content
Content for Community-Ad
FusionCharts will render here