cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Walkthrough Wednesdays
1052
Views
0
Helpful
6
Replies
Highlighted
Beginner

Troubleshooting C20-isdnlink call

I have a C20 codec and an isdlink adapter with BRI lines.

I'm trying to call from C20 to a ISDN destination with "10.125.11.5;x-h320number=isdnnumber" but the call doesn't work.

In the c20 log I can see something like "unsupported gate type 3".

Can you help me?.

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Cisco Employee

Hi. Good morning.  Looking at the xcon from the link module, instead of putting the GW peer URI as the IP address, can you remove this and put this in the peer host field versus the peer URI? 

If your still having a problem placing a call after this change, log in to the ISDN Link module and run the following and capturing the output to a text file:

1)xcon

2)xstat

3)log ctx sippacket debug 9

4)log output on

5)systemtools isdntrace decode on

6)systemtools isdntrace on

7)systemtools isdntrace output on

Place SIP call from system connected to Link Module to see if the SIP call arrives on the module, and the ISDN Trace output on, we will hopefully see whats happening with the call as it goes out the ISDN network. 

Turn off logging after the call failure occurrs:

1) log output off

2)systemtools isdntrace output off

3)systemtools isdntrace off

4)log ctx sippacket debug 0

Let us know if this helps.  Thanks in advance.

VR

Patrick

View solution in original post

6 REPLIES 6
Highlighted
Cisco Employee

Hi.

1) Are you able to call endpoints?

2) The issue is isolated to audio only calls?

If yes to both, then you should modify your call-string.

Try to call from the cli:

xcom dial number: ;x-h320number=;x-h320tlph=true callrate:64 calltype:audio

//Marius

Highlighted

1) I can call others h323/SIP ip destinations.

2) This issue happens with video and audio destinations

Thanks

Highlighted
Cisco Employee

Hi. Good morning.  Looking at the xcon from the link module, instead of putting the GW peer URI as the IP address, can you remove this and put this in the peer host field versus the peer URI? 

If your still having a problem placing a call after this change, log in to the ISDN Link module and run the following and capturing the output to a text file:

1)xcon

2)xstat

3)log ctx sippacket debug 9

4)log output on

5)systemtools isdntrace decode on

6)systemtools isdntrace on

7)systemtools isdntrace output on

Place SIP call from system connected to Link Module to see if the SIP call arrives on the module, and the ISDN Trace output on, we will hopefully see whats happening with the call as it goes out the ISDN network. 

Turn off logging after the call failure occurrs:

1) log output off

2)systemtools isdntrace output off

3)systemtools isdntrace off

4)log ctx sippacket debug 0

Let us know if this helps.  Thanks in advance.

VR

Patrick

View solution in original post

Highlighted

Great! Changing the peer URI by the peer host solves the problem. Now I can make outgoing and incomming calls. Cisco should correct the documentation.

Thank You Patrick.

Highlighted

HI jlcembellin.  Which doc you referring to here?  Is it the installation guide or the Administrator guide in which we need to see about correcting?  Just want to see which one your referring to so we can see about getting it corrected or improved if you will.  Thanks for your feedback. 

VR

P2

Highlighted

Hi Patrick the documentation from Cisco web is correct, this documentation is dated July 2012. The documentation included in the box with the isdn link device (Installation Guide) makes reference only to "peeruri", this documentation is dated MAY 2012. I should have read the most recent documentation.

Thanks.

Content for Community-Ad