Showing results for 
Search instead for 
Did you mean: 

Community Helping Community


VCS and CUCM SIP Trunk Issue


We are integrating VCS Control and CUCM via SIP trunk for video endpoints registered on the VCSc and IP phones registered on the CUCM to be able to communicate.

VCS endpoints dial plan: 49xx

CUCM IP phone dial plan: 797xxxx

IP address of CUCM peers: 10.x.x.12, 10.x.x.13, 10.x.x.20, 10.x.x.23

We followed carefully the deployment guide on how to do the integration.

The problem is on the VCSc neighbor zone configuration, when setting the Neighbor zone to CUCM the zone will fail.

When setting to profile zone to Default, the zone will become active.

VCS-CUCM Neighbor Zone - failed - Copy.jpg

VCS-CUCM Neighbor Zone - 2 - Copy.jpg

Then doing test calls, calls from VCSc to CUCM fails and vise versa.

Here's the search rules configured on VCSc:

Protocol: Any

Source: Any

Request must be authenticated: No

Mode: Alias pattern match

Pattern type: Regex

Pattern string: (797\d{4})@vcs.domain(.*)

Pattern behavior: Leave

On successful match: Stop

Target: CUCM Neighbor

State: Enabled

VCSc transforms configuration:

Pattern type: Regex

Pattern string:  (.*)@(10\.x\.x\.12|10\.x\.x\.13)((:|;).*)?  and  (.*)@(10\.x\.x\.20|10\.x\.x\.23)((:|;).*)? (in another transform)

Pattern behavior: Replace

Replace string:  \1@vcs.domain\2

State: Enabled

Any suggestions?

Thank you.

Acevirgil de Ocampo

Everyone's tags (2)

VCS and CUCM SIP Trunk Issue

What is the transport field in the SIP settings set to; UDP, TCP, or TLS? My successful trunk is below, also using CUCM as the Zone Profile.

2014-02-26 14_46_48-SKCVCSControl - Edit zone.png

VCS and CUCM SIP Trunk Issue

Hi Chris,

Here's the current configuration:

VCS-CUCM Neighbor Zone - 1.jpg

Authentication policy: Do not check credentials

SIP authentication trust mode: Off



Cisco Employee

VCS and CUCM SIP Trunk Issue

Curious.  When you enable the zone configuration and save,  VCS will send OPTION to CUCM and hopefully it returns 200 OK, but may return 200 Ok with a failure code perhaps. 

Hopefully, you have a trunk configuration in the opposite direction (CUCM->VCS), cause CUCM may in turn deny you access since it doesn't know what that IP address is. 

If you turn off SIP on the zone, enable network log to debug (Maint>Diagnostics>Diagnostic Logging) and turn on SIP with CUCM zone back on, you may need to look at the OPTION ping from VCS to CUCM, and what the CUCM returns and maybe we can ascertain whats up. 



VCS and CUCM SIP Trunk Issue

Hi Patrick,

I tried to set the profile zone to Custom and now it works fine. We fully established the connection between CUCM and VCS. Calls from IP phone on CUCM to video endpoint on VCS and vise versa is working well.

Just to share the VCS configuration under Zone profile:


Thank you.

CreatePlease to create content
Content for Community-Ad
FusionCharts will render here