Showing results for 
Search instead for 
Did you mean: 
Gianluca Fedele

VCS does not accept any Release Key


our VCS stopped working and we are trying to re-install the software using the SCP procedure.

The problem is we are getting the answer "Release Key invalid".

So we did the factory-reset command but we got a similar answer:

"Failed to initialize serial number"

"Release key verification failed!"

We also tried with an older software versione with relative release key, same answer.

We checked the file /mnt/harddisk/factory-reset/rk and the release key in it is correct.

We do have root access by console;

We do not have access using admin user, we get the error "Failed to connect to TANDBERG software"

We also ran the command rkvfy using root user and we got same "Failed to initialize serial number".

It looks like the VCS "LOST" the serial number, is it possible? How can I check it or fix it?

We do not have active contract, so I can`t open a ticket with the TAC. Thanks.

Wayne DeNardi
VIP Advisor

The  file you need to add the 16 digit release key to should be /tandberg/etc/rk.

Please remember to rate responses and to mark your question as answered if appropriate.

Please remember to rate responses and to mark your question as answered if appropriate.

The rk file is correct, it is located in "/mnt/harddisk/factory-reset" folder.

The problem is the VCS try to validate the rk using the serial number, and if the VCS "lost" or "corrupted" the serial number it answers "release key invalid".

I also tried to update manually the VCS placing the files release-key and tandberg-image.tar.gz in the tmp folder, two times with two different software versions, but I got same answer "release key invalid".

Gianluca Fedele

We solved the problem!!

I`ll try to resume our job to help more customers with same problem.

First of all, the VCS was not booting because the script /etc/rc2.d/S30hwcheck was founding an hardware problem in the eth3 (missing).

It actually calls the command /etc/init.d/hwcheck, and in case of HW failure it creates the file /tmp/hwfail. During the start of services the TANDBERG service doesn`t start if the file /tmp/hwfail is present.

So we removed the hwfail file and the script hwcheck and the VCS did boot, but accessing the GUI the serial number field was empty.

It was running in the demonstration mode, with only 3 licenses, and it didn`t accept any release key.

Ok, now we know the VCS uses the eth ports or Mac Address to validate/create the serial number, if the eth ports have problem the s/n is not validated and any release key will not be accepted.

We went back to analise the ethernet port problem and see if there was a way to solve it.

Looking in internet forum we found an important information on INTEL site:

The Intel Pro 1000 NIC can loose his flash memory in same case with power problem, our VCS was running with only 3 ethernet ports (eth0, eth1, eth2) instead 4 (eth3 was missing).

The Intel site do provide a script to restore the ROM of NIC ports (bootutil64e).

Running this script according to Intel instructions restored the eth3, and with all 4 ethernet ports up the system now validate the serial number and release key.

This is our suggestion to other Cisco customers: if you have a VCS out of contract and it doesn`t boot, check all boot log using a console connection. If the problem is a missing ethernet port try the Intel script to restore ROM in the NIC, your VCS may come back alive.

Recognize Your Peers
Content for Community-Ad