cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

Webex Room Kit mini and Webex Codec plus will not update

reddsman
Beginner
Beginner

I have a webex room kit mini and a webex codec plus that will not update to a newer version.  Both devices are registered to a Cisco Expressway -C not to the Cisco cloud.  I downloaded the cop.sgn file.  It downloads to the device fine, I click on Install software.  After what a bit of time, the device says Could not install package; (ready state:0 status:0 statusText:error). Then it starts to try to update anyway.  It gets the oplock, verifies the copfile and then starts to extract the copfile before failing with installation failed.. I have other Cisco room kits and room kit mini devices that have updated fine with the same file, so I don't think it's the file.  I've tried multiple browsers.as well just to see.  I've also restarted the codecs.  I'm not sure what the next steps are.  Has anyone experienced this issue?  I thought the file was corrupted or I was downloading the wrong file.  I'm just not sure what to try.  I'd like to get them to 9.10.2 if possible.  We use webex a lot and being able to have the Webex button is a real plus.

1 ACCEPTED SOLUTION

Accepted Solutions

As per the CE9 release notes, because CE9.10.0 and later are larger files than the older software releases are able to handle, you will need to upgrade to CE9.8.2 or CE9.9.1 first before upgrading to a current (9.10+) release.

Wayne
--
Please remember to rate responses and to mark your question as answered if appropriate.

View solution in original post

13 REPLIES 13

Patrick McCarthy
Cisco Employee
Cisco Employee

What version are you running now? On occasion there have been times that to get from one version to another you have to go through some version that's in between. 

9.7.1 for both.

As per the CE9 release notes, because CE9.10.0 and later are larger files than the older software releases are able to handle, you will need to upgrade to CE9.8.2 or CE9.9.1 first before upgrading to a current (9.10+) release.

Wayne
--
Please remember to rate responses and to mark your question as answered if appropriate.

Thanks, that did it.  

Worked for me.  Thanks Wayne!!!

Wayne,

I have the same problem but the Plus is at 9.51 and I can't even get it to go to 9.62. And exactly how are we to download deferred version to make the hop when Cisco is now blocking those?!

 

9.6.2 upgrade should not be caused by the size issue. Could you try upgrading to 9.5.3 and then to a newer version like 9.6.2? 9.9.2 fixes the same issue that the deferred 9.9.1 did with the size issue. Cisco should update the documentation to reference this version since 9.9.1 is no longer available to download.

You can't download a deferred release.   You just need to use one of the later replacement releases.

You would use CE9.9.4 now instead of CE9.9.1 that I mentioned in the earlier post as the intermediate step from an old release to then be able to upgrade to one of the newer CE9.10.1+ releases.

ie CE9.5.x -> CE9.9.4 -> CE9.13.0

Note: this is only required when upgrading using the device's web interface.  If you upgrade via other methods (ie CUCM, TMS, etc) then the "1 Gb file size limit" issue doesn't apply.

Wayne
--
Please remember to rate responses and to mark your question as answered if appropriate.

gfolens
Enthusiast
Enthusiast

I'm trying to upgrade from 9.7.1 to 9.12.4 but it fails. The version 9.8.x and 9.9.x versions are deferred and cannot be downloaded anymore.

The log says:

 

2021-02-01T09:59:18.493+01:00 appl[1471]: SoftwareUpgrade I: Result from installimage: 'ERROR Failed finding package to install'
2021-02-01T09:59:18.493+01:00 appl[1471]: SoftwareUpgrade[0]: [4131070576] SWUH::setNotification() {t0,s1,p0,afalse,h1,dfalse,pMtrue,tT0,iSfalse,iDfalse} type=3, text='ERROR Failed finding package to install'
2021-02-01T09:59:18.493+01:00 appl[1471]: SoftwareUpgrade[0]: [4131070576] LFH::setNotification() {tQfalse,dfalse,insfalse,rCT0,iT60,afalse,ppfalse,psfalse} type=3, text='ERROR Failed finding package to install'

Open TAC case to request CE9.10.  I got lucky and had CE 9.8 and CE9.10 so we could step it up to 9.14

 

unfortunate 9.7 requires a step upgrade.

I was trying to upgrade from 9.6.2 to 9.15.0.11.

CUCM version of upgrade worked for a few Webex Room Kit Pluses. But not for 2 of them.

Deferred versions 9.9.x were not available for download so I've found that I can download small enough .pkg file from my CUCM and upgrade not upgrading WRKPs directly. URL is 

http://<your_cucm>:6970/s53200ce9_15_0_11-aec227943ed.pkg

These nice .pkg files get created on CUCM.

No step upgrade was needed.

 

HTH

Richard 

Word of caution when using the .pkg file as that does not also update the camera and peripherals.

Found this nice note when either searching for something on the interweb or possibly looking at some recorded session from Cisco Live, at the moment I can't for the life of me recall what it was.

There is a good workaround to this that can be used and many admins controls or knows how to set up a HTTP server (which can also be done on your workstation).

1. If you have a web server (Apache, Nginx, IIS or similar in your network that has connectivity to the device), you can put the software on that web server and push the command:

Your web server (maybe hosting other files as well, this can be used as a resource for upgrading)

xCommand SystemUnit SoftwareUpgrade URL: http(s)://<yourcustomhttpserver>/<filename>.k9.cop.sgn

2. If you have a CUCM or TMS, these should be used to manage upgrades regardless, but if you are not you
can use them as a hosting resource for the files:
xCommand SystemUnit SoftwareUpgrade URL: http(s)://<yourtmsserver>/public/<pathtofile>/<filename>.k9.cop.sgn

CUCM can also be used as a http server resource, but if you have a CUCM, you should be using it to manage
the software upgrades anyway:

xCommand SystemUnut SoftwareUpgrade URL: http(s)://<yourcucmserver>:6970/s53300ce9_15_0_11-aec227943ed.loads
The loads file contains pointers to the whereabouts of the peripheral software. The device will download the software
based on what it has connected.

Or (but careful):
xCommand SystemUnut SoftwareUpgrade URL: http(s)://<yourcucmserver>:6790/53300ce9_15_0_11-aec227943ed.pkg

Careful with upgrading using PKG files as this will cause camera upgrades and peripheral upgrades to fail.
This can be fixed by upgrading again using the cop file. For older devices, the peripheral software is included
in the pkg.

To check the status of the upgrade process use this command, xStatus //Upgrade.

 



Response Signature


Wayne DeNardi
VIP Advisor VIP Advisor
VIP Advisor

Cisco have released a StepUpgrade package for the RoomKit series devices that can now be used as well as an intermediate step 

 

https://software.cisco.com/download/home/286316402/type/280886992/release/CE9.15.6%20StepUpgrade

 

You can upgrade from your earlier release to this StepUpgrade version, then up to the RoomOS 10 version you need.

Wayne
--
Please remember to rate responses and to mark your question as answered if appropriate.
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: