cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

Open Automation Module for Managing Nimble Storage (NOT AN OFFICIAL NIMBLE PLUGIN)

2276
Views
1
Helpful
10
Comments

Task Name

Open Automation module for controlling Nimble storage via its RESTful API (NOT AN OFFICIAL NIMBLE PLUGIN)

Description

Prerequisites

Minimum UCSD version: 5.4.0.0

Category

Open Automation Module for Nimble Storage

Components

User Inputs

User Output

Instructions for Regular Workflow Use:

Instructions for Regular Workflow Use:

  1. 1 Download the attached .ZIP file below to your computer. *Remember the location of the saved file on your computer.
  2. 2 Log in to UCS Director as a user that has "system-admin" privileges.
  3. 3 Navigate to "Administration->Open Automation" and click on "Add           ".
  4. 4 Click "Browse" and navigate to the location on your computer where the .ZIP file resides. Click "Upload".
  5. 5 Once file is uploaded, Click "Submit".
  6. 6 Highlight the newly installed module and click ‘enable’.
  7. 7 Click "Submit".
  8. 8 Restart UCS Director services for the new module to be loaded.

After following the instructions above, the following plugin should show in the UCS Director GUI:

Screen Shot 2016-02-25 at 12.10.24.png

Once installed, the following orchestration workflow tasks will be available:

Screen Shot 2016-02-25 at 12.13.27.png

Running the 'Nimble Get Inventory' workflow task will dynamically create a list of values (LOVs) for your array that can be used to provide drop down selectors in your other workflow tasks.

Edit Workflow Input Types:

Screen Shot 2016-02-25 at 12.17.24.png

These can now be used to enhance your workflows:

Screen Shot 2016-02-25 at 12.19.39.png

UPDATE 18th April 2016: I've replaced the slimcea module with a more official looking Nimble module. The attached file feature-nimble-genericstack-1.0.0.zip is a REPLACEMENT for the slimcea module. If you currently have the slimcea module installed and running, you will need to delete it BEFORE you load the nimble module. The new module has nicer icons, no mention of the the word slimcea and the the ability to add a Nimble array to a Generic type pod as well as a SmartStack.

Unknown.png

UPDATE 15th June 2016: I've modified the Create Volume task to retrieve the dynamic IQN for iSCSI arrays and set as a task output. This can be found in feature-nimble.1.0.2.zip

Comments
Cisco Employee

I installed the open automation plugin , I was start to write a workflow to do a boot from san and create zones for bare metal servers but seems the plugin doesn’t bring the WWPN addresses when I use the GEN Storage FC Adapter list INPUT on UCSD, the other WWPNs from other storage arrays are visible , but the ones from nimble are not. Any suggestions on how to solve that problem?

If i don't get the WWPN Target addresses i can't zone the servers

Regards

Cisco Employee

Hi there,

Eventually, I will write in a full inventory that will allow this process. In the meantime, would a 'Get WWPN' workflow task suffice? If so, I'll write one for you.

Regards

Russ.

Cisco Employee

Actually what i'm trying to build is a workflow to build Bare metal machines that boot from SAN , to do that i need to build a ZONING first , and i need to know the targets , when creating the workflow there's an INPUT called "Generic Storage FC Adapter list" , so i can check the list of targets i want, it shows only the targets associated to other arrays that are configured in my POD , but the ones that belong to nimble don't show up.  If you have 5 mins i can show you. But i think that task you mentioned would work fine.

Beginner

Hi

I have installed the 5.4 modules and i can create/delete a volume etc. I can find the LOV's but no information about the san when i click in the POD and on Nimble san - is this to be expected?

thanks

Cisco Employee

I believe so. Russ just wrote the integration not all the screens.

Enthusiast

Hello Russ and Orf,

 

I installed the Nimble open automation in my environment some time ago. We've since upgraded to UCSD 6.5. Now, when I run Get_Inventory, I am getting the following error:

 

Aug 01, 2018 22:15:44 UTC httpClient.executeMethod(): java.security.AccessControlException: access denied ('java.net.SocketPermission' 'localhost:0' 'listen,resolve')

 

I have tried updating my Java Security Policy, but it seems to have no impact. Have either of you tested on 6.x?

 

Thanks

Cisco Employee

try putting this task before the offending task with user = admin

https://community.cisco.com/t5/ucs-director-documents/change-workflow-user/ta-p/3642185

then after that set user = ${INITIATING_USER}

Enthusiast

Thanks Orf. I realized I was using the Nimble supported version 1.1.0 and not 1.0.1. I disabled 1.1.0 and the task seems to be completing with 1.0.1.

 

Thanks again

Enthusiast

Hi Orf,

 

Whereas the Get_Inventory process appears to run, it does not successfully collect the inventory. I tried using the 5.4 tasks from your contribution below, but now am getting the socket permission issue, even when running the change_user task ahead of get_inventory.

 

https://community.cisco.com/t5/ucs-director-documents/ucsd-cisco-russ-nimble-integration-ucsd-5-3-2-5-4-0-0-tasks/ta-p/3635210

 

Thanks

Cisco Employee

I sent this question to Russ.. 

 

Content for Community-Ad
This widget could not be displayed.