cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
466
Views
0
Helpful
2
Replies

Cisco 7960/7960G and UCCX 10.6 device associated with extension is invalid

stevepnoble13
Beginner
Beginner

Hi all,

A few weeks ago, my company had to update our security certificates on our UCCX 10.6 server, as our previous ones had expired. Since then, we've had sporadic reports of users being unable to log into their Finesse dashboard because of an invalid device associated with their extension. I believe that this may be related to the fact that the 7960 phones went end of support in July so therefore the new security certificate is causing issues with the phones. It's not on every 7960 phone in a call center, but it's not shown up with any other models either. We're also running CUCM 10.5.

Symptoms are as follows:

- The agent extension appears on a 7960/7960G

- The agent can log in, and the finesse web dashboard will accept the credentials, and begin the login process.

- The login process will be interrupted with an error message of "The device associated with the extension is invalid" and will abort.

I have tried the following,(not in this order):

- disassociating the line appearance with the phone

- removing, then replacing, the agent ID on the end user profile

- re-adding the user into UCCX

- deleting, and rebuilding, the DN

- deleting, and rebuilding, the entire phone config for the 7960

- applying a "no IPv6" phone configuration - which I found a bug report on

- Building an entirely new extension on the phone

- Performing a factory reset on the phone

Full disclosure: I may have done other troubleshooting steps than these but forgotten to mention them. Please don't take offense if you suggest something and I've already tried that.

Of 5 or 6 occurrences, I have only managed to get the user's problem fixed once, and that was after trying all of the above options multiple times. What's interesting is that if I place the same extensions on a 7965, I don't get the error, even if I only change the physical phone.

A search through the bug tool and support forums yielded no result for me aside from the "No IPv6" bug, which seems unlikely, since to my knowledge, nothing in our network is configured for IPv6 (I've only been at my current job for 3 months). Certainly, our CUCM is only working in IPv4.

If anyone's had similar issues or been able to track this down, please share your experience.

2 Replies 2

Deepak Rawat
Cisco Employee
Cisco Employee

I do not even see that as supported phone models to be used with Finesse. Refer to below Comaptibility Matrix:

http://docwiki.cisco.com/wiki/Unified_CCX_Software_Compatibility_Matrix_for_10.6%281%29

Hence, you can try doing below three things in the order mentioned below:

1) Go to CCX >> Cisco Desktop Adminstrator (Web Based) and perform a Manual Synchronization of Directory Services as per the attached screenshot

2) Match the firmware version of non working phones with the working ones (in case if Finesse login works for any of 7960/7960G in your setup) and if they are not same, try upgrading it

3) Restart CTI Manager on CM side for all the servers in cluster i.e., Publisher and Subscriber followed by CCX Engine restart

Point 2 and 3 should strictly be done in after hours as it requires the restart of CTI Manager, CCX Engine and TFTP service that are service impacting.

Below is a very good Cisco document on CAD login issues for your reference. Make sure that you have configured the agents that way only:

http://www.cisco.com/c/en/us/support/docs/customer-collaboration/unified-contact-center-express/200129-Troubleshoot-CAD-and-Finesse-Desktop-Log.html

Regards

Deepak

- Rate Helpful Posts -

Thank you for the links and suggestions. I'll try them and see what I can find.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: