Showing results for 
Search instead for 
Did you mean: 

Connection 10.5 Media Master Headache

Level 4
Level 4

Unity connection 10.5 and I have been battling with this for days. Juggling browsers. adding exceptions in Java etc. Finally get the recording to load into the media master and now cannot save. SSL certificate error, failed to record name. Hmm that is strange seeing that all of my certificates are up to date.

You know this has always been the biggest headache. Can we please come up with a better way to load greetings? How about starting with not using the bug infested Java!

Does anyone know a better way to get greetings loaded into Unity Connection? I have several call handlers that need updating and due to this war against Java they are overdue. 

16 Replies 16

Terry Cheema
VIP Alumni
VIP Alumni

I had a similar problem which I managed to resolve by adding the SSL certificate from CUC into the root store and then used the URL in the cert to visit the CUC GUI that did let me save. 

If you haven't already tried.


Please rate helpful posts

This still isn't working.  I installed the certificate, used the link within the cert and I still get an SSL issue and if I hit ok to accept it I get a "Failed to record name".  Uploading a file doesn't work either, says its corrupt which is garbage as it works fine.....  This is extremely frustrating to have to assign a phone call handler just to get the job done...

Set the security level to medium and disable verification for 'Mixed code security verification'.


An alternate option is to use the Audio Text Manager Tool,

Tool Help File,

Medium security level is not an option on Java 8.......   Also, I've already disabled mixed code verification.

Java 8 is not supported with Unity Connection yet. You need to downgrade to Version 7 or 6.

Some versions i've tested and works fine - Java 7 Update 51, J7U53. J6U15, J6U21, J6U35.

I believe the documents recommend J7U71 or J7U73. You can try with one of these versions. In case you still face issues, open a TAC case. The BU can be involved to get the issues fixed in the latest version of Java 7.

Right.  Also, if you install the 64bit version and your modern browser does not seem to recognize it, try a 32bit version instead.

Download and installed ATM tool and connected just fine. However when I tried to save the file I get the error:


"Error uploading WAV file for greeting to the remote server in btnRecording_Play_Click"




Try turning off Windows firewall and then upload.

I also highly recommend the Auto Text Manager. Java's downward spiral of buggy, death-by-security prompt failures is one of the top five time-wasting elements of UC work. The next is Cisco bugs ... but I digress.


Cisco, please get rid of Java dependency.

I downgraded Java to several different versions and could not get the recording to save. I even saved current recording, then tried to "open file" and save the original back, but still got same error. I found this post after working on this for a few hours this morning. As others here have stated, save yourself some time install the Informix ODBC Drivers and use ATM! Thanks for the links Anirudh.

Richard Simmons
Level 3
Level 3

I've been battling the same issue for a past few days, only way ive got them to upload is by using Internet Explorer, as you've mentioned you need to add the exceptions in java, both https://ipaddress and https://ipaddress:8443

Also once the greeting has uploading, prior to clicking save press play and listen to the prompt via the computer, i know it sounds strange but it seems to allow me to save it if i first play the prompt.

Good luck!

I ended up just typing what I wanted the call handler to say.  The audio file recorded from unity connection on another box works but won't save.  No matter what I do to my browser, java, or anything else, it just doesn't work.  The user is going to record what they want it to say in the end via phone anyway so it doesn't really matter I guess.  I just hate having options that flat out don't work because of Java.

So I built a windows XP machine and wow worked right away first try no issue. It is safe to say that this tool needs to be evaluated, clearly it is out of date.

Level 1
Level 1

Agreed.  Enough of the outdated and vulnerable Java already.  We really need this code to be rewritten to use only HTML 5.  

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: