Showing results for 
Search instead for 
Did you mean: 

CUC Upgrade from 8.6.2ES44.22900-44 to failing


I am working with a TAC engineer on a DNS issue with CUC/Office 365 integration.  The CUC version we are running is not Office 365 compatible, so he wants me to upgrade to a version that is.  I have tried to upgrade to 2 different patches and i get the same result:

"Error encountered: An unknown error occurred while accessing the upgrade file"

I've attached the output from the installation log.  Any help is appreciated!

10 Replies 10

George Thomas

It looks like the MD5 hash is not correct. have you validated the MD5 hash of the download against Cisco's website?

Please rate useful posts.

Please rate useful posts.

Sorry for the late response on this.  I really think the TAC engineer is heading down the wrong path on this one.  When testing the Unified Messaging Account on a users mailbox, I get the following:

In the Unified Messaging Service, if I change the "Hosted Exchange Server" field to an IP address instead of, all tests pass.  This tells me that the CUC version we are on supports Office 365 or it wouldn't work with an IP address.  Also, would I even be able to build a service for Office 365 if it was supported?  Doesn't make sense to me.

Can you see if a DNS resolution works in CUC? You will have to try that from the CLI using "utils network host" commands.

Please rate useful posts.

Please rate useful posts.

Here is the output from that command:

admin:utils network host
Local Resolution:
Nothing found

External Resolution: is an alias for is an alias for has address has address has address has address has address has address has address has address has address has address has address has address has address has IPv6 address 2a01:111:f400:2c2a::9 has IPv6 address 2a01:111:f400:2c2a::2 has IPv6 address 2a01:111:f400:83e::2 has IPv6 address 2a01:111:f400:83e::6 has IPv6 address 2a01:111:f400:2c2a::6 has IPv6 address 2a01:111:f400:83e::9 has IPv6 address 2a01:111:f400:c04::12 has IPv6 address 2a01:111:f400:400::9 has IPv6 address 2a01:111:f400:854::6 has IPv6 address 2a01:111:f400:c16::6 has IPv6 address 2a01:111:f400:400::2 has IPv6 address 2a01:111:f400:400::12

So it looks like my CUC is trying to connect to the IPv6 addresses for some reason instead of the IPv4 addresses.  I've confirmed that IPv6 is disabled on CUC.

Hi Jafetters,

Were you able to resolve the ipv6 address issue?

I am having the same issue on my CUC 9.1.2 box.


Hello Jafetters,

Bottom line issue is that Unity Connection is trying to connect to an IPv6 address, however this is because the first address that Microsoft is returning is IPv6 rather than IPv4.

Patches won't work on this matter you need to jump to CUC 9.x where IPv6 is supported or get Microsoft to make some changes on their DNS.

I would also like to add:

Release Notes for Cisco Unity Connection Release 9.0(1)

Support for Internet Protocol Version 6 (IPv6)

"Beginning with Connection 9.0(1) release, Cisco Unity Connection supports IPv6 for web based integration including Cisco Unity Connection clients, web interfaces, and Exchange integration. "

Best regards,

David Rojas Peck.

Message was edited by: David Rojas

We are having the same issue as well. A Cisco Support engineer recommended we upgrade to today stating it would take care of the IPv6/Office 365 issue. I see David mentions 9.0(1) is the only way we can remedy this. Has anybody had any luck with the latest ES?

I upgraded to 8.6.2ES84.24091-84 and it resolved the issue.  We have been using Single Inbox with O365 with no issues since.

Adam Thompson

I am pretty sure 8.6 will connect to Office365 just fine, even when Office365 is using IPv6.

Check the following in Unity Connection:

System Settings > General Configurations > IP Addressing Mode

     By default this is set to IPv4 only. Change this to 'IPv4 and IPv6' and restart the Conversation Manager service.

Edit: Apparenlty I didn't read the thread fully. Please disregard and carry on with your day



Message was edited by: Adam Thompson

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: