Showing results for 
Search instead for 
Did you mean: 


Level 1
Level 1


I’ve problem with CUCM 11.5(1)SU2 and CCX 11.5(1)SU1,

During intergration of CCX with CUCM system returns an error „Cisco Unified CM Authentication Failed because of CCMAXL Exception”,

Service „Cisco AXL Web Service” and others on CUCM are active.

What is the reason of this error?

I have the same error on 11.0(1a)..

11 Replies 11

Level 1
Level 1

Have you made the AXL user a member of the Super Users group in CUCM?


Chris Deren
Hall of Fame
Hall of Fame

What roles is the AXL user assigned to?  You need to make sure it has the AXL API role assigned, no need for this user to be a superuser, in fact that is not recommended due to security risk. 


I had exactly this same error with the application user configured with AXL API role assigned and after I made them also a member of the super users group, it worked.

The AXL Admin user name must not be the Unified CM Administrator username. In case you specify a user name other than the Unified CM Administrator username, add the user name of the AXL Administrator to the Standard Unified CCX Administrators group and "Standard AXL API Access" roles in Unified CM.


In CUCM 11.5(1)SU2, with the AXL admin user configured as with the Standard AXL API Access role only, you get the error in the original post.

"Standard Unified CCX Administrators group" does not appear to exist in this version of CUCM. It may exist in v9 which the document you linked refers to, but the original post relates to 11.5(1)SU2.

For a list of the groups in 11.5, see the attachment

With only Standard AXL API Access role assigned to the AXL admin user you get the error in the original post. If you also add the user to the Super Users group, you do not get the error.

This may be a new feature or requirement in v11. I'm not commenting on what may or may not be best practice as recommended at any point in time, I'm just trying to help someone stuck at the same point I have been in the past.

You need to create the group, there is no default AXL user group by default on any version, only the AXL API role, which needs to be added to new group.


Thanks for clarifying Cisco's documentation. It seems the original post arose from the documentation not being clear. Can you clarify how creating a new group for the user and putting them in it will give them more access rights than having the role assigned to them?

I agree, I had to add the super user role. However, I had no success until restarting the Cisco ACL Web Service in CM Servicability

I just faced this problem. The way I fixed this thing is change the password. At first I use "123456" after I changed it to "P@ssw0rd". It can continue to integrate with CUCM. Not sure it can work with your system, but not difficult to try. Good Luck everyone.

Level 1
Level 1

Can anyone confirm whether this is happening due to the bug CSCvd56174?

As per the bug documentation, if you are using self-signed certificates in CUCM, you are not affected.



Libin Benedict

Level 1
Level 1

Go to End-user

select user created for uccx

then go down and add permission

standard ccm admin user

standard cti enabled