cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
25341
Views
10
Helpful
28
Replies

Exchange 2013 UM and CUCM 8.6

Daniel Appleby
Level 1
Level 1

Hi All,

I am having some difficulty setting up a direct sip connection from Callmanager 8.6 to Exchange 2013 UM and want to know if anyone has encountered this or has a solutions. See below:

I am following the exchange 2010 guide as a starter: http://go.microsoft.com/fwlink/p/?linkId=213007

I have the trunk pointing at the CAS 2013 server (which does the SIP 302 redirection to the mailbox server). The behaviour I am seeing is CUCM sends the INVITE to exchange 2013 CAS and it responds with a 302 and the XXXXX@mailbox-server.fqdn (and port) in the contact info in the header. At this point CUCM doesn't even attempt to contact the mailbox server.

From my troubleshooting it seems to want to handle it as a URI so after creating another trunk to the mailbox server and setting up a remote destination the call makes it to the mailbox server but stripps the caller extension in the INVITE.

Is there anyway in the trunk config to get it to follow the URI redirect (i.e. connect to the FQDN and port given in the header)? Having to make seperate trunks to each mailbox server would result in a lot of trunks.

It seems that if the response was XXXXX@ipaddress in the header from the 302 the redirect would work correctly, but exchange returns XXXXX@fqdn

Thanks in advance

Regards,

Daniel

28 Replies 28

Per our setup:

For the SIP Security Profile, your CM listens for your Exchange servers on 5060 and you should be able to use the same profile for both trunks.

For the SIP trunks, the CAS service listens on 5060 and the mailbox service listens on 5062.

In CAS SIP Trunk settings on one trunk I have this


I am trying to create Mailbox server trunk with following settings


and I am getting error

SIP Security profile

when I am trying to save the trunk

in the example CAS and Mailbox server rolls are combined (same as what we have)

but its not possible in CCM to create 2 trunks to the same server (with different destinatino ports) with same SIP security profile , because CCM listens on port specified in SIP Security profile

I encountered the same issue as this post on my own CUCM 8.6 and Exchange Server 2013 CU2 environment.

Then, according to Daniel's work-around, I could successfully solve it, while I don't really know

the root cause of it especially whether it is design or not...

At any rate, Thanks!

Daniel Hi

I posted  above a problem I am comming acros while stepping through your instruction on CUCM9.1.2. (Did you test it on CUCM9 ?)

Thanks

I am having the same error "Both have the same Incoming Port "5060" and hope someone can help.

We are runing CM 9.1.2 & Exch2013

There are two trunks. The 1st trunk points to the CAS server using it's IP address and destination port of 5060.

The CAS server redirects to the UM server via a CONTACT header it sends back to CM, the contact header contains the UM servers FQDN, not it's ip address.

So now CM needs a SIP route to the UM server. (This is the FQDN of your UM server)

The 2nd trunk ponts to the UM server using it's FQDN, and destination port 5062.

Below is needed on the SIP profile to assure that SIP routing is used.

We have a single SIP Security Profile that both trunks use, and it listens on 5060.

These steps worked a treat for me this morning.

Thank you very much

5*

I started with Exchange UM and CUCM back in Exchange 2007, then migrated to Exchange 2010 with no real trouble. When trying to get to Exchange 2013, though, it all hit the fan. Even once I updated my existing SIP Trunk with the 2013 mailbox server and port 5062 there was up to a ten-second delay from the time I pressed the messages button until Exchange 2013 answered.

After following your steps, Daniel, the delay is gone. Thank you very much for your terrific step-by-step directions! I truly appreciate it!

David

I have the trunks and the SIP route pattarns created just as Daniel post. You press the messages button on the phone it works great.

My problem:

If you call the pilot number from a phone that has no voicemail associated, the Exchange will prompt for extension (that is good). Once you enter a valid extension, Exchange will ask you again to enter your extension, this time when you enter the extension it works. What I think is happening is the request first goes to CAS Exchange server , it sends a refer back to CUCM to go to server 3 that has the user mailbox but CUCM sends a request to server 2 instead ignoring the refer and then goes server 3. So we get double prompts to enter extension.

Has anyone exprerence this? Is there a fix?

Thanks,

Solomon

Hi Solomon,

I'm having the same issue, have you made any progress with this?

Thanks,

Mat

According to Cisco TAC we are hitting this bug

https://tools.cisco.com/bugsearch/bug/CSCtf35144

I will upgrade to one of the fixed releases and see if that will fix the issue.

Solomon

 

Solomon

I am hitting the same issue, did you manage to fix it by upgrading? I have an upgrade scheduled for Q2 this year though the exchange team have just upgraded to 2013 and we have hit this bug!

I appreciate any help, I have implemented using Daniels notes above including using SIP routing for the mailbox servers. I am running CUCM 8.6.2.23900-10

If anyone from Microsoft is reading this please update your documentation as it's not "just the same as 2010".

We hear you.  :)  Working on it... 

for info:

The name field in ip gateway definition in MS Exchange 2016 must contains the ip address of the CUCM. Otherwise, an error - 

ms-diagnostics-public: 15602;source="EXCH-01.test.com";reason="The Unified Messaging server is not authorized to accept calls from this SIP peer."

p.s. Take tcpdump from Exchange server with "netsh trace" command and analyze it with MS Network Monitor.

p.s. My environment - Exchange 2016 and CUCM 11