cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
221
Views
0
Helpful
0
Replies

Extension Mobility problem

Translator
Community Manager
Community Manager

Greetings everyone,

I am having difficulties applying the Mobility extension and making external calls.

Highlighting that when I log in I can make internal calls, but not external calls. I don't know, it's because of the corlist applied to dn to prevent certain extensions from making external calls.

At that moment I applied corlist which allows external calls to only two extensions, the rest cannot be made.

Then I applied Extension mobility to one of these extensions with permission to make external calls and out of nowhere it stopped making external calls. And I can't see the option to use corlist in voice logout.

Does anyone have a tip for me?

Next is the used and functional script.

 


CUCME#sh run
Building configuration...

 

Current configuration : 32439 bytes
!
! Last configuration change at 10:26:36 GMT Mon May 6 2024 by ohilario
!
version 15.7
service timestamps debug datetime msec localtime
service timestamps log datetime local
service password-encryption
service sequence-numbers
!
CUCME hostname
!
boot-start-marker
boot system flash0:/IOS/c2900-universalk9-mz.SPA.157-3.M8.bin
boot-end-marker
!
!
logging buffered 10000
no logging console
no logging monitor
enable password 7 13061E010803
!
aaa new-model
!
!
aaa authentication login default group tacacs+ local
aaa authentication login h323 group tacacs+ local
aaa authentication enable default group tacacs+ enable
aaa authorization config-commands
aaa authorization exec default group tacacs+ local
aaa authorization exec h323 group tacacs+ local
aaa authorization commands 0 default group tacacs+ local
aaa authorization commands 15 default group tacacs+ local
aaa authorization network h323 group tacacs+ local
aaa accounting exec default start-stop group tacacs+
aaa accounting commands 0 default start-stop group tacacs+
aaa accounting commands 15 default start stop group tacacs+
!
!
!
!
!
!
aaa session-id common
clock timezone GMT 1 0
!
!
!
!
!
!
!
ip traffic-export profile
bidirectional
!
!
!
ip dhcp excluded-address 10.10.10.1
ip dhcp excluded-address 10.9.200.250
!
ip dhcp pool CUCME
network 10.9.200.0 255.255.255.0
option 66 ip 10.9.200.254
option 150 ip 10.9.200.254
default-router 10 September 200254
dns-server 8.8.8.8
lease 10
!
!
!
ip domain name CME.COM
ip name-server 8.8.8.8
ip name-server 4.4.4.2
cef ip
in cef ipv6
multilink bundle-name authenticated
!
!
!
!
!
!
crypto pki trustpoint TP-self-signed-4067579559
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-4067579559
revocation-check none
rsakeypair TP-self-signed-4067579559
!
!
crypto pki certificate chain TP-self-signed-4067579559
certificate self-signed 01
3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
69666963 6174652D 34303637 35373935 3539301 AND 170D3134 30383139 31383334
30325A17 0D323030 31303130 303030 305A3031 312F302D 06035504 03132649
4F532D53 656C662D 5369676E 65642D43 65727469 6696361 74652D34 30363735
37393535 3930819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
8100A0F3 7BD36DF3 697812E2 B4AF5F1C 3C0DEFA2 69CEA5D5 432726F2 8E656A3F
BC4EC98A B6487257 5C00B65A 1B264DA3 3F756B6B 03F18A18 4B350722 E9FB8CD6
396526A7 827F76C2 C2FDE4C5 1B393F38 102E29C7 BDC0C447 AFBD96CF 302AF50F
B79E2210 229757B9 983AB527 8D628CB3 314D25AA BFBB9316 F612F5E6 3B2158FE
89ED0203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603
551D2304 18301680 14D05DF1 DFC95131 1B14773F 445BFF9D 0C32C083 28301D06
03551D0E 04160414 D05DF1DF C951311B 14773F44 5BFF9D0C 32C08328 300D0609
2A864886 F70D0101 05050003 81810061 0A2C2498 C0AC4384 383DA89D 28B42804
3C617C98 EC92C791 526D18DB 5BDAE3BA 949418CF AE92117C 0A6D999A 71059E3C
AB6F642B 86CF7297 F0D238FC 9E1C670B 39DE3D32 AE136C33 F078F8B4 0471B39C
E5430B84 C8D472CC B4990B06 ECF5DE22 6405417B 9E270FAC F703CDF6 D28970DA
F1C5EC3F 606CE056 F84BEC
(PHP 3, PHP 4)
voice-card 0
!
!
!
voip voice service
ip address trusted list
ipv4 10 September 200254
ipv4 10.10.10.1
ipv4 172 16 22 111
ipv4 192 168 50 211
allow-connections h323 to h323
allow-connections h323 to sip
allow-sip connections to h323
allow-sip connections to sip
supplementary-service h450.12
no supplementary-service h225-notify cid-update
no supplementary-service sip moved-temporarily
no supplementary-service sip refer
no supplementary-service sip handle-replaces
fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
h323
h225 timeout setup 4
sip
bind control source-interface GigabitEthernet0/0
(PHP 3, PHP 4)
error-passthru
register server expires max 600 min 60
no update-callerid
early-offer forced
midcall-signaling passthru
privacy-policy passthru
g729 appendib-all
!
voice class codec 1
codec preference 1 g711alaw
g711ulaw codec preference 2
codec preference 3 g729r8
!
voice class codec 2
g711ulaw codec preference 1
g711alaw codec preference 2
codec preference 3 g729r8
!
voice class h323 1
h225 tcp timeout establish 3
!
!
voice logout-profile 1
pin 2024
user 701 password 2024
701 type normal
!
voice logout-profile 2
pin 12345
user 700 password 12345
number 700 type normal
!
voice user-profile 1
pin 2024
701 type normal
!
voice user-profile 2
pin 12345
number 700 type normal
!
voice lpcor enable
custom lpcor voice
group 10 Password
group 12 Analog
!
voice lpcor policy Password
service fac
accept Fac Password
accept Analog fac
!
voice lpcor policy Analog
service fac
accept Fac Password
accept Analog fac
!
!
voice translation-rule 1
rule 1 /^924133453/ /701/
rule 2 /^924164456/ /609/
rule 3 /^924164456/ /700/
!
voice translation-rule 2
rule 1 /700/ /924133453/
rule 2 /6./ /924164456/
rule 3 /701/ /924164456/
!
!
in-ISP voice translation-profile
translate called
!
(PHP 3, PHP 4)
translate called
!
voice translation-profile out-ISP
translate calling 2
!
(PHP 3, PHP 4)
translate called
!
!
!
!
application
auth package
param passwd-prompt flash:enter_pin.au
param abort-digit *
param passwd 12345
param term-digit #
param user-prompt flash:enter_account.au
param max-digits 32
!
!
vxml logging-tag
license udi pid CISCO2911/K9 sn FCZ1834605Z
hw-module pvdm 0/0
!
hw-module pvdm 0/1
!
!
!
username test privilege 15 secret 5 $1$nIpR$X9HJip5m3sJ/.IbbezKeJ.
username cisco privilege 15 password 7 05080F1C2243
username Password privilege 15 password 7 13262231262949061E0B651E1C0C32
username cmecisco privilege 15 password 7 121A081211021F0725
username support privilege 15 password 7 13360202041E107926752632
!
redundancy
!
!
!
class-map match-all VoIP
match dscp ef
class-map match-all Management
match access-group name Management
class-map match-all Signaling
match dscp af11
!
policy-map 128k-LLQ
class VoIP
priority
class Signaling
bandwidth 8
class Management
bandwidth 8
class class-default
fair-queue
random-detect
!
gw-accounting aaa
!
gw-accounting file
primary ftp 10.9.200.X/cisco/ username cisco password 7 05080F1C2243
secondary ifs flash0:/CDRCISCO
maximum buffer-size 15
maximum retry-count 3
maximum fileclose-timer 200
!
!
!
!
Embedded-Service-Engine0/0 interface
no ip address
shutdown
!
GigabitEthernet0/0 interface
description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$
ip address: 10.9.200.254 255.255.255.0
auto duplex
speed auto
!
GigabitEthernet0/1 interface
ip address: 172.16.22.111 255.255.255.0
auto duplex
speed auto
!
GigabitEthernet0/2 interface
description ###_SIP_TRUNK_ISP_###
ip address 10.1.1.2 255.255.255.252
auto duplex
speed auto
!
ip forward-protocol nd
!
http server ip
ip http authentication aaa
http secure-server ip
ip http path flash0:\GUI
!
ip tftp source-interface GigabitEthernet0/0
ip route 0.0.0.0 0.0.0 172.16.22.1
ip route 10.9.200.0 255.255.255.0 GigabitEthernet0/0
!
!
!
snmp-server community testRO Password
snmp-server contact suporte@teste.net
tftp-server flash0:/phones/7911
tftp-server flash0:/Phones/7911/apps11.9-4-2TH1-1.sbn alias apps11.9-4-2TH1-1.sbn
tftp-server flash0:/Phones/7911/cnu11.9-4-2TH1-1.sbn alias cnu11.9-4-2TH1-1.sbn
tftp-server flash0:/Phones/7911/cvm11sccp.9-4-2TH1-1.sbn alias cvm11sccp.9-4-2TH1-1.sbn
tftp-server flash0:/Phones/7911/dsp11.9-4-2TH1-1.sbn alias dsp11.9-4-2TH1-1.sbn
tftp-server flash0:/Phones/7911/jar11sccp.9-4-2TH1-1.sbn alias jar11sccp.9-4-2TH1-1.sbn
tftp-server flash0:/Phones/7911/SCCP11.9-4-2-1S.loads alias SCCP11.9-4-2-1S.loads
tftp-server flash0:/Phones/7911/term06.default.loads alias term06.default.loads
tftp-server flash0:/Phones/7911/term11.default.loads alias term11.default.loads
tftp-server flash0:/Phones/7912/cmterm-7912-8.0.0-sip.cop alias cmterm-7912-8.0.0-sip.cop
tftp-server flash0:/Phones/7940/P00308010200.bin alias P00308010200.bin
tftp-server flash0:/Phones/7940/P00308010200.loads alias P00308010200.loads
tftp-server flash0:/Phones/7940/P00308010200.sb2 alias P00308010200.sb2
tftp-server flash0:/Phones/7940/P00308010200.sbn alias P00308010200.sbn
tftp-server flash0:Phones/7912/Sip/bmp2logo.exe alias bmp2logo.exe
tftp-server flash0:Phones/7912/Sip/cfgfmt.exe alias cfgfmt.exe
tftp-server flash0:Phones/7912/Sip/cfgfmt.linux alias cfgfmt.linux
tftp-server flash0:Phones/7912/Sip/cfgfmt.sun alias cfgfmt.sun
tftp-server flash0:Phones/7912/Sip/CP7912080001SIP060412A.sbin alias CP7912080001SIP060412A.sbin
tftp-server flash0:Phones/7912/Sip/gkdefault.txt alias gkdefault.txt
tftp-server flash0:Phones/7912/Sip/prserv.exe alias prserv.exe
tftp-server flash0:Phones/7912/Sip/prserv.linux alias prserv.linux
tftp-server flash0:Phones/7912/Sip/prserv.sun alias prserv.sun
tftp-server flash0:Phones/7912/Sip/Readme.txt alias Readme.txt
tftp-server flash0:Phones/7912/Sip/sipexample.txt alias sipexample.txt
tftp-server flash0:Phones/7912/Sip/sip_ptag.dat alias sip_ptag.dat
tftp-server flash0:/Phones/7940-SIP/OS79XX.TXT alias OS79XX.TXT
tftp-server flash0:/Phones/7940-SIP/P003-8-12-00.bin alias P003-8-12-00.bin
tftp-server flash0:/Phones/7940-SIP/P003-8-12-00.sbn alias P003-8-12-00.sbn
tftp-server flash0:/Phones/7940-SIP/P003-8-12-00.loads alias P003-8-12-00.loads
tftp-server flash0:/Phones/7940-SIP/P0S3-8-12-00.loads alias P0S3-8-12-00.loads
tftp-server flash0:/Phones/7940-SIP/P0S3-8-12-00.sb2 alias P0S3-8-12-00.sb2
tftp-server flash0:/Phones/7940-SIP/GUI/telephony_service.html alias telephony_service
tftp-server flash0:/Phones/6921/BOOT69xx.0-0-0-14.zz.sgn alias BOOT69xx.0-0-0-14.zz.sgn
tftp-server flash0:/Phones/6921/DSP69xx.12-4-122-99.131025.zz.sgn alias DSP69xx.12-4-122-99.131025.zz.sgn
tftp-server flash0:/Phones/6921/SCCP69xx.9-4-1-3SR2.loads alias SCCP69xx.9-4-1-3SR2.loads
tftp-server flash0:/Phones/6921/SCCP69xx.9-4-1-3SR2.zz.sgn alias SCCP69xx.9-4-1-3SR2.zz.sgn
tftp-server flash:/7821_10_3/kern2.78xx.10-3-1-12.sbn alias kern2.78xx.10-3-1-12.sbn
tftp-server flash:/7821_10_3/kern78xx.10-3-1-12.sbn alias kern78xx.10-3-1-12.sbn
tftp-server flash:/7821_10_3/rootfs2.78xx.10-3-1-12.sbn alias rootfs2.78xx.10-3-1-12.sbn
tftp-server flash:/7821_10_3/rootfs78xx.10-3-1-12.sbn alias rootfs78xx.10-3-1-12.sbn
tftp-server flash:/7821_10_3/sboot2.78xx.10-3-1-12.sbn alias sboot2.78xx.10-3-1-12.sbn
tftp-server flash:/7821_10_3/sboot78xx.10-3-1-12.sbn alias sboot78xx.10-3-1-12.sbn
tftp-server flash:/7821_10_3/sip78xx.10-3-1-12.loads alias sip78xx.10-3-1-12.loads
tftp-server flash:apps41.8-5-2TH1-9.sbn alias apps41.8-5-2TH1-9.sbn
tftp-server flash:cnu41.8-5-2TH1-9.sbn alias cnu41.8-5-2TH1-9.sbn
tftp-server flash:cvm41sccp.8-5-2TH1-9.sbn alias cvm41sccp.8-5-2TH1-9.sbn
tftp-server flash:dsp41.8-5-2TH1-9.sbn alias dsp41.8-5-2TH1-9.sbn
tftp-server flash:jar41sccp.8-5-2TH1-9.sbn alias jar41sccp.8-5-2TH1-9.sbn
tftp-server flash:SCCP41.8-5-2S.loads alias SCCP41.8-5-2S.loads
tftp-server flash:term41.default.loads alias term41.default.loads
tftp-server flash:term61.default.loads alias term61.default.loads
tftp-server flash:aliasP00308010100.sbn
tftp-server flash:/7945G/apps45.9-4-2ES26.sbn alias apps45.9-4-2ES26.sbn
tftp-server flash:/7945G/cnu45.9-4-2ES26.sbn alias cnu45.9-4-2ES26.sbn
tftp-server flash:/7945G/cvm45sccp.9-4-2ES26.sbn alias cvm45sccp.9-4-2ES26.sbn
tftp-server flash:/7945G/dsp45.9-4-2ES26.sbn alias dsp45.9-4-2ES26.sbn
tftp-server flash:/7945G/jar45sccp.9-4-2ES26.sbn alias jar45sccp.9-4-2ES26.sbn
tftp-server flash:/7945G/SCCP45.9-4-2SR3-1S.loads alias SCCP45.9-4-2SR3-1S.loads
tftp-server flash:/7945G/term45.default.loads alias term45.default.loads
tftp-server flash:/7945G/term65.default.loads alias term65.default.loads
tftp-server flash:/7940_SCCP/P0030801SR02.bin alias P0030801SR02.bin
tftp-server flash:/7940_SCCP/P0030801SR02.loads alias P0030801SR02.loads
tftp-server flash:/7940_SCCP/P0030801SR02.sb2 alias P0030801SR02.sb2
tftp-server flash:/7940_SCCP/P0030801SR02.sbn alias P0030801SR02.sbn
tftp-server flash:/7940_SCCP/P0030801SR02.txt alias P0030801SR02.txt
tftp-server flash:/its/td-sccp.jar alias td-sccp.jar
tftp-server flash:/its/td-sip.jar alias td-sip.jar
tftp-server flash:/its/g3-tones.xml alias g3-tones.xml
tacacs-server host 192.168.20.22 timeout 5
tacacs-server directed-request
tacacs-server key 7 0723341C785A155556534A
!
!
!
control-plane
!
!
voice-port 0/0/0
!
voice-port 0/0/1
!
voice-port 0/1/0
!
voice-port 0/1/1
!
!
!
!
!
mgcp behavior rsip-range tgcp-only
(PHP 3, PHP 4)
(PHP 3, PHP 4)
(PHP 3, PHP 4)
!
(PHP 3, PHP 4)
!
!
!
!
custom dial-peer color
name internal emergency
name External emergency
!
!
dial-peer cor list permission-internal-emergency
member internal emergency
!
dial-peer color list permission-External-emergency
member internal emergency
member External-emergency
!
!
dial-peer voice 9001 voip
description ***in_CMEIP***
translation-profile outgoing out_to_CMEIP
session target ipv4:172.16.22.111
incoming called-number 7...
voice-class sip bind control source-interface GigabitEthernet0/2
voice-class sip bind media source-interface GigabitEthernet0/2
in vad
!
dial-peer voice 9002 voip
description ***in_SIP-ISP***
translation-profile incoming in-ISP
max-conn 50 mg
media flow-around
Next
session target ipv4:10.10.10.1
incoming called-number .T
voice-class sip options-keepalive up-interval 10 down-interval 60 retry 2
voice-class sip bind control source-interface GigabitEthernet0/2
voice-class sip bind media source-interface GigabitEthernet0/2
dtmf-relay rtp-nte
g711alaw codec
in vad
!
dial-peer voice 9003 voip
corlist outgoing permission-External-emergency
description ***out SIP-ISP***
translation-profile outgoing out-ISP
preference 1
destination-pattern [29]..........$
media flow-around
Next
session target ipv4:10.1.1.1
voice-class sip bind control source-interface GigabitEthernet0/2
voice-class sip bind media source-interface GigabitEthernet0/2
dtmf-relay rtp-nte sip-kpml sip-notify
g711alaw codec
in vad
!
dial-peer voice 9004 voip
description ***out-CMEIP***
destination-pattern 6.
session target ipv4:172.16.22.111
in vad
!
!
gateway
timer receive-rtp 1200
!
au-sip
authentication username cisco password 7 01100F175804
register ipv4:10.9.200.254 expires 65500
!
!
!
gatekeeper
shutdown
!
!
telephony-service
conference transfer pattern
on autorreg-ephone
Cisco 1234 authentication credential
in keep-history
at logout 8:0 12:0
max-ephones 58
max-dn 70
ip source-address 10.9.200.254 port 2000
pcPort 1 service phone
service phone spanToPCPort 0
service phone webAccess 0
service directed-pickup gpickup
interdigit 6 timeouts
system message ALL NEW
http://10.9.200.254/CCMCIP/authenticate.asp Cisco 1234 authentication url
cnf-file location flash:
(PHP 3, PHP 4)
user-locale U1 load CME-locale-en-Portuguese_Brazil-12.0.12.0.tar
user-locale 1 GB
network-locale
load 7915-12 CP7912080004SCCP080108A
load 7911 SCCP11.9-4-2-1S
load 7912 CP7912080004SCCP080108A.sbin
load 7960-7940 P00308010200
load 6921 SCCP69xx.9-4-1-3SR2
olsontimezone Africa/Luanda version 2010o
time zone 22
time-format 24
date-format dd-mm-yy
90 keepalive
max-conferences 6
call-forward pattern .T
moh 239.0.0.1 port 2000 multicast
web admin system name cisco password cisco
dn-webedit
time-webedit
transfer-system full-consult
transfer-pattern .T
secondary-dialtone 0
standard fac
create cnf-files version-stamp Jan 01 2002 00:00:00
!
!
ephone-template 1
CBarge Newcall remote-in-use softkeys
softkeys hold Join Newcall Resume Select
softkeys idle Newcall Redial Login Gpickup Pickup Cfwdall RmLstC
softkeys seized Callback Cfwdall Endcall Gpickup Meetme Pickup Redial
softkeys alerting Acct Callback Endcall
softkeys connected Acct Confrn Park Transfer Hold Flash RmLstC
softkeys ringing Answer Dnd HLog
type 6921
!
!
dual-line ephone-dn 1
number 700
label 700-DG
description 700-DG
name 700-DG
corlist incoming permission-External-emergency
!
!
dual-line ephone-dn 2
number 701
label 701 -RH
Returns TRH on success or FALSE on error.
name 7042 - RH
corlist incoming permission-External-emergency
!
!
dual-line ephone-dn 3
number 702
label 702 - SYSTEMS
SYSTEMS
name 702 - SYSTEMS
corlist incoming permission-internal-emergency
!
!
dual-line ephone-dn 4
number 703
label 703-Assist
description 703-Assist
name 703-Assist
corlist incoming permission-internal-emergency
!
!
dual-line ephone-dn 5
number 704
label 704-Chief
description Boss
name 704-Chief
corlist incoming permission-internal-emergency
!
!
ephone 1
mac-address 0022.01B3.5345
ephone-template 1
type 7965
logout-profile 1
!
!
!
ephone 2
mac-address 0012.4356.CD3E
ephone-template 1
type 7945
logout-profile 2
!
!
!
ephone 3
mac-address 0011.0067.7B70
ephone-template 1
type 7912
1:3 button
!
!
!
ephone 4
mac-address 00BB.8334.0098
ephone-template 1
type 7912
1:4 button
!
!
!
ephone 5
mac-address 0032.BA1B.5C33
ephone-template 1
type 7940
1:5 button
!
!
line con 0
password 7 03125E0709012458
line aux 0
line 2
no activation-character
in exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
privilege level 15
password 7 071972401E074A1156534A
transport input telnet ssh
vty 5 line 15
privilege level 15
transport input telnet ssh
!
scheduler allocate 20000 1000
ntp logging
ntp master
ntp update-calendar
ntp server 10.9.200.254
!
end

0 Replies 0