cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
633
Views
0
Helpful
4
Replies

Issues with notifications when the phone is locked.

Firework
Level 1
Level 1

Hello, friends.

I have a situation like this: I have my own physical server with a configured UCM (latest version) + Expressway 14.2.7, MRA mode enabled, and the push service activated. Phones (Jabber) are connected to it. I receive calls and messages when both phones are unlocked. Notifications also come through.

But here's the problem: If I leave the phone locked for 20-40 minutes and try to make a call or send a message to it, it doesn't respond. Notifications or calls do not come through. As soon as I unlock the phone, I receive a message or a missed call.

When I call from one phone to another (which has been locked for more than 20 minutes), the call doesn't go through. In the logs, it says "subscriber did not answer."

Phones: iPhone 7, 8 - latest firmware. iPhone SE 2022 - Different firmware versions 16+, including the latest.

We also tested on one Android phone with the same result.

If anyone has had a similar problem or knows what might be causing it, please help. I appreciate any assistance, thank you!

4 Replies 4

Sounds like push notifications isn’t working. I would suggest that you start there.



Response Signature


This doesn't happen every time. Sometimes calls and messages go through, and sometimes they don't. We have configured a push notification service, but for some reason, notifications don't always reach their destination.

It's strange because there are times when the phone can be left untouched all night, and in the morning, I can call it, and the call goes through. But not everytime

Review the RTMT logs to identify any notifications related to the push notification service. If you find any relevant notifications, please share them here so that we can assist you with troubleshooting the issue.

Firework
Level 1
Level 1

Hello. Thank you for responding, showing interest in my case, and being ready to assist. I really appreciate it.

I will send a full log package, which includes:

Cisco call manager (1 and 2)
Cisco local push notification service (1 and 2)
Cisco push notification service (1 and 2)
Diagnostics log exp C
Diagnostics log exp E
Jabber phone logs

------------------
Here's an example of an unsuccessful incident with a timestamp:

09/23/23
17:10 - Three calls from 1033 to 1037 - Unsuccessful
17:11 - Three chat messages from 1033 to 1037 - Unsuccessful

17:14 - Activated the screen on the iPhone

Chat messages arrived.
Call notifications - nothing.

17:14
Call from 1033 to 1037 (after Activated the screen) - Successful
------------------

A very interesting observation:
We conducted various tests and noticed that the problem only exists when the phone is connected to the internet via Wi-Fi. When the phone operates using the SIM card (without Wi-Fi), there are no issues - all notifications work, and all calls and messages come through immediately.
The problem occurs exclusively when the phone is connected via Wi-Fi. We tried both home Wi-Fi and a mobile router.

I am grateful to everyone who will be interested in this matter and will greatly appreciate any advice.