Showing results for 
Search instead for 
Did you mean: 

Rolm 9751 9005/PIMG/Unity Connections MWI


I'm attempting to integrate a Rolm 9751 9005 to a Unity Connecitons via PIMG.  Unity is answering and accepting the message.  It indicated the MWI is on.  However, on the Rolm phone no MWI, no stuttertone.  In the PIMG, I never see the 2 MWI ports in use.  Of 8 ports on the PIMG 6 are set up for incoming while the last two ports are set up for outgoing/mwi.  All ports are green and enabled throughout the system.  Any ideas how to trouble shoot this?

1 Accepted Solution

Accepted Solutions


Can you activate using feature codes??

View solution in original post

5 Replies 5

Rising star
Rising star

We recently integrated our Unity Connection with a similar PIMG-RLM unit and our HiCom PBX. It wasn't easy, but in the end it worked out. We still have a problem with the MWI port going out of service every other day or so (an identified bug), but other than that, it's OK. We had a PBX vendor working closely with us, so we had that going for us as well. If you have a PBX vendor, it's worth paying them to come in and help troubleshoot.

That being said, here are some things you can try:

  • make sure you follow the integration guide to the letter. i remember missing one step that was at the bottom of one page and it drove us nuts!
  • use the appropriate port status monitor to see if Unity is actually sending out the MWI on/off commands
  • PBX's like the same port to turn off the MWI that turned it on. this is what port memory is all about. but honestly, i think port memory is a bit loosey-goosey. We've chosen to turn off port memory and simply enable only one port for MWI. problem solved.
  • that being said, you'll have to ensure you turn off all MWIs on the phones before you make this change in an attempt to synchronize, otherwise, you'll have issues
  • the incoming/outgoing ports have nothing to do with mwi, it's more to do with inbound calls and outbound calls (like TRAP, notification, etc).
  • plug a rolm phone into the port to see you can dial out to the extensions, if that fails, you've got PBX issues
  • the class of service on the PBX side has to be correct for each port. i remember that it needed the class of service for off-net access (but that could have just been our setup)

If that doesn't help, you will likely have to get the TAC involved, they can help quite a bit in this case. But you'll need an experienced PBX person (for us it was our vendor).



Can you activate using feature codes??

Thank you all for the advice.  Worked with CISCO TAC and it was my error.  DIdn't set the Unity Mailbox to the right Telephone switch.  DUH!  Thanks again.

Hey..............ya need one of DUh's every now and then!!!    loved the old 9751's....its been awhile...take care

Something so small, yet painstaking to troubleshoot   Glad its working for you


Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers