cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1353
Views
5
Helpful
5
Replies

Single Inbox w/E2k3 - reply or forward to message

maratimer_2
Level 1
Level 1

We have UC 8.5.SU 1 (ES 16) single Inbox configured, mulitple UM Services configured to each E2k3 server.   We added the unityconnection host names to the exchange environment via connectors so a user could reply in Outlook to a voicemail message. 

When a user sends a voicemail over the TUI to a user, and the recipient replies to it in email, the MWI for the original sender goes on, and it appears in outlook.  However, if the user reads the email in Outook and deletes it in Outlook, the MWI does not go off.   After any amount of time, 5 minutes or 5 hours, the MWI is still on for the user and the only way to turn it off is to access the TUI and listen to the email reply message, and then delete it.

Is there a workaround or configuration we need to implement to stop this behavior?  The customer wants users to be able to reply to voice messages in Outlook, but they do not want the MWI to go on for email replies.   These users do not have TTS enabled and do not use Viewmail.

1 Accepted Solution

Accepted Solutions

Maratimer,

Here is a suggestion of something for you to test.  Unity Connection has message actions based on the type of message delivered to a user's mailbox.  With Single Inbox, there is actually a couple spots where this may come into play so you'll have to see how settings interact.  Here goes:

1.  For a single user - go to the user record choose Edit > Message Actions.  By default, the message action for Email is "Accept the Message".  If you are delivering emails directly to the SMTP address of each user via the addition of the connectors from within Exchange and you have the default setting here then it is accepted into the Unity Connection inbox (i.e., it does not go to the recipient's Exchange mailbox).  This is probably why you see MWI for every message when you reply to a voicemail from within Exchange.

2.  For that user, change the Message Action for Email to "Relay the Message".  In the "Relay Address", enter the user's corporate email address (i.e., Exchange address).

3.  Now, you are going to need an SMTP smart host.  This is simply an SMTP relay host that will accept messages relayed from Unity Connection and can then relay the message to a user in the appropriate domain.  In your case, you will need to have a smart host that can relay messages to users in your corporate domain.  You could configure your Exchange server for this purpose or it could be another server in your environment.  If you already have one that's great.  If you don't then you'll need to work it out with the email folks and then in Unity Connection go to System Settings > SMTP Configuration > Smart Host > and enter the IP address of the relay server.  You need this to work or the next step is of no value.

4.  Couple ways to test the next item.  You need to verify the SMTP relay and the MWI behavior.  Within Outlook, address a message to the Unity Connection SMTP address of the user you modified in #2 (not the Exchange address, the Unity Connection SMTP address for the user).  Assuming routing works, the email message will be sent to Unity Connection where it will see it is an email and then it will RELAY the message to the RELAY ADDRESS.  The difference here is that the message would not ever reside in the user's Unity Connection inbox and would simply be relayed back out to the Exchange address.  If this works correctly, you should not get MWI for Unity Connection (it is not storing the reply message) but you should receive the email reply in Exchange.

Now with Single Inbox, there are also some Message Actions that you must configure with the Unified Messaging service.  These settings interact with the individual user message actions.  By default, the Email message action for the UM services is "Relay the Message" but if the individual setting includes "Accept" then the message will be accepted.  You will want to review the help to see what the interaction should be in your environment. 

If this works sufficiently then you would just need to update the Message Actions (for each user / you could use BAT) and/or the UM service Message Actions.

Let me know what you find and if this has any effect.

Hailey

Please rate helpful posts!

View solution in original post

5 Replies 5

Bradford Magnani
Cisco Employee
Cisco Employee

Hi,

It's very likely that this is expected behavior since users do not have VMO installed, when replying to the voice message, Outlook converts the message class to an email (IPM.Note message class) rather than the IPM.Note.Custom.Cisco.Unity.Voice message class that UC uses to sync messages.  So it's now an email, no longer a voice mail.  You can confirm this by adding the "Message Class" column to your Outlook view and comparing pre and post reply.

Hope that helps,

Brad

This messages are indeed marked IPM.Note but if the message is marked as an email (IPM.Note message class), then why is Unity Connection turning on the MWI in the first place?  It doesnt do that for any other regular email.  It doesnt sound like it is by design or desireable.

Ah, I misunderstood the message flow.  After re-reading it does sound like something unexpected may be happening.  Given your scenario a reply seems to be what doesn't turn the light off.  What happens if you try forwarding a message with the same message flow?  Does the forwarded message exhibit the same behavior where the light doesn't go off?

Maratimer,

Here is a suggestion of something for you to test.  Unity Connection has message actions based on the type of message delivered to a user's mailbox.  With Single Inbox, there is actually a couple spots where this may come into play so you'll have to see how settings interact.  Here goes:

1.  For a single user - go to the user record choose Edit > Message Actions.  By default, the message action for Email is "Accept the Message".  If you are delivering emails directly to the SMTP address of each user via the addition of the connectors from within Exchange and you have the default setting here then it is accepted into the Unity Connection inbox (i.e., it does not go to the recipient's Exchange mailbox).  This is probably why you see MWI for every message when you reply to a voicemail from within Exchange.

2.  For that user, change the Message Action for Email to "Relay the Message".  In the "Relay Address", enter the user's corporate email address (i.e., Exchange address).

3.  Now, you are going to need an SMTP smart host.  This is simply an SMTP relay host that will accept messages relayed from Unity Connection and can then relay the message to a user in the appropriate domain.  In your case, you will need to have a smart host that can relay messages to users in your corporate domain.  You could configure your Exchange server for this purpose or it could be another server in your environment.  If you already have one that's great.  If you don't then you'll need to work it out with the email folks and then in Unity Connection go to System Settings > SMTP Configuration > Smart Host > and enter the IP address of the relay server.  You need this to work or the next step is of no value.

4.  Couple ways to test the next item.  You need to verify the SMTP relay and the MWI behavior.  Within Outlook, address a message to the Unity Connection SMTP address of the user you modified in #2 (not the Exchange address, the Unity Connection SMTP address for the user).  Assuming routing works, the email message will be sent to Unity Connection where it will see it is an email and then it will RELAY the message to the RELAY ADDRESS.  The difference here is that the message would not ever reside in the user's Unity Connection inbox and would simply be relayed back out to the Exchange address.  If this works correctly, you should not get MWI for Unity Connection (it is not storing the reply message) but you should receive the email reply in Exchange.

Now with Single Inbox, there are also some Message Actions that you must configure with the Unified Messaging service.  These settings interact with the individual user message actions.  By default, the Email message action for the UM services is "Relay the Message" but if the individual setting includes "Accept" then the message will be accepted.  You will want to review the help to see what the interaction should be in your environment. 

If this works sufficiently then you would just need to update the Message Actions (for each user / you could use BAT) and/or the UM service Message Actions.

Let me know what you find and if this has any effect.

Hailey

Please rate helpful posts!

Thank you David, this indeed resolved the issue.  After reviewing all of the UM Services created (there were approximately 40 per cluster X 10), it was noted that several of them were configured with "accept and relay the message" for email as opposed to "relay".  Once we updated the UM Services with the correct configuration, the MWI stopped turning on when a user replies to a voicemail through Outlook. 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: