Showing results for 
Search instead for 
Did you mean: 

User Count Tool beta now published to SW Center on CCO!

Level 4
Level 4

Now User Count Tool (UCT) is available to all CCO users in beta form on the SW Center.  We encourage partners, field and end-users to test this tool with CUCM versions 5.0 through 8.6 and become familiar with the manner of license conversions to CUWL and UCL license types on 9.0 systems.

Currently, this is posted to version 8.6 location prior to 9.0 availability.  Location/path on SW Center is as below:

Downloads Home


Voice and Unified Communications

IP Telephony

Unified Communications Platform

Cisco Unified Communications Manager (CallManager)

Cisco Unified Communications Manager Version 8.6

Unified Communications Manager / CallManager / Cisco Unity Connection Utilities-UCT

23 Replies 23

There is a known issue when upgrading from v1.0 to v2.x: no error message is displayed after report generation but there is no information in the License Requirements Based on Usage Data table.

The workaround is to remove the C:\users\<user>\UserCountTool folder and restart UCT 2.x. The issue will be fixed in the next release of the tool.

I've tried this multiple times already (deleting the folder) and the results don't change.

I deleted the folder in:

"The workaround is to remove the C:\users\<user>\UserCountTool folder and restart UCT 2.x"

and this worked for me.

We have enough challenges with upgrades, licenses and migrations, I just wish the responsible Cisco QA folks would be more thorough before posting upgrades to utilities. Collectively this type of 'glitch' creates a lot of wasted time and unnecessary headaches.

Glad to hear the workaround fixed your problem and we appreciate your feedback.

Yes, upgrades, licensing and migration are certainly a challenge and we think we're on the right path with the User Count Tool and Enterprise License Manager. But, as you say, any glitches make it difficult on our users. We're commited to getting this process right and the feedback we're getting from our customers will be invaluable to our QA folks going forward.

Joe Cooke
Level 5
Level 5

I'm having sporadic issues with the UCT not generating counts properly - the collection seems to run however the Essential/Enhanced/EnhancedPlus/Standard/Premium counts are zero.  The unused DLU's report correctly however.

Has anyone else run into this before?


I've ran this version with some remarks.

UCL Basic and UCL Enhanced reported correctly, but it shows a lot of Essetial licenses that actually should not exist.

Level 4
Level 4

My workaround was to use a new virtual machine where UCT was never run. But today i just tried to use the new UCT 2.1a and the test connection is ok, but when i try to generate the report i've this error


I tried another fresh virtual machine and my PC but i've the same problem also when i try to connect on different CUCM cluster. Any idea? Is there any kind of log generated by UCT?

The UCT log is located at (for example) C:\Users\<user>\UserCountTool\com\cisco\uct\log4j

Thx gregwils.

I've attacched the log where the ip address of the CUCM is changed to

It seem that a something of strange is happen. The username a password are correct, i can login with them and the user have the "super user" privilege, so AXL role.

UCT seem to be able to connect to the database but when the log change to "Thread-4" i see "Error occoured while decrypting AXL Password. Error: Password is not ASCII".

This happen to me trying different CUCM cluster, the strange thing is that on February i used UCT 2.0 on that cluster and it worked.

Any idea?


Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: