Showing results for 
Search instead for 
Did you mean: 

User Management broken on CUCM after upgrade from 10.5(2) to 11.5(1)


Hello everyone,

first of all, this is a lab environment I am talking about, nothing critical. I have no problems setting up the whole bunch again, but I would like to understand what happened to me. Also please note that this is my first real contact with CUCM 11.5. This lab was set up in preparation for upgrading our productive cluster.

The environment:

CUCM, single server, upgraded from

Unity Connection, also single server

I set up the CUCM 10.5.2 and the Unity and got everything to work so far. I setup Unity as well with user import via AXL from the CUCM. Integration worked fine as far as I could test it in my lab.

I then went about upgrading the CUCM to the above mentioned 11.5 version via OS Administration. The upgrade itself and the version switch worked fine and gave me no errors at all.

After the CUCM was back up, I verified the version, which shows fine. My phones came back up after an additional restart. After that, I also tested the Unity integration, which still worked.

My surprise came when I wanted to add a new user to the CUCM...

I noticed the following Symptoms:

- when adding a new user, the User Rank is a required field, but I cannot select anything in the dropdown menu, even after I have created additional ranks. This applies to End Users and Application Users

- I cannot change the rank of existing users, the User Rank field of those is grayed out on Rank 1

- I can change other information of existing users, except User Groups, those buttons are missing

- I have no option to delete existing users. On the user page, the button is missing, in the user list there is no checkbox to select a user

- The missing checkbox applies to all pages where I would have to select a user, e.g. assigning a user to a line

- The Quick Add User/Phone page stays blank after loading

- I cannot add a LDAP directory. The Save button simply does nothing on that page

- I cannot create or change user groups. When I try, I get a message telling me "User is not authorized to access this page". I am logged in with the application user created during CUCM installation.

- I can still create Phones, Lines, User Device Profiles or Call Routing stuff.

When I switch back to the old version, everything seems to work again. I then also repeated the upgrade, but again I have the same issues.

Any help in understanding what has happened to my lab is appreciated.

1 Accepted Solution

Accepted Solutions