cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

5844
Views
409
Helpful
62
Replies
Community Manager

Ask the Expert: Cisco IM and Presence Installing, Integrating and Troubleshooting

Welcome to this Cisco Support Community Ask the Expert conversation. This is an opportunity to ask questions about Cisco IM and Presence to Nagajothi Thangapandian and Sathishbabu Muthalagan.

Ask questions from Monday November 2nd to Friday November 13 , 2015

Cisco IM and Presence delivers enhanced enterprise IM features, group chats, and IM logging, along with a suite of business-to-business and business-to-consumer IM and presence open federations. Customers deploying Cisco Unified Communications Manager can then view the presence status or availability of the people they want to communicate with, exchange instant messages with these individuals, and escalate to a voice and video call or rich collaborative session.

This session will help customers with Troubleshooting Cisco IM & presence install and it’s UC integration related issues.

 

Nagajothi and Sathishbabu will be helping you with all your queries on all of the above.

 

Nagajothi Thangapandian is a Customer Support Engineer in Cisco TAC team in Bangalore. She has been working with TAC for past 4 years and has 7 years of industry experience working with enterprise deployment and troubleshooting. Her area of expertise includes Cisco Unified Communications Manager, IM & Presence server, Cisco Jabber, Attendant Console and Prime Collaboration Provisioning. She is graduated with a Bachelor of Electronics and Communication from Anna University. She holds CCNA, CCNP - Voice and RHCE. She is also pursuing CCIE Collaboration and VCP.

 

 

Sathishbabu Muthalagan is a Customer Support Engineer in Cisco TAC based out in Bangalore, India. He has been working with TAC for past 2 years and has 5 years of industry experience working with enterprise deployment and troubleshooting. His area of expertise covers Cisco Unified Communications Manager, Cisco IM and Presence, Cisco Unity Connection, Cisco Unified Attendant Console, Cisco Emergency Responder, Cisco Jabber and Prime Collaboration Provisioning. He is graduated with a Bachelor of Electronics and Communication Engineering from Anna University. He has achieved certifications for CCNA, CCNP - Voice and he is also pursuing CCIE Collaboration and RHC.

 

Find other  https://supportforums.cisco.com/expert-corner/events.

Because of the volume expected during this event, Nagajothi and Sathishbabu might not be able to answer every question. 

**Ratings Encourage Participation! **
Please be sure to rate the Answers to Questions

 

Join the Discussion : Cisco Ask the Expert

1 ACCEPTED SOLUTION

Accepted Solutions

Hi Jack,

Hi Jack,

According to your issue, Sync agent is not up and you have already modified the CUCM UI admin password in CUCM, hence you can skip step 1 and 2.

3. Change the password in IMP using the command reset_application_ui_administrator_password

4. Start sync agent

5. Try login to IMP now.

Regards

62 REPLIES 62

Hi,

Hi,

I do have few concerns on Jabber Mobile Clients like IPhone/Android, is Jabber Mobile client support FAC and any possibility to initiate meet me from Jabber.

Hi Niyadh,

Hi Niyadh,

Thanks for your interest. I would like to let you know that this session is intended to have questions related to troubleshooting IM&P server installation and integration. Though jabber is not planned, i will try to help here.

Unfortunately the features FAC and Meet me are not supported currently. Here are the enhancements opened on this.

FAC:

https://tools.cisco.com/bugsearch/bug/CSCug51288/?reffering_site=dumpcr

Meet me:

https://tools.cisco.com/bugsearch/bug/CSCus37131/?reffering_site=dumpcr

Regards

Highlighted
Advisor

Hi ,

Hi ,

We are doing fresh installation of IMP version 10.5.2.21900-4 and Cisco XCP router is not running. We checked our configuration , SIP Trunk is UP and all services in IMP are Activated and Running .Only this XCP Router service is not running.We did fresh installation of IMP but still status is same.

 

We also tried restarting XCP Router and shows STARTING and again goes in "NOT Running"

Can u please advise what could be the issue?

 

regds,

aman

Hi Aman,

Hi Aman,

  • If you have more than a node in IMP, then verify dbreplication status. Make sure HA is not enabled until dbreplication status is 2. Better to check your CUCM is 10.5.2 version.
  • Sync agent service in IMP is up and running?
  • Any changes in the CUCM hostname or Domain after the IMP server installation?
  • System troubleshooter of IMP will be helpful. Can you check for any alerts like "This IM & Presence server has been deleted from the CUCM Server List. This server must be reinstalled" in system troubleshooter
  • Consider system troubleshooter alerts and any service restart alert that you can see as soon as you login to admin page
  • If the above is not helping we need to anlayze IMP logs

Please set below logs to debug :

XCP router
XCP config manager
XCP connection manager
XCP authentication manager

Restart XCP router once, wait for it to go to not running status and then collect these logs from RTMT.

Regards

Beginner

Dear Experts,

Dear Experts,

i have 2 issues,

I have a four Cisco IM and Presence servers with 2 cluster, 1 cluster in HO and another cluster in branch, in branch cluster one of the server all services are in starting state and not moving to started.and it happen on any of the server in branch cluster.

user A cannot see a presence of user B who is assigned in cluster B (branch).

Hi Jack,Issue 1: Usually

Hi Jack,

Issue 1: Usually happens when HA enabled as soon as the node installed, before the dbreplication setup is completed. Can you follow the below procedure if HA is enabled for this cluster:

  • Disable HA
  • Use the command "set replication watcher disable" from CLI
  • Wait for services to come up
  • Check DB status using "utils dbreplication status"
  • Once when the status is 2, enable HA


If HA was not enabled already, you can try to unassign the problematic subscriber from the subcluster and assign it back.

Issue 2: Unable to communicate and see presence status between subcluster.
It is hard to comment on what could be the issue without analysing the logs. The scenario mostly occur when the IMP nodes are in different subnet.

If the nodes are in different subnet, the routing communication type in IMP should be set as router-to-router. In recent version this can be verified under IMP service parameter for XCP router.

Logs to collect for this scenario in debug level would be :

  • XCP connection manager
  • XCP router
  • Presence engine
  • Jabber problem report from both the side

Regards

Advisor

Hi Nagajothi,

Hi Nagajothi,

I can find command utils restore_application_ui_administrator_account in IMP 10.5.2.

 

what exactly it does?

 

regds,

aman

Hi Aman,

Hi Aman,

This command will be rarely used in scenarios like when the application user id which is a ui account, is deleted by mistake from CLI or root. This account cannot be deleted from GUI, as the server will alert you with the messge : Cannot delete last account with super user acess.

But if the account is deleted by mistake from CLI using sql query or root, this command is to restore that UI account back so that we can contine to access UI.

Regards

Advisor

Hi Nagajothi,

Hi Nagajothi,

thanks for the reply[+5].

 

regds,

aman

Advisor

Hi Nagajothi,

Hi Nagajothi,

One query: when we create a SIP trunk between CUCM and IMP version 10.5, do we need to enter IP address of two IMP servers[say two] in SIP Trunk for redundancy purpose ?

 

regds,

aman

Hi Aman,

Hi Aman,

Yes, to achieve high availability we can mention more than one IP address based on number of IMP nodes in the cluster. But the best procedure will be to use DNS SRV record as explained in this document

DNS SRV in CUCM for IM & Presence Service Configuration Example

Hope this helps

Beginner

Dear expert,

Dear expert,

after installing 8.6 when i logged in first time for the post installation it asked me for the axl username and password and  i used the same admin application username and password of cucm which was created while installation of cucm,few months before i changed the password and presence communication with cucm was fine, last week i upgraded to 11.0 cup & cucm and the communication lost between the cup & cucm when i changed the admin application password in cucm then the communication was successful and all services in presence came up.

Now i dont want to use admin application username & password i want to use another username and password is it possible ??? and how can we do it.

thanks

Hi Jack,

Hi Jack,

8.X and 9.X requires such AXL integration during the post install setup.

From 10.x onwards, it has been designed in such way that the UI admin credential which has been created during the CUCM installation will be used for AXL integration and this cannot be modified in GUI. If you have a very specific requirement to have a differnt account for AXL integration, this would be possible by editing few tables in database from CLI or root. But not a suggestible procedure. Please let us know if you have further queries.

Regards

Beginner

Dear Expert,

Dear Expert,

can we change only the password, becz when i changed the password the communication between the cucm and cup break.

thanks

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards