cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2318
Views
10
Helpful
12
Replies
Beginner

Background images

I have a new install of call manager 11, I have the background images loaded and the List.xml file adjusted. When the phone tries to download the image, it is requesting the <filename>.png.sgn is this a new requirement for CUCM 11? And if so, how do I go about signing my background images? Or, can it be disabled somewhere?

12 REPLIES 12
Beginner

Nothing on this? Anyone have

Nothing on this? Anyone have any idea where to even start?

Cisco Employee

Hi David,

Hi David,

This is default for CUCM 11, if you can provide More detail like.

  1. Phone Model
  2. Firmware used
  3. Console logs from the phone while trying to access background image.
  4. TFTP detail logs from CUCM
  5. PCAP from phone if possible.
  6. MAC for the phone we tested with.

above information needs to be collected simultaneously

JB

Beginner

When you say this is default

When you say this is default for call manager 11, do you mean that this is the intended functionality now?

What do I need to do then to make the background images appear on the phone? The phone requests the file via TFTP as expected, but there is NO png.sgn file created. If I need to create the sgn I will do that, but I don't see any documentation regarding this.

Beginner

Where you able to get an

Where you able to get an answer on this?

thank you..

Beginner

No, I haven't found anything

No, I haven't found anything yet. The phone is a 7965, latest firmware that comes with version 11 of CUCM, I was seeing the request in the TFTP logs for the phone, it was looking for the signed background image. I'm not able to pull any further logs as the system is in production and I don't have access to it at the moment.

Hi Team,

Hi Team,

Are you still with this problem? I have the same situation.

Beginner

It's a bug with 11.5.

It's a bug with 11.5.  CSCva82202.  List.xml.sgn should be automatically created when you upload a new List.xml file to the server.  It retains the old version which is why new background images don't show up on the phones.  The only way to fix this is to open a case with TAC and give them root access so they can delete List.xml.sgn.  I was told this bug will not be fixed until CUCM 12 so make sure you get all your background images loaded before going through this process.  Otherwise, you'll have to open another case and go through the steps again.

Beginner

The ".sgn" is added to all

The ".sgn" is added to all files that are required for the phones when they are in secure mode.  If you remove the security setting from the phone itself it should no longer request signed files from the call manager.

The files should be automatically signed by the call manager.  There is nothing you can do to force this process.

Is your cluster set to process SRTP?

Beginner

Re: The ".sgn" is added to all

i had the same problem as all of you, had done so many image background deployments i knew i had not missed a step. Finally i decided to delete the .sgn file and everything works!

 

I dont know what the file is all about. TAC was on with me and he was trying to explain i had my image size wrong, but that was not it. I asked him about the sgn file and he didnt really have a good explanation so i said well im deleting it, i did it and it worked. Tried it on other 11 clusters where background images were not taking and it worked.

 

I think once a phone grabs the image, it writes that file? im not sure exactly what is happening but just delete the sgn version of what you are trying to update and it will take.

Highlighted

Re: The ".sgn" is added to all

can't delete the .png.sgn.

Beginner

Re: The ".sgn" is added to all

Plus. The same issue. Any ideas how to solve it?
When I delete the files through OS Administration, it writes that files were deleted, but indeed nothing happens and .sgn files are still on the server (not changed).

Re: The ".sgn" is added to all

in my case the issue was with the List.xml. Thumbnails had the correct directory, but for the main image I forgot to add the full folder Desktops/8....png.

It is working with the .sgn file created. I did not have to delete it.

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards