cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
863
Views
0
Helpful
2
Replies
Highlighted
Beginner

can not make an external call with CuCM and H323 gateway

Hi experts, i'm having an issue with CuCM and h323 Gateway. i'm using a 2811 router to make an H323 gateway, CuCM server and Switch layer 2 to build a VoIP LAB, this my network:  

Untitled.png

and my router configuration:

Current configuration : 2335 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

logging message-counter syslog

!

no aaa new-model

!

!

!

dot11 syslog

ip source-route

!

!

ip cef   

ip dhcp excluded-address 192.168.1.1 192.168.1.10

!

ip dhcp pool VOICE

   network 192.168.1.0 255.255.255.0

   option 150 ip 192.168.1.2

   default-router 192.168.1.1

!

!

no ipv6 cef

!

multilink bundle-name authenticated

!

!

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

supplementary-service h450.12

fax protocol cisco

!

!

!

voice class h323 1

  h225 timeout tcp establish 3

!

!

!

voice translation-rule 1

rule 1 /^9/ //

!

!

voice translation-profile PSTN

translate called 1

!

!

voice-card 0

!

!

application

service aa1 flash:its-cisco.2.0.2.0.tcl

  paramspace english language en

  paramspace english index 1

  param aa-pilot 0839959204

  paramspace english location flash:

  paramspace english prefix en

!

!

!        

archive

log config

  hidekeys

!

!

interface FastEthernet0/0

ip address 192.168.1.1 255.255.255.0

duplex auto

speed auto

h323-gateway voip interface

h323-gateway voip bind srcaddr 192.168.1.1

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

ip forward-protocol nd

no ip http server

no ip http secure-server

!

!

!

control-plane

!

!

!

voice-port 0/0/0

echo-cancel coverage 32

connection plar opx 3100

description 08395959204

caller-id enable

!

voice-port 0/0/1

!        

voice-port 0/0/2

!

voice-port 0/0/3

!

!

!

dial-peer voice 1010 pots

service aa1

incoming called-number 08395959204

direct-inward-dial

port 0/0/0

!

dial-peer voice 2020 pots

description PSTN

translation-profile outgoing PSTN

destination-pattern 9T

progress_ind setup enable 3

progress_ind progress enable 8

port 0/0/0

forward-digits all

!        

dial-peer voice 10 voip

destination-pattern 1...

progress_ind setup enable 3

progress_ind progress enable 8

voice-class h323 1

session target ipv4:192.168.1.2

dtmf-relay h245-alphanumeric

codec g711ulaw

no vad

!

!

!

!

line con 0

line aux 0

line vty 0 4

password cisco

login

!

scheduler allocate 20000 1000

end

i configured h323 Gateway and router parttern on CUCM follow attach files

what's problem and how to solve it?

thanks for all helping.

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Cisco Employee

can not make an external call with CuCM and H323 gateway

Your DP pointing to CUCM is wrong, or your plar OPX, whichever you need.

voice-port 0/0/0

echo-cancel coverage 32

connection plar opx 3100

description 08395959204

caller-id enable

dial-peer voice 10 voip

destination-pattern 1...

progress_ind setup enable 3

progress_ind progress enable 8

voice-class h323 1

session target ipv4:192.168.1.2

dtmf-relay h245-alphanumeric

codec g711ulaw

no vad

Your DP expects 1... and you're sending 3100, they need to match.

You might need to change the significantt digits and inbound CSS, but that only you can know

For outbound, you're discarding predot 9, but yet, you're expecting it in your DP, again, change as you need to.

dial-peer voice 2020 pots

description PSTN

translation-profile outgoing PSTN

destination-pattern 9T

progress_ind setup enable 3

progress_ind progress enable 8

port 0/0/0

forward-digits all

You cannot forward digits all, you'll also send the 9 for every call

Adjust your configuration as you wish/need.

HTH

java

if this helps, please rate

www.cisco.com/go/pdihelpdesk

HTH

java

if this helps, please rate
2 REPLIES 2
Hall of Fame Cisco Employee

can not make an external call with CuCM and H323 gateway

Your DP pointing to CUCM is wrong, or your plar OPX, whichever you need.

voice-port 0/0/0

echo-cancel coverage 32

connection plar opx 3100

description 08395959204

caller-id enable

dial-peer voice 10 voip

destination-pattern 1...

progress_ind setup enable 3

progress_ind progress enable 8

voice-class h323 1

session target ipv4:192.168.1.2

dtmf-relay h245-alphanumeric

codec g711ulaw

no vad

Your DP expects 1... and you're sending 3100, they need to match.

You might need to change the significantt digits and inbound CSS, but that only you can know

For outbound, you're discarding predot 9, but yet, you're expecting it in your DP, again, change as you need to.

dial-peer voice 2020 pots

description PSTN

translation-profile outgoing PSTN

destination-pattern 9T

progress_ind setup enable 3

progress_ind progress enable 8

port 0/0/0

forward-digits all

You cannot forward digits all, you'll also send the 9 for every call

Adjust your configuration as you wish/need.

HTH

java

if this helps, please rate

www.cisco.com/go/pdihelpdesk

HTH

java

if this helps, please rate
Beginner

can not make an external call with CuCM and H323 gateway

Thank you for your help. I will follow it

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards