cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
657
Views
0
Helpful
12
Replies

Can't Recieve Calls on my Analogue phone (port 0/0/0)

NelsonCBN
Beginner
Beginner

I I have configured the following dial peers on my UC560. I can call out but when a call comes in, it doesnt get to the analog telephone on the voice port 0/0/0.

What am I not doing well?

dial-peer voice 1 pots

incoming called-number .

direct-inward-dial

port 0/3/0:15

dial-peer voice 90 pots

destination-pattern .T

port 0/3/0:15

dial-peer voice 10 pots

destination-pattern 99043700

port 0/0/0

forward-digits all

12 REPLIES 12

Chris Deren
Hall of Fame Master Hall of Fame Master
Hall of Fame Master

Please post "debug isdn q931" and "debug voice dialpeer"

Chris

debug isdn q931

*Apr 26 13:31:45.043: ISDN Se0/3/0:15 Q931: Received SETUP  callref = 0x8A73 cal

lID = 0x000B switch = primary-net5 interface = User

*Apr 26 13:31:45.047: ISDN Se0/3/0:15 Q931: TX -> CALL_PROC pd = 8  callref = 0x

8A73

        Channel ID i = 0xA9839E

                Exclusive, Channel 30

*Apr 26 13:31:45.051: ISDN Se0/3/0:15 Q931: TX -> CONNECT pd = 8  callref = 0x8A

73

*Apr 26 13:31:45.391: ISDN Se0/3/0:15 Q931: RX <- CONNECT_ACK pd = 8  callref =

0x0A73

*Apr 26 13:31:45.391: %ISDN-6-CONNECT: Interface Serial0/3/0:29 is now connected

to 8131694027 N/A

*Apr 26 13:31:49.035: ISDN Se0/3/0:15 Q931: RX <- DISCONNECT pd = 8  callref = 0

x0A73

        Cause i = 0x8090 - Normal call clearing

        Progress Ind i = 0x8288 - In-band info or appropriate now available

*Apr 26 13:31:49.035: %ISDN-6-DISCONNECT: Interface Serial0/3/0:29  disconnected

from 8131694027 , call lasted 3 seconds

*Apr 26 13:31:49.035: ISDN Se0/3/0:15 Q931: call_disc: PI received in disconnect

; Postpone sending RELEASE for callid 0xB

*Apr 26 13:31:49.039: ISDN Se0/3/0:15 Q931: TX -> RELEASE pd = 8  callref = 0x8A

73

*Apr 26 13:31:49.203: ISDN Se0/3/0:15 Q931: RX <- RELEASE_COMP pd = 8  callref =

0x0A73

debug voice dialpeer:

CBN-AFRICA#debug voice dialpeer Se0/3/0:15 Q931: Sending SETUP

voip dialpeer default debugging is on99: //-1/9025F1B98046/DPM/dpMatchPeer

CBN-AFRICA#l history

!

*Apr 26 13:35:36.707:

e=DIALPEER_INFO_SPEECH

*Apr 26 13:35:36.707: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:

   Result=Success(0) after DP_MATCH_ORIGINATE; Incoming Dial-peer=2

*Apr 26 13:35:36.707: //-1/xxxxxxxxxxxx/DPM/dpMatchSafModulePlugin:

   dialstring=NULL, saf_enabled=0, saf_dndb_lookup=0, dp_result=0

*Apr 26 13:35:36.707: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:

   Calling Number=8131694027, Called Number=3700, Voice-Interface=0x0,

   Timeout=TRUE, Peer Encap Type=ENCAP_VOICE, Peer Search Type=PEER_TYPE_VOICE,

   Peer Info Type=DIALPEER_INFO_FAX

*Apr 26 13:35:36.707: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:

   Result=NO_MATCH(-1) After All Match Rules Attempt

*Apr 26 13:35:36.707: //-1/xxxxxxxxxxxx/DPM/dpMatchSafModulePlugin:

   dialstring=NULL, saf_enabled=0, saf_dndb_lookup=0, dp_result=-1

*Apr 26 13:35:37.059: %ISDN-6-CONNECT: Interface Serial0/3/0:29 is now connected

to 8131694027 N/A

*Apr 26 13:35:43.015: %ISDN-6-DISCONNECT: Interface Serial0/3/0:29  disconnected

from 8131694027 , call lasted 5 seconds

*Apr 26 13:35:43.023: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:

   Calling Number=.T, Called Number=, Voice-Interface=0x0,

   Timeout=TRUE, Peer Encap Type=ENCAP_VOIP, Peer Search Type=PEER_TYPE_VOICE,

   Peer Info Type=DIALPEER_INFO_SPEECH

*Apr 26 13:35:43.023: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:

   Result=NO_MATCH(-1) After All Match Rules Attempt

*Apr 26 13:35:43.023: //-1/xxxxxxxxxxxx/DPM/dpMatchSafModulePlugin:

   dialstring=NULL, saf_enabled=0, saf_dndb_lookup=0, dp_result=-1

This debug shows that call is matching dial peer 2 (which you did not provide) on the inbound side, but then is unable to match any outbound dialpeers, the called number here shows 3700, yet your dial-peer 10 has destination-pattern  99043700.

Chris

Chris, I changed the dial-peer from 10 to 2 ten is off now.

my DID   number is 099043700 (why is it showing 3700?)

Peer Info Type=DIALPEER_INFO_SPEECH

*Apr 26 13:42:02.271: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:

   Result=Success(0) after DP_MATCH_ORIGINATE; Incoming Dial-peer=2

*Apr 26 13:42:02.271: //-1/xxxxxxxxxxxx/DPM/dpMatchSafModulePlugin:

   dialstring=NULL, saf_enabled=0, saf_dndb_lookup=0, dp_result=0

*Apr 26 13:42:02.271: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:

   Calling Number=8131694027, Called Number=3700, Voice-Interface=0x0,

   Timeout=TRUE, Peer Encap Type=ENCAP_VOICE, Peer Search Type=PEER_TYPE_VOICE,

   Peer Info Type=DIALPEER_INFO_FAX

*Apr 26 13:42:02.271: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:

   Result=NO_MATCH(-1) After All Match Rules Attempt

*Apr 26 13:42:02.271: //-1/xxxxxxxxxxxx/DPM/dpMatchSafModulePlugin:

   dialstring=NULL, saf_enabled=0, saf_dndb_lookup=0, dp_result=-1

*Apr 26 13:42:02.623: %ISDN-6-CONNECT: Interface Serial0/3/0:30 is now connected

to 8131694027 N/A

*Apr 26 13:42:08.183: %ISDN-6-DISCONNECT: Interface Serial0/3/0:30  disconnected

from 8131694027 , call lasted 5 seconds

*Apr 26 13:42:08.187: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:

   Calling Number=.T, Called Number=, Voice-Interface=0x0,

   Timeout=TRUE, Peer Encap Type=ENCAP_VOIP, Peer Search Type=PEER_TYPE_VOICE,

   Peer Info Type=DIALPEER_INFO_SPEECH

*Apr 26 13:42:08.187: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:

   Result=NO_MATCH(-1) After All Match Rules Attempt

*Apr 26 13:42:08.187: //-1/xxxxxxxxxxxx/DPM/dpMatchSafModulePlugin:

   dialstring=NULL, saf_enabled=0, saf_dndb_lookup=0, dp_result=-1

Is this complete debug? It does not show any called number.

Chris

*Apr 26 13:31:49.035: %ISDN-6-DISCONNECT: Interface Serial0/3/0:29  disconnected: L3_ProcessEvent: callref = 0x0000 Corwar

   Calling Number=, Called Number=080

from 8131694027 , call lasted 3 secondsETUP_REQ:U0_SetupReq(nlcb)990437004/0RIC

*Apr 26 13:31:49.035: ISDN Se0/3/0:15 Q931: call_disc: PI received in disconnectMatchPeersCore:aut

no modem enable-dial-peer)#dest

line

        source_id = Q.

; Postpone sending RELEASE for callid 0xB DL_DATA_REQ 0x0More--its - re

*Apr 26 1

*Apr 26 13:31:49.039: ISDN Se0/3/0:15 Q931: TX -> RELEASE pd = 8  callref = 0x8A 4 int_id = 0x888DC8FC datasize = 49peer v

   Dial String=08036, Expanded String

7303

*Apr 26 13:31:49.203: ISDN Se0/3/0:15 Q931: RX <- RELEASE_COMP pd = 8  callref = Timeout=FALSE, Is Incoming

*Apr 26 13:25:38.827:   888DC8FC00000300024004000001

0x0A73:44:31

CBN-AFRICA#no debug all lasted no exec s

!R

*Apr 26 13:31:49.035: %ISDN-6-DISCONNECT: Interface Serial0/3/0:29  disconnected: L3_ProcessEvent: callref = 0x0000 Corwar

   Calling Number=, Called Number=080

from 8131694027 , call lasted 3 secondsETUP_REQ:U0_SetupReq(nlcb)990437004/0RIC

*Apr 26 13:31:49.035: ISDN Se0/3/0:15 Q931: call_disc: PI received in disconnectMatchPeersCore:aut

no modem enable-dial-peer)#dest

line

        source_id = Q.

; Postpone sending RELEASE for callid 0xB DL_DATA_REQ 0x0More--its - re

*Apr 26 1

*Apr 26 13:31:49.039: ISDN Se0/3/0:15 Q931: TX -> RELEASE pd = 8  callref = 0x8A 4 int_id = 0x888DC8FC datasize = 49peer v

   Dial String=08036, Expanded String

7303

*Apr 26 13:31:49.203: ISDN Se0/3/0:15 Q931: RX <- RELEASE_COMP pd = 8  callref = Timeout=FALSE, Is Incoming

*Apr 26 13:25:38.827:   888DC8FC00000300024004000001

0x0A73:44:31

CBN-AFRICA#no debug all lasted no exec s

!R

This is my new dial-peer configurations

dial-peer voice 2 pots

destination-pattern .T

port 0/3/0:15

!

dial-peer voice 3 pots

destination-pattern .T

port 0/0/0

forward-digits all

!

dial-peer voice 4 pots

incoming called-number 099043700

direct-inward-dial

IS ANYTHING WRONG WITH IT?

It is showing 4 digits as that is probably how the PRI is defined for sign digits. Simply change your dial-peer 10 to use 3700 as the destination pattern to make it work.

Chris

This is my new debug voice dialpeer:

*Apr 26

CBN-AFRICA#: //-1/9025

CBN-AFRICA#  Peer Info

CBN-AFRICA#ER_INFO_SPE

CBN-AFRICA#

Building

   Timeout=TRUE, Peer Encap Type=ENCAP_VOICE, Peer Search Type=PEER_TYPE_VOICE,

   Peer Info Type=DIALPEER_INFO_SPEECH

*Apr 26 13:52:30.015: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:

   Result=Success(0) after DP_MATCH_ORIGINATE; Incoming Dial-peer=2

*Apr 26 13:52:30.015: //-1/xxxxxxxxxxxx/DPM/dpMatchSafModulePlugin:

   dialstring=NULL, saf_enabled=0, saf_dndb_lookup=0, dp_result=0

*Apr 26 13:52:30.015: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:

   Calling Number=8131694027, Called Number=3700, Voice-Interface=0x0,

   Timeout=TRUE, Peer Encap Type=ENCAP_VOICE, Peer Search Type=PEER_TYPE_VOICE,

   Peer Info Type=DIALPEER_INFO_FAX

*Apr 26 13:52:30.015: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:

   Result=NO_MATCH(-1) After All Match Rules Attempt

*Apr 26 13:52:30.015: //-1/xxxxxxxxxxxx/DPM/dpMatchSafModulePlugin:

   dialstring=NULL, saf_enabled=0, saf_dndb_lookup=0, dp_result=-1

*Apr 26 13:52:30.363: %ISDN-6-CONNECT: Interface Serial0/3/0:30 is now connected

to 8131694027 N/A

*Apr 26 13:52:31.131: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:

   Calling Number=.T, Called Number=, Voice-Interface=0x0,

   Timeout=TRUE, Peer Encap Type=ENCAP_VOIP, Peer Search Type=PEER_TYPE_VOICE,

   Peer Info Type=DIALPEER_INFO_SPEECH

*Apr 26 13:52:31.131: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:

   Result=NO_MATCH(-1) After All Match Rules Attempt

*Apr 26 13:52:31.131: //-1/xxxxxxxxxxxx/DPM/dpMatchSafModulePlugin:

   dialstring=NULL, saf_enabled=0, saf_dndb_lookup=0, dp_result=-1

Please post your full config.

Chris

This is my running config:

Current configuration : 2060 bytes

!

! Last configuration change at 14:01:34 UTC Fri Apr 26 2013

!

version 15.0

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname CBN-AFRICA

!

boot-start-marker

boot-end-marker

!

card type e1 0 3

!

no aaa new-model

!

!

!

network-clock-participate wic 3

!

dot11 syslog

ip source-route

ip cef

!

!

!

!

no ipv6 cef

!

!

!

!

multilink bundle-name authenticated

isdn switch-type primary-net5

!

!

!

!

!

!

voice-card 0

!

!

!

license udi pid UC560-T1E1-K9 sn FGL1525141N

!

!

controller E1 0/3/0

pri-group timeslots 1-31

!

!

!

!

!

!

!

!

interface GigabitEthernet0/0

no ip address

duplex auto

speed auto

!

!

interface Integrated-Service-Engine0/0

description Loopback interface used to manage integrated application module

no ip address

shutdown

!

!

interface GigabitEthernet0/1/0

!

!

interface GigabitEthernet0/1/1

!

!

interface GigabitEthernet0/1/2

!

!

interface GigabitEthernet0/1/3

description Interface used to communicate with integrated service modue

!

!

interface Serial0/3/0:15

no ip address

encapsulation ppp

isdn switch-type primary-net5

isdn overlap-receiving

isdn incoming-voice voice

no cdp enable

!

!

interface Vlan1

ip address 192.168.10.1 255.255.255.0

!

!

ip forward-protocol nd

!

no ip http server

no ip http secure-server

!

!

!

!

!

!

control-plane

!

voice-port 0/0/0

!

voice-port 0/0/1

!

voice-port 0/0/2

!

voice-port 0/0/3

!

voice-port 0/3/0:15

!

voice-port 0/1/0

!

voice-port 0/1/1

!

voice-port 0/1/2

!

voice-port 0/1/3

!

voice-port 0/4/0

auto-cut-through

signal immediate

input gain auto-control

description Music On Hold Port

description Music On Hold Port

!

!

dial-peer voice 2 pots

destination-pattern .T

port 0/3/0:15

!

dial-peer voice 3 pots

destination-pattern 3700

port 0/0/0

forward-digits all

!

dial-peer voice 4 pots

incoming called-number 099043700

direct-inward-dial

!

!

!

!

line con 0

no modem enable

line aux 0

line 2

no activation-character

forward-digits all

!

dial-peer voice 4 pots

incoming called-number 099043700

direct-inward-dial

!

!

!

!

line con 0

no modem enable

line aux 0

line 2

no activation-character

no exec

transport preferred none

transport input all

speed 115200

line vty 0 4

login

!

end

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: