cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Walkthrough Wednesdays
260
Views
0
Helpful
11
Replies
asmlicense
Beginner

CFNA/CFB to voicemail does not work while calling 2nd line

Hello all,

I have strange  problem with voicemail. Here are the situation:

Phone A ext: 1001

Phone B ext: 1002

All phones are configured with CFNA/CFB to voicemail. .

I call from mobile to 1001, pick up the call and leave it connected stay. Then I call from another mobile to 1001 again. I hear beep sound in the 2nd line. But after 12 sec. it does not forward to voicemail, just keeps calling.

Internally everything works fine. Even when I call from 1002 to 1001 and keep in connected, I call from mobile to 1001, the 2nd line forwards to voicemail after 12 sec.

So strangely 2nd line does not forward to voicemail when 2 calls from outside coming to the same extention.

Do you have any idea?

Environment are CUCM, CUC, 2921 router with fxo ports.

11 REPLIES 11
Brandon Buffin
Advisor

Check the Forward No Answer Internal/External and Forward Busy Internal/External settings for the DNs. Post the config here.

Brandon

here is config. I don't beleive anything is wrong here. As I said, forwarding works when I do only one call from outside. But when I do 2 outside to inside call, the second call does not forwarded.

Do both DNs have the same configuration?

All DNs have the same configs.

Your original post indicated you are using FXO ports. So, is your first call to the number associated with port 1? Second call is to the same number and your carrier is forwarding the call to the second line based on a hunt group? Or second call is to a different number associated with a different FXO port? All ports send calls to DN 1001?

Mobile call comes in to certain fxp port and connection plar is set to DN. Second call is the same number, yes.

This is the configs in router:
voice-port 0/0/0
input gain -5
no vad
connection plar opx immediate 104
caller-id enable

voice translation-rule 1
rule 1 /104/ /102/

voice translation-profile 104
translate called 1

dial-peer voice 1 pots
description Default inbound dial-peer for calls from PSTN
translation-profile incoming 104
incoming called-number .
direct-inward-dial
port 0/0/0

102 is local DN which accepts the call. I don't understand actually, why translation-rule is needed here. Connection plar could be set to 102 directly, couldn't be?

Yes, connection plar can take care of this. I'm not sure the translation rule is taking effect since it would translate a called number of 104 to 102. However, the connection plar command would send calls to 104. Which DN should calls be forwarded to - 102 or 104? If you remove the translation profile from the dial peer do you get the same result?

I guess, call is sent to 104, but then router translates it to 102. At the DN is 102, who accept the call.

Don't you think that it could be codec issue?

I would recommend removing the translation profile and changing the connection plar command to send to 102. The config above seems to add complexity. Is this config the same for all voice ports? Can you post the outbound dial peer to CUCM?

I also think so. In the meanwhile, I see both sccp and sip trunk to CUC. I will make configurations simpler and get you back soon. Please keep in contact to solve this problem :)
Here are dial-peers to CUCM:
dial-peer voice 200 voip
description **Inbound Extension**
destination-pattern 20[01]
session target ipv4:172.27.199.11
voice-class codec 1
dtmf-relay h245-alphanumeric
no vad
dial-peer voice 202 voip
description **Inbound Extension**
destination-pattern 102
session target ipv4:172.27.199.11
voice-class codec 1
dtmf-relay h245-alphanumeric
no vad
dial-peer voice 203 voip
description **VM**
destination-pattern 888
session target ipv4:172.27.199.11
voice-class codec 1
dtmf-relay h245-alphanumeric
no vad

Content for Community-Ad

Spotlight Awards 2021