cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
146
Views
0
Helpful
0
Replies
Highlighted
Beginner

Cisco CME incoming calls give busy signal

Hi folks, 

 

I've been racking my brain for hours over this and finally after hours of internet searching and reading technical manuals, I feel like I should turn to the community for help because I feel as though I am missing something super easy. I am trying to set up a lab CME on a 2821 router in my test lab and have gotten the system set up, a couple of extensions running and a SIP trunk registered with outbound calling working, but for the life of me cannot figure out how to get inbound calling from elsewhere working properly. All I get from dialing the number of the CME is a busy signal. 


Below is the #show run of the router. Below that is a debug of when an incoming call from my cell comes in. Sensitive information has been removed. Basically the way this is supposed to work is the cme number is dialed, it matches it, rings 1010 which is a parallel group which rings 1001 1002 1003 and 1004. 

 

cme0#show run 
Building configuration...


Current configuration : 9753 bytes
!
! Last configuration change at 22:34:54 EST Fri Aug 7 2020
! NVRAM config last updated at 22:35:00 EST Fri Aug 7 2020
! NVRAM config last updated at 22:35:00 EST Fri Aug 7 2020
version 15.1
service timestamps debug datetime msec
service timestamps log datetime localtime
service password-encryption
!
hostname cme0
!
boot-start-marker
boot-end-marker
!
!
logging buffered 51200 warnings
enable secret 5 (redacted)
!
no aaa new-model
!
clock timezone EST -5 0
clock summer-time EST recurring
!
dot11 syslog
ip source-route
!
!
ip cef
!
ip dhcp excluded-address 10.200.5.1 10.200.5.9
!
ip dhcp pool VOICE_VLAN_DHCP
 network 10.200.5.0 255.255.255.0
 default-router 10.200.5.1 
 option 150 ip 10.200.5.1 
!
ip dhcp pool DATA_VLAN_DHCP
 network 10.200.6.0 255.255.255.0
 default-router 10.200.6.1 
 dns-server 8.8.8.8 
!
!
ip domain timeout 2
ip name-server 8.8.8.8
ip name-server 4.2.2.2
no ipv6 cef
!
multilink bundle-name authenticated
!
!         
!
!
!
!
!
voice service voip
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 no supplementary-service sip handle-replaces
 sip
  registrar server expires max 600 min 60
!
voice class codec 1
 codec preference 1 g711ulaw
 codec preference 2 g711alaw
 codec preference 3 g729br8
!
voice class sip-profiles 1
 response ANY sip-header Contact modify "10.200.1.250" "firewall_public_IP" 
 request ANY sip-header Contact modify "10.200.1.250" "firewall_public_IP" 
 response ANY sdp-header Audio-Connection-Info modify "10.200.1.250" "firewall_public_IP" 
 response ANY sdp-header Connection-Info modify "10.200.1.250" "firewall_public_IP" 
 response ANY sdp-header Session-Owner modify "10.200.1.250" "firewall_public_IP" 
 request ANY sdp-header Audio-Connection-Info modify "10.200.1.250" "firewall_public_IP" 
 request ANY sdp-header Connection-Info modify "10.200.1.250" "firewall_public_IP" 
 request ANY sdp-header Session-Owner modify "10.200.1.250" "firewall_public_IP" 
!
!
voice hunt-group 4 parallel
 final 2000
 list 1001,1002,1003,1004
 timeout 20 
 pilot 1010 
!
!
!
!
voice translation-rule 1
 rule 1 /^9911/ /911/
 rule 2 /^9411/ /411/
 rule 3 /^9\(..........\)$/ /\1/
 rule 4 /^9\(1..........\)$/ /\1/
 rule 5 /^9011/ //
 rule 6 /..../ /number_of_cme/ 
!
voice translation-rule 6
 rule 7 /number_of_cme/ /1010/
!
!
voice translation-profile Incoming_to_Ext
 translate calling 6
 translate called 6
!
voice translation-profile Strip9
 translate calling 1
 translate called 1
!
!
voice-card 0
!
crypto pki token default removal timeout 0
!
!
!
!
license udi pid CISCO2821 sn x
!
redundancy
!
!
!
translation-rule 1
 Rule 0 ^1xxx xxx
!
! 
!
!
!
!
!
!
!
interface GigabitEthernet0/0
 shutdown
!
interface GigabitEthernet0/1
 description Internal Network
 ip address 10.200.1.250 255.255.255.0
 load-interval 30
 duplex auto
 speed auto
!
interface GigabitEthernet0/1.150
 encapsulation dot1Q 150
 ip address 10.200.5.1 255.255.255.0
 no cdp enable
!
interface GigabitEthernet0/1.160
 encapsulation dot1Q 160
 ip address 10.200.6.1 255.255.255.0
 no cdp enable
!
ip default-gateway 10.200.1.1
ip forward-protocol nd
ip http server
ip http secure-server
ip http timeout-policy idle 5 life 86400 requests 10000
ip http path flash:
!
!
ip dns view default
 domain timeout 2
ip dns server
ip route 0.0.0.0 0.0.0.0 10.200.1.1
!
!
!
!
!
!
tftp-server flash:/PHONES/SCCP42.9-3-1SR3-1S.loads alias SCCP42.9-3-1SR3-1S.loads
tftp-server flash:/PHONES/apps42.9-3-1ES19.sbn alias apps42.9-3-1ES19.sbn
tftp-server flash:/PHONES/cnu42.9-3-1ES19.sbn alias cnu42.9-3-1ES19.sbn
tftp-server flash:/PHONES/cvm42sccp.9-3-1ES19.sbn alias cvm42sccp.9-3-1ES19.sbn
tftp-server flash:/PHONES/dsp42.9-3-1ES19.sbn alias dsp42.9-3-1ES19.sbn
tftp-server flash:/PHONES/jar42sccp.9-3-1ES19.sbn alias jar42sccp.9-3-1ES19.sbn
tftp-server flash:/PHONES/term42.default.loads alias term42.default.loads
tftp-server flash:/PHONES/term62.default.loads alias term62.default.loads
!
control-plane
!
!
!
!
mgcp profile default
!
!
dial-peer voice 2002 voip
 description Outgoing call to SIP Trunk 
 translation-profile outgoing Strip9
 destination-pattern 91[2-9]..[2-9]......
 session protocol sipv2
 session target dns:registrar_dns_address
 session transport udp
 voice-class sip profiles 1
 voice-class sip bind control source-interface GigabitEthernet0/1
 voice-class sip bind media source-interface GigabitEthernet0/1
 dtmf-relay rtp-nte
 codec g711ulaw
 no vad
!
dial-peer voice 2000 voip
 description Incoming call from SIP Trunk
 translation-profile incoming Incoming_to_Ext
 session protocol sipv2
 session target registrar
 incoming called-number .%
 voice-class sip bind control source-interface GigabitEthernet0/1
 voice-class sip bind media source-interface GigabitEthernet0/1
 dtmf-relay rtp-nte
 codec g711ulaw
 no vad
!
!
sip-ua 
 credentials username (redacted) password 7 (redacted) realm registrar_dns_address
 authentication username (redacted) password 7 (redacted)
 retry invite 2
 retry bye 2
 retry cancel 2
 retry register 10
 registrar dns:registrar_dns_address expires 3600
 sip-server dns:registrar_dns_address
 reason-header override
 connection-reuse
 host-registrar
!
!
!
gatekeeper
 shutdown
!
!
telephony-service
 max-ephones 42
 max-dn 144
 ip source-address 10.200.5.1 port 2000
 cnf-file location flash:
 cnf-file perphone
 load 7962 SCCP42.9-4-2SR3-1S.loads
 max-conferences 8 gain -6
 web admin system name user secret 5 (redacted)
 dn-webedit 
 time-webedit 
 transfer-system full-consult
 create cnf-files version-stamp Jan 01 2002 00:00:00
!         
!
ephone-dn  1
 number 1001 no-reg primary
 name Test 1
!
!
ephone-dn  2
 number 1002 no-reg primary
!
!
ephone-dn  3
 number 1003 no-reg primary
 name Test 3
!
!
ephone-dn  10
 number 1010
!
!
ephone-dn  144
 number 3999 no-reg primary
 paging
!
!
ephone  1
 device-security-mode none
 mac-address 0026.0BD7.C1DF
 paging-dn 150
 type 7962
 button  1:1
!
!
!
ephone  2
 device-security-mode none
 mac-address 001B.2A20.2373
 paging-dn 150
 type 7970
 button  1:2
!
!
!
ephone  3
 device-security-mode none
 mac-address 001B.2A89.8ABE
 paging-dn 150
 type 7970
 button  1:3
!
!
!         
!
line con 0
line aux 0
line vty 0 4
 password 7 (redacted)
 login
 transport input telnet
line vty 5 15
 password 7 (redacted)
 login
 transport input telnet
!
scheduler allocate 20000 1000
ntp master
ntp update-calendar
ntp server x.x.x.x
end

Debug:

cme0#debug ccsip message
SIP Call messages tracing is enabled
cme0#debug ccsip error
SIP Call error tracing is enabled
cme0#
Aug  8 02:51:21.047: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received: 
INVITE sip:cme_number@10.200.1.250:5060 SIP/2.0
Via: SIP/2.0/UDP registrar_ip:5065;branch=z9hG4bK54cq5l204g7u3ocukfq0.1
Contact: <sip:cellphone_number@registrar_ip:5065;transport=udp>
CSeq: 4966 INVITE
Content-Length: 342
Content-Type: application/sdp
Call-ID: S08T20200808025121U1980322@10.3.135.171
From: "WIRELESS CALLER" <sip:cellphone_number@registrar_ip:5065>;tag=S08T20200808025121U1980323_DIDcme_number
To: sip:cme_number@firewall_public_IP:1145;transport=udp
Diversion: sip:cme_number@null;reason=unconditional
Max-Forwards: 67
Session-Expires: 1800;refresher=uac
Allow: INVITE
Allow: ACK
Allow: PRACK
Allow: CANCEL
Allow: BYE
Allow: REFER
Allow: NOTIFY
Allow: OPTIONS
Allow: MESSAGE
Allow: INFO
Allow: REGISTER
Allow: SUBSCRIBE
Supported: timer

v=0
o=Sonus_UAC 685181 101165 IN IP4 198.204.63.224
s=SIP Media Capabilities
c=IN IP4 registrar_ip
t=0 0
m=audio 21394 RTP/AVP 18 0 8 101
a=rtpmap:18 G729/8000
a=fmtp:18 annexb=no;mr=0;mg=0;jmdelay=no;mrmods=
a=rtpmap:0 PCMU/8000
a=rtpmap:8 PCMA/8000
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-15
a=sendrecv
a=maxptime:20

SIP: (176) Attribute mid, level 1 instance 1 not found.
Aug  8 02:51:21.055: //176/DFBA5EAA80B1/SIP/Error/sipSPI_ipip_update_codec_params_in_channelInfo: 
failed to update call entry
Aug  8 02:51:21.055: //176/DFBA5EAA80B1/SIP/Error/sipSPI_ipip_update_call_entry: 
failed to update call entry
Aug  8 02:51:21.055: //-1/xxxxxxxxxxxx/SIP/Error/sipSPI_ipip_set_channel_count: Unable to set CHANNEL_COUNT for callid 176
Aug  8 02:51:21.055: //176/DFBA5EAA80B1/SIP/Error/sip_iwf_sip_copy_sdp_to_channelInfo: Channel count is not set at this point. Not SIP-SIP or SET_MODE is not done.
Aug  8 02:51:21.059: //176/DFBA5EAA80B1/SIP/Msg/ccsipDisplayMsg:
Sent: 
SIP/2.0 100 Trying
Via: SIP/2.0/UDP registrar_ip:5065;branch=z9hG4bK54cq5l204g7u3ocukfq0.1
From: "WIRELESS CALLER" <sip:cellphone_number@registrar_ip:5065>;tag=S08T20200808025121U1980323_DIDcme_number
To: sip:cme_number@firewall_public_IP:1145;transport=udp
Date: Sat, 08 Aug 2020 02:51:21 GMT
Call-ID: S08T20200808025121U1980322@10.3.135.171
CSeq: 4966 INVITE
Allow-Events: telephone-event
Server: Cisco-SIPGateway/IOS-12.x
Content-Length: 0


Aug  8 02:51:21.063: //176/DFBA5EAA80B1/SIP/Msg/ccsipDisplayMsg:
Sent: 
SIP/2.0 403 Forbidden
Via: SIP/2.0/UDP registrar_ip:5065;branch=z9hG4bK54cq5l204g7u3ocukfq0.1
From: "WIRELESS CALLER" <sip:cellphone_number@registrar_ip:5065>;tag=S08T20200808025121U1980323_DIDcme_number
To: sip:cme_number@firewall_public_IP:1145;transport=udp;tag=B1C9E0-11B5
Date: Sat, 08 Aug 2020 02:51:21 GMT
Call-ID: S08T20200808025121U1980322@10.3.135.171
CSeq: 4966 INVITE
Allow-Events: telephone-event
Server: Cisco-SIPGateway/IOS-12.x
Reason: Q.850;cause=21
Content-Length: 0


Aug  8 02:51:21.099: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received: 
ACK sip:cme_number@10.200.1.250:5060 SIP/2.0
Via: SIP/2.0/UDP registrar_ip:5065;branch=z9hG4bK54cq5l204g7u3ocukfq0.1
CSeq: 4966 ACK
Call-ID: S08T20200808025121U1980322@10.3.135.171
From: "WIRELESS CALLER" <sip:cellphone_number@registrar_ip:5065>;tag=S08T20200808025121U1980323_DIDcme_number
To: <sip:cme_number@firewall_public_IP:1145>;transport=udp;tag=B1C9E0-11B5
Max-Forwards: 67
Content-Length: 0

no debug all
All possible debugging has been turned off

Let me know if any more information would be helpful.

0 REPLIES 0