cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Walkthrough Wednesdays
2485
Views
30
Helpful
14
Replies
dsobrinho
Engager

Cisco ova to CUCM, CUCM IM&P version 12.x and UCCX 11.6 does not work properly in ESXi 6.5

Hi 

 

I have a problem to use the ova cucm 12.x, cucm im&P 12.x, uccx 11.5 with vmware ESXi 6.5. 

 

According to Cisco documentation these ovas are compatible. There are a lot of posts on the  Cisco Forums about problem, including anothers solutions. What happens when the ova is uploaded to ESXi 6.5, it should raise the standard hardware for the type of installation, except that it already gives error right away, it unconfigures all the hardware.

 

Using a tool called vmware ovftools via cli it is possible to perform the conversion of OVA into OVF, but even after uploading this hardware in vmware it is necessary to configure the hardware manually. (This workaround is not supported by Cisco).

 

Does anybody knows something that? In the  Cisco repository there is still have the same version of ova without proper settings for ESXi 6.5.

Matrix CUCM12.png

 

Best regards

 

 

Daniel Sobrinho
14 REPLIES 14
Chris Deren
Hall of Fame Master

They are fully compatible, what error are you getting?

What is your full ESXI version, you want to be on 6.5U2+ to address some OVA deployment issues with Unity Connection.

Hi @Chris Deren,

The ESXi version is 6.5.0 Build number: 8294253
In resume: ESXi 6.5 U2
I have not tested with ova of Unity Connection yet.

When I  have uploaded the ova cucm_12.0_vmv8_v1.0.ova and selected the hardware for CUCM 10000 users the error is displayed:

"At least one extra disk image was provided that will be ignored."

 

I have found some bugs related: CSCvh75620, CSCVe22405.

 

Daniel Sobrinho

We have bad experence with this ovas:

 

Using: vmware ESXi 6.5.0 Build number: 8294253

 

Cisco OVA files:

cucm_im_p_12.0_vmv8_v1.4.ova

CUCM 12.xCUCM 12.x

 

CUCM IM & Presence 12.x

 cucm_im_p_12.0_vmv8_v1.4.ova

CUCM IMP 12.xCUCM IMP 12.x

UCCX 11.6

UCCX_11.6_vmv8_v2.5.ova           

UCCX 11.6UCCX 11.6

 

 

 

Daniel Sobrinho

I have tried with version ESXi 6.0

 

Same problem:CUCM 12.x vmware 6.0CUCM 12.x vmware 6.0

 

CUCM IMP 12.x vmware 6.0CUCM IMP 12.x vmware 6.0

 

UCCX 11.6 vmware 6.0UCCX 11.6 vmware 6.0

 

 

 

 

Daniel Sobrinho

Hi team,

 

new information here:

 

In the ESXi 6.0 I can use the vsphere client. Now we installed the vsphere client and believe or not, the provisioning works fines with vsphere client 6.x.

 

The problem is with web tools from vmware!!!! However in the version 6.5 does not have vsphfere client only web client.

Now We have made the same test with web tools from version 5.5, and the results problem was the same in web client. When we deploy the ova in vsphere client it works fine.

 

Workaround for version before vmware 6.0 is not use the web client tools, use the vsphere client.

 

 

Daniel Sobrinho

Hi team,

 

 

WHY CISCO DOES NOT CHECK THIS PROBLEM AND PROVIDE US UPDATE ABOUT THIS PROBLEM. IN THE VERSION ESXi 6.5 THERE IS NOT VSPHERE CLIENT... HOW CAN I FIX THE PROBLEM?????

 

From what I could verify this happens since the version ESXi 5.5 that made the web client available for provisioning!!!!

Daniel Sobrinho

Run latest SU on 6.5 or alternatively install vmware Fling on your host.

hi @Chris Deren

 

Same problem happen!

Daniel Sobrinho

Hi @Chris Deren,

 

I have opened a tac for that problem.

I have a case opened since september 25th. No workaround. 

 

 

Daniel Sobrinho

Did you ever get a resolution from your TAC case?  I have this problem now as well.

 

Thanks,

Tim

pqueued
Beginner

The 6.5 base embedded host client is super buggy. What you need to do is update the client and all your problems will go away with OVA imports.
You need this file"VMware_bootbank_esx-ui_1.31.0-9277095.vib"

1. https://labs.vmware.com/flings/esxi-embedded-host-client

2. Select the esxui-offline-bundle-6.x-10692217.zip and download it

3. In the archive its under the /vib20/esx-ui/ directory.


Once you have the file~
1. Enable ssh in esxi--Host>Actions>Services>Enable SSH
2. Copy the VMFS volume info and paste it in your fav text editor or w/e--Storage>Datastore1 (or whatever); you are wanting to copy the location, will be like /vmfs/volumes/<UUID>
3. Create a folder in your datastore (that you copied the volume info for) e.g. "vib" and copy the file to that directory.
4. SSH into esxi and enter the following "esxcli software vib install -v <paste the VMFS location from text editor>/vib/VMware_bootbank_esx-ui_1.31.0-9277095.vib"

The embedded client will be updated to a stable version and the OVA's will now run smoothly, you will be able to modify settings without settings becoming negative values or clearing out completely, you will be able to actually do thick provisioning, install VCS 8.11.x, etc.

 

Is this for the HTML5 or Flash based client? Also, if I'm not mistaken, you can still use the thick client for ESXi 6.5, you just can't for vCenter 6.5.

6.5 is HTML5, I believe the absolute original base version of the Cisco 6.5 ESXi image you could still use the C# client, however using the embedded client is now mandatory which is where the problems are presenting. First BE I was sent w/ 6.5 I was able to provision w/ the C# client, all subsequent BE's I have deployed since I have been forced to use the web client. I have seen all sorts of bugs from having to add network adapters via CLI b/c the gui couldnt see them, to the issues described by the OP, to the latest with the failure of deploying VCS 8.10.3 (and 8.11.X) where you get the below:

 

TypeError: Cannot read property 'replace' of null
    at https://x.x.x.y/ui/scripts/main.js:368:13460
    at Object.r [as forEach] (https://x.x.x.y/ui/scripts/main.js:318:21020)
    at https://x.x.x.y/ui/scripts/main.js:368:13149
    at Object.r [as forEach] (https://x.x.x.y/ui/scripts/main.js:318:21126)
    at getPropertyFields (https://x.x.x.y/ui/scripts/main.js:368:12906)
    at Object.<anonymous> (https://x.x.x.y/ui/scripts/main.js:368:15748)
    at Object.e [as invoke] (https://x.x.x.y/ui/scripts/main.js:319:3874)
    at w.instance (https://x.x.x.y/ui/scripts/main.js:319:23885)
    at https://x.x.x.y/ui/scripts/main.js:319:15273
    at r (https://x.x.x.y/ui/scripts/main.js:318:21126)

Following the steps outlines in my above post resolved every issue.

Wow, that's pretty terrible. Thanks for sharing what you know on the topic.
Content for Community-Ad

Spotlight Awards 2021