cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

390
Views
5
Helpful
2
Replies
sbeukenkamp
Beginner

Cisco Personal Communications Assistant and HTTPS

Hi,

CPCA is working perfectly when using http, but when moving to https things start falling down.

SAWeb is working just fine using https.

When connecting to https://um01/ciscopca/logon.do I get directly on the login page " Unable to contact server. Try logging on again in a few minutes...."

I ran to the troubleshooting guide and everythings seems to be fine.

Including output from ciscopca_event_log.txt. It seems to me that somewhere still the url http is used....

ERROR com.cisco.ecsbu.cpca.data.access.AvxmlConnector - AvxmlConnector.generateResponse() IOException Server returned HTTP response code: 403 for URL: http://TF-DT01-UM01/Avxml/AvxmlSvr.dll

2005-04-29 06:48:24.243 [Thread-10] WARN com.cisco.ecsbu.cpca.data.access.AvxmlConnector - sendEnvelope: no response generated

2005-04-29 06:48:24.243 [Thread-10] ERROR com.cisco.ecsbu.cpca.data.DataAccessManager - sendEnvelope() - send failed returning fault

2005-04-29 06:48:24.243 [Thread-10] ERROR com.cisco.ecsbu.cpca.actions.LogonAction - populateLogonModel - error retrieving logon information - fault - server must be down

<?xml version="1.0" encoding="UTF-16"?>

<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/">

<SOAP-ENV:Header/>

<SOAP-ENV:Body>

<SOAP-ENV:Fault>

<SOAP-ENV:faultcode>SOAP-ENV:Server</SOAP-ENV:faultcode>

<SOAP-ENV:faultactor>DataAccessManager</SOAP-ENV:faultactor>

<SOAP-ENV:faultstring>CONNECTION FAILED</SOAP-ENV:faultstring>

<SOAP-ENV:detail>Connection to the unity server(s) has failed</SOAP-ENV:detail>

</SOAP-ENV:Fault>

</SOAP-ENV:Body>

</SOAP-ENV:Envelope>

2005-04-29 06:48:24.259 [Thread-10] ERROR com.cisco.ecsbu.cpca.actions.LogonAction - perform - Attribute "PROVIDER" unknown/unset value: null

2005-04-29 06:48:24.259 [Thread-10] WARN com.cisco.ecsbu.cpca.actions.LogonAction - perform - Attribute "PROVIDER" will be defaulted to: Windows

2005-04-29 06:48:47.994 [Thread-10] ERROR com.cisco.ecsbu.cpca.data.access.AvxmlConnector - AvxmlConnector.generateResponse() IOException Server returned HTTP response code: 403 for URL: http://TF-DT01-UM01/Avxml/AvxmlSvr.dll

2005-04-29 06:48:47.994 [Thread-10] WARN com.cisco.ecsbu.cpca.data.access.AvxmlConnector - sendEnvelope: no response generated

2005-04-29 06:48:48.009 [Thread-10] ERROR com.cisco.ecsbu.cpca.data.DataAccessManager - sendEnvelope() - send failed returning fault

2005-04-29 06:48:48.009 [Thread-10] ERROR com.cisco.ecsbu.cpca.actions.LogonAction - populateLogonModel - error retrieving logon information - fault - server must be down

<?xml version="1.0" encoding="UTF-16"?>

<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/">

<SOAP-ENV:Header/>

<SOAP-ENV:Body>

<SOAP-ENV:Fault>

<SOAP-ENV:faultcode>SOAP-ENV:Server</SOAP-ENV:faultcode>

<SOAP-ENV:faultactor>DataAccessManager</SOAP-ENV:faultactor>

<SOAP-ENV:faultstring>CONNECTION FAILED</SOAP-ENV:faultstring>

<SOAP-ENV:detail>Connection to the unity server(s) has failed</SOAP-ENV:detail>

</SOAP-ENV:Fault>

</SOAP-ENV:Body>

</SOAP-ENV:Envelope>

2005-04-29 06:48:48.009 [Thread-10] ERROR com.cisco.ecsbu.cpca.actions.LogonAction - perform - Attribute "PROVIDER" unknown/unset value: null

2005-04-29 06:48:48.009 [Thread-10] WARN com.cisco.ecsbu.cpca.actions.LogonAction - perform - Attribute "PROVIDER" will be defaulted to: Windo

2 REPLIES 2
path
Beginner

Make sure that none of the SSL (certificate) checkboxes are checked for the /Avxml/AvxmlSvr.dll file from the IIS manager.

Then if that is not the case, know that the 403 code seen is (but not limited to)

o SSL required to view page,

o Read permission denied

o Execute permission denied

o ...

The SSL required sounds like the issue here.

PatH

I forgot to add,

Even if the SSL checkboxes is grayed out, don't be fooled; the setting is active if it is checked even if the checkbox is disabled.

Example 1: Require Secure channel unchecked

[] Require Secure Channel (SSL)

[x] Require 128-bit encryption <- grayed out but active

You will need to first check the secure channel box, this will enable the 128-bit box. Then uncheck the 128-bit box and uncheck the secure channel box.

That's what I meant by make sure both box are unchecked.

PatH

Create
Recognize Your Peers
Content for Community-Ad