cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
25095
Views
20
Helpful
24
Replies
Roger Jin
Beginner

Cisco Sync Agent is not running - IM and Presence 10.x (new installed)

Hi Guys,

I recently re-installed my lab UC with version 10, however I could not get "Cisco Sync Agent" service running on IM server.

Everything else looks fine. I think I must miss reconfigured something however I went through the document, could not figure out.

I have added the IM server into the CUCM. What else I need to do?

 

1 ACCEPTED SOLUTION

Accepted Solutions

I just had the same issue in Cisco IM and Presence 9.1. After the server access got really slow and I tried almost everything but reinstalling, I noticed that my AXL user password had a @ and after I removed it, everything magically started to work and the slowness went away.

It's really bad that a special character can do this to the whole system but now I can tell you that everything is back to normal, the only issue I'm facing now is that users on one server of the cluster cannot IM with users in the other server of the same cluster, but that's for another post.

hope this is useful.

Best regards

View solution in original post

24 REPLIES 24
bobby.jacob
Beginner

Hi hareluya,

 

Iam also having the same issue, looks like its a BUG? Sync service shows always 'starting' and then it stops by itself.

I had installed with CUCM 10.0.1 and IMP also with 10.0.1.

Can i know exactly which version you have? Iam now Planning to upgrade both the servers to 10.5

tnx

 

I tried both version 10.1 and 10.5 however got  exactly same problem.

I can't believe if it is a bug.

 

 

Hi,

I did upgrade to 10.0.1 SU1 today, still problem persist. Sync service not starting, all other services are up. Is it time call TAC?

Sorted

If you still have the problem, try different password.

The same password works fine for UI_Admin, however as this account also been used for the AXL user and it just does not like it.

I just had the same issue in Cisco IM and Presence 9.1. After the server access got really slow and I tried almost everything but reinstalling, I noticed that my AXL user password had a @ and after I removed it, everything magically started to work and the slowness went away.

It's really bad that a special character can do this to the whole system but now I can tell you that everything is back to normal, the only issue I'm facing now is that users on one server of the cluster cannot IM with users in the other server of the same cluster, but that's for another post.

hope this is useful.

Best regards

I have the problem too version 11.5.1SU2. I am seeing this message in the service manager log:

ame="Cisco Sync Agent" Status="Stopped"><ReasonCode>-1019</ReasonCode>

Does someone know what 1019 is? I changed password to remove a , (comma) from the password but, it has not helped.

Hi,

  The sync agent trace file you attached has these errors that are related to AXL (Application) username and password.

 

2014-06-23 15:13:25,261 INFO  [main] axl.AXLClientLogger - AXLClientConnectionConfig:
Username: administrator
Host: 10.153.15.3
Port: 8443
URL With Credentials:https://administrator:*****@10.153.15.3:8443/axl/
URL without Credentials :https://10.153.15.3:8443/axl/
2014-06-23 15:13:31,965 ERROR [AXL Runner for parent thread ID:1 (main)] axl.AXLClientLogger - sendSOAPRequest() :: Received SOAPException.
com.sun.xml.messaging.saaj.SOAPExceptionImpl: java.security.PrivilegedActionException: com.sun.xml.messaging.saaj.SOAPExceptionImpl: Bad response: (401Unauthorized
	at com.sun.xml.messaging.saaj.client.p2p.HttpSOAPConnection.call(HttpSOAPConnection.java:191)
	at com.cisco.cup.axlclient.AXLClientBase.sendSOAPRequest(AXLClientBase.java:377)
	at com.cisco.cup.axl.AxlClient$AxlRunner.run(AxlClient.java:603)
	at java.lang.Thread.run(Thread.java:744)
Caused by: java.security.PrivilegedActionException: com.sun.xml.messaging.saaj.SOAPExceptionImpl: Bad response: (401Unauthorized
	at java.security.AccessController.doPrivileged(Native Method)
	at com.sun.xml.messaging.saaj.client.p2p.HttpSOAPConnection.call(HttpSOAPConnection.java:185)
	... 3 more
Caused by: com.sun.xml.messaging.saaj.SOAPExceptionImpl: Bad response: (401Unauthorized
	at com.sun.xml.messaging.saaj.client.p2p.HttpSOAPConnection.post(HttpSOAPConnection.java:368)
	at com.sun.xml.messaging.saaj.client.p2p.HttpSOAPConnection$PriviledgedPost.run(HttpSOAPConnection.java:214)
	... 5 more

CAUSE:

java.security.PrivilegedActionException: com.sun.xml.messaging.saaj.SOAPExceptionImpl: Bad response: (401Unauthorized
	at java.security.AccessController.doPrivileged(Native Method)
	at com.sun.xml.messaging.saaj.client.p2p.HttpSOAPConnection.call(HttpSOAPConnection.java:185)
	at com.cisco.cup.axlclient.AXLClientBase.sendSOAPRequest(AXLClientBase.java:377)
	at com.cisco.cup.axl.AxlClient$AxlRunner.run(AxlClient.java:603)
	at java.lang.Thread.run(Thread.java:744)
Caused by: com.sun.xml.messaging.saaj.SOAPExceptionImpl: Bad response: (401Unauthorized
	at com.sun.xml.messaging.saaj.client.p2p.HttpSOAPConnection.post(HttpSOAPConnection.java:368)
	at com.sun.xml.messaging.saaj.client.p2p.HttpSOAPConnection$PriviledgedPost.run(HttpSOAPConnection.java:214)
	... 5 more
2014-06-23 15:13:31,993 ERROR [AXL Runner for parent thread ID:1 (main)] axl.AXLClientLogger - sendSOAPRequest() :: 401-Permission Denied.Authorisation failed. Possibly invalid credentials
2014-06-23 15:13:32,000 ERROR [AXL Runner for parent thread ID:1 (main)] axl.AXLClientLogger - Error in AXL request
com.cisco.cup.axlclient.AXLExceptionMessageDenied: Authorisation failed. Possibly invalid credentials
	at com.cisco.cup.axlclient.AXLClientBase.sendSOAPRequest(AXLClientBase.java:399)
	at com.cisco.cup.axl.AxlClient$AxlRunner.run(AxlClient.java:603)
	at java.lang.Thread.run(Thread.java:744)
2014-06-23 15:13:32,000 ERROR [main] axl.AXLClientLogger - AXL call reported error

Sync agent service won't stay up and running if it cannot connect to CUCM using the application username and password configured on CUCM. One quick test to verify if the credentials are working is by typing https://<cucm ip address>/axl/ and enter 'administrator' as the userid and the password. If there is an error on the web page, then that explains the reason.

If there is no error, then a tac case will be required as troubleshooting will require remote access to IM&P server to verify some files. We have some previous cases for the same issue that required root access.

Sankar

Cisco TAC.

 

 

Thanks for your reply Sankar

I just tried "administrator" with the link https://<cucm ip address>/axl/, got below:

Cisco CallManager: AXL Web Service

The AXL Web Service is working and accepting requests. Use HTTP POST to send a request.

 

So, a TAC case is required? 

Hareluya,

       A TAC case will help so that we can retrieve the platformConfig file using the root account. While opening the case, can you include the below information?

1. Output of the below sql queries from CUCM and IMP servers.

run sql select applicationuser.name , credential.credentials from applicationuser inner join credential on applicationuser.pkid=credential.fkapplicationuser where credential.tkcredential=3 and applicationuser.name='ccmadministrator'

run sql select applicationuser.name , credential.credentials from applicationuser inner join credential on applicationuser.pkid=credential.fkapplicationuser where credential.tkcredential=3 and applicationuser.name='administrator'

2. From presence admin cli:

run sql select * from epassyncagentcfg

3. Screenshot of CUCM Administration Page > User Management > Application User page.

Do you remember the cucm administration username configured during installation? Is it 'administrator' or it was something else during installation and changed to 'administrator' after installation?

Sankar

 

 

 

Hi Sankar

Please see below output, the administrator was from the installation and never been changed.

 

I could not open TAC case as it is part of our partner NFR bundle which does not have sopport...

hi Sankar,

 

I'm sorry for bumping this discussion but thanks to your post I sorted out my problem and stuck at solving it.
I want to change password for AXL user or maybe whole username\password in the CUP server. my CUP and CUCM servers are already deployed and I can't find where I can change this password and I haven't menu like this - "System > CUCM Publisher" in my CUP server:

my CUP and CUCM version is 10.5

thanks!

HI, I am having same issue with 11.5 version . Can you please take a look I will attach screenshots ans ouptut commands u mentioned ?  

Jaime Valencia
Hall of Fame Cisco Employee

I didn't face such problem in my lab with the base 10.0 versions, I'm running now the SU1 and don't see the issue either, have you tried the SU1??

HTH

java

if this helps, please rate

I have attached the logs.....It seems multiple errors there... 

Create
Recognize Your Peers
Content for Community-Ad