Showing results for 
Search instead for 
Did you mean: 

Christian Klier

Cisco UC Integration for Lync cannot connect to desk phone

Hello, I tried to work with Cisco UC Integration for Lync in version 9.2.5.

We're using Cisco UCM ver 8.2.6 and Lync Server 2013 with client 2013.

I can use the computer for calls very well and I can dial from Lync client.

But if I want to control my desk phone (7945), it cannot connect.

If done and rechecked all config steps from Installation guide.

All phones associated to the user are listed, but when one is selected, the status bar shows Configureing phone... and then

the error icon is displayed.

I tried to reduce the CTI controllable devices in the end user setup to one, but no change.

In the status window I get:


Status:     Not connected

Reason:    Connection error. Ensure ther server information in the Phone Services tab on the Options window is coorect. ...

Address:    10.x.x.x (CTI)

Protocol:     CTI

In the log file there is an entry:

DEBUG [0x000031c8] [\impl\TelephonyServerHealthImpl.cpp(255)] [csf-unified.telephony.TelephonyServerHealthImpl] [TelephonyServerHealthImpl::updateHealth] - updating health with serverType [CucmDeskphone] serverHealthStatus [Unhealthy] serverConnectionStatus [Disconnected] serverAddress [10.X.X.X (CTI)] serviceEventCode [UnknownConnectionError] transportProtocol [CTI]

I'm using Lotus Sametime plugin without any problem. Also Stand-alone Click-to-Call is working without any problem on the same client.

Has someone an idea, where I can have a look at to solve the issue?

Many thanks in advance.

In CTI-log I found the following entry for the device not working:

[CTI-APP] [DeviceThirdParty(11)::gettingRegistrationStatus_deviceRegStatusRes]     (Signal=CtiDeviceRegistrationStatusRes DeviceName=SEP001D7061473E State=deviceTPState_gettingRegistrationStatus , mLocalHandle=1

Invalid State: deviceName=SEP001D7061473E (mState=2)

ready_CtiDeviceRegistrationStatusRes - Device=SEP001D7061473E not found in mDeviceNameToLineHandleList

Tommer Catlin

Not sure if you did the following but:

- tied the device (Cisco phone) to the user ID

- Tied the Line (of the Cisco phone) to the user ID (associated)

- User ID must be the same as Lync user ID

- CUCM must be LDAP enabled

I assume you are running CUCM 8.6.2 not 8.2.6.     You could also have a problem between DNS or IP on how Lync and or CUCM is trying to resolve names or not.

For the CUCM EndUser, did you add in the correct security groups for CTI control as well?

Hello, thanks for your reply.

I tied the line and the device to the user ID. The desk phone and the Client Services Framework phone are added to controlled devices. The user is member of the CTI groups.

User ID is the same in both systems (both from same AD).

I can solve and the names and ping the servers vice versa.

You're right we're using CUCM 8.6.2.

is nobody running into the same issue?

I checked the configs several times, but the issue is still present.

I made the same configuration at a another CUCM cluster of our company and had no prblems. Really strange!

Hi Christian,

I'm running into the same issue.

Could you please tell me how did you solve your problem ?


we never solved the problem.

Perhaps you should raise a TAC.



Content for Community-Ad