Showing results for 
Search instead for 
Did you mean: 
Nicolas MATHEY

Cisco Unified Attendant Console Standard Directory Sync issue

Hi there,

We have been using CUAC Standard v10 since few months but still not able to get synchronize CUCM Phone Directory with the application.

The local Directory still empty. I tried to change Directory sync timer for 0 to another number but once I click on "Apply" button I do have error popups message saying wrong configuration on each every fields even if I didn't change them.

The only action I can do is to click on "Cancel" button.


I just tried today to upgrade to the latest 10.5 version but still having the same issue.

Other than that call control is working fine.






Swathi Alagaraj
Cisco Employee

Hi Nicolas,


Can you please share screenshot of the error and also the changes you have made.



Here you go:

1) Starting login screen: see it successfully loading attendant devices while typing digit number to login


2) Calls can be seen on the attendant console and can be manipulate. But no directory number have been synced so far


Calls handling ok

3) Current config (very basic - only CUCM configured - no voicemail - no presence, etc.)


Current config

4) Once trying to change any configuration filed and hit apply: got following error messages

Error while changing configs

Hi all,

I have exactly the same issue!

Nicolas how did you solve it?

Thanks in advance...

Hello, in my case it was a rights credential issue. I had the same problem and solved it by running the application with the option "run as administrator".

Probably I will have to allow the windows user some rights to modify the files of the application.


Best regards,


Hello Hector

many thank, i solved it by running the application with the option "run as administrator".

Best regards

Same problem for me with console standard version 11.02 on a windows 8.1 professional 64 bit and CUCM version 11

I ran it without problem on a windows 7 on lab with same version.

Problem resolved with administrator right on launching.

Hi ,

many thanks, i solved it in 2019 with version 12.0.5 of CUACS and CUCM 12.5 and solved also by running the application with the option "run as administrator".

Cisco Employee

Hi Nicolas,


Do you have the Directory Sync source set to CUCM from within the application?


Hi Mawindha,


Yes, the Directory Sync source has been set to CUCM.

AXL communication is working fine but checking logs we can see the DirSync issue/failure:

2014-02-07 10:07:56,128 [8] DEBUG Directory - SyncSourceBase.PerformSync. Synchronize Result:FAILURE

2014-02-07 10:07:56,128 [8] DEBUG Directory - SyncSourceBase.DoRaiseSourceChangeEvent. SourceEventData:SourceState: EventType: StateChange, SourceState:Finished, SourceFailureReason:Unknown, TotalContacts:1495, SynchedContacts:100, RemaingContacts:1395, SourceId:8bf9256c-5b6c-fe4b-8a33-5f7a4acd68e1, SourceType:CCM

2014-02-07 10:07:56,177 [8] DEBUG Directory - SyncSourceBase.Initialize. MaxBatchSize:100

FYI, I also open a TAC case in parallel. 

Which version of CUCM are you using?