Showing results for 
Search instead for 
Did you mean: 

Click to call problem with outlook 2010


we are using Outlook 2010 and the newest version of click to call, version 8. It works fine but each call I make, I get a prompt that says:

Security Alert: A scure connection with this site cannot be verified. Would you still like to proceed?

And I can press Yes and the call goes through fine. There is also the option to install the certificate and I do, but it does not change anything.

On every call I have to alt tab to the security warning and click yes to make the call go though. This is very annoying, can someone please help?

thank you


thanks for the reply, I have already installed the certificate on Trusted root authorities on Local Computer, Registry etc. However I still get the same prompts over and over.

I assumed you also followed the instructions on that link:

Ensure that the value of the WebDialer Service 
field in the Click to Call Preferences dialog box matches the name of 
the Cisco Unified Communications Manager server in the certificate, not 
the IP address of the Cisco Unified Communications Manager server.


It does not match the name as I have put the ip of the call manager. I tried to change the name to CUCM-PUB but it keeps reverting it to the ip address. I even changed it to the registry to CUCM-PUB and it still uses the ip on the click to call preferences. How do I make that change stick ?

I changed the address to CUCM-PUB but it resolves it to the ip address and then it stores the ip address instead of the name on the click to call preferences.

Try change IP to name from CUCM.


I have same problem. How to change IP address to CUCM name? Did anybody solved the problem?


From click-to-call preferences.


I had the same issue and did the following to fix it:

1. Uninstall click to call from add/remove programs

2. Open regedit and delete the following: HKEY_LOCAL_MACHINE\SOFTWARE\Cisco Systems, Inc.\Unified Communications\Click To Call

3. Delete all that is under c:\program files\cisco systems\click to call (delete the entire folder)

4. Reboot the pc

5. Edit the regedit key I'm posting, change the following:


to  be the HOSTNAME of the server (not the ip), it must be the name that  the certificate is showing when you try to install it.  Only modifiy  that, do not remove the extra spaces in the file.  Import the key under HKEY_CURRENT_USER\Software\Policies

6. Install click to call and give it a try

Osiris: Notable ha servido mucho tu aporte. Bien hecho.

The changing of the web dialer service entry from IP to hostname (plus installing the cert) worked for me.

Which works as long as there is an entry for your CCM in the your organizations DNS server.  As a work around, you can manually add a DNS entry to your computers hosts file per the following instructions:

Recognize Your Peers
Content for Community-Ad