cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

1111
Views
10
Helpful
9
Replies
faizanelahi
Beginner

CUBE - One way audio

Hi,

We are facing one way audio connecting to a SIP provider. Callee cant hear the voice of caller, the other way is fine.

I can see rx and tx packets increasing during the call.

*** IP Phone - CUCM - CUBE - SIP Provider Router - SIP Server ***

Provider had confirmed that they are not receiving any RTP and to check internally.

Attached is the config of VGW.

Appreciate for any input.

 

1 ACCEPTED SOLUTION

Accepted Solutions

I can see under voice service voip, you have binded with gi 0/0/0. and in dial-peer its with gi0/0/1. Are you binding with  the right  interfaces. 

 

Since your RTP streams are not reaching ISP, you need to check from phone subnet if you are able to reach the CUBE IP's. 

 

Whats the reason for adding all codecs in voice class codec 1 , most of the ISP work with g711 A an u Law. Use the codec which your ISP mentioned. 

 

 

 

 



Response Signature


View solution in original post

9 REPLIES 9
Sadav Ansari
Participant

Hi,

 

One way audio most of the time is a routing problem. So make sure that you don't have routing flapping causing intermittent RTP failure.

 

Another common reason (which can be your case) is a firewall device inspecting your RTP/SCCP/SIP traffic. I suggest to make sure that you look at inspection configuration and make sure that VoIP protocols are excluded.

Is bind command configured on CUBE ?

is this issue for inbound/Outbound or both ?

 

Share your CUBE configuration for more clarification.

 

Pls rate if its “Helpful”. If this answered your question pls click “Accept As Solution”.

Hi Sadav,

 

There is no firewall in place. Yes bind command configured.

We are only testing outbound calls for now and its having this issue.

Nithin Eluvathingal
VIP Advisor

Mostly  the one way audio issue are due to routing. "outside user ? Based on " Provider had confirmed that they are not receiving any RTP and to check internally", I assume outside party is not able to hear your voice.  And you are able to hear the PSTN users voice.

Does this happen for both inbound and outbound calls ?

Can your please  share  your configuration. 

 

 

 

 

 

 



Response Signature


Hi Nithin,

 

Yes, outside party not able to hear my voice. I can hear the PSTN users voice. Below is the configuration.

 


version 16.6
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
platform qfp utilization monitor load 80
no platform punt-keepalive disable-kernel-core

hostname Router

boot-start-marker
boot system flash /bootflash/isr4300-universalk9.16.06.09.SPA.bin
boot system flash isr4300-universalk9.16.06.09.SPA.bin
boot-end-marker

vrf definition Mgmt-intf

address-family ipv4
exit-address-family

address-family ipv6
exit-address-family


no aaa new-model

no login on-success log

subscriber templating
multilink bundle-name authenticated
voice call send-alert
voice rtp send-recv

voice service voip
ip address trusted list
ipv4 0.0.0.0 0.0.0.0
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
no supplementary-service h450.2
no supplementary-service h450.3
supplementary-service h450.12
no supplementary-service sip moved-temporarily
no supplementary-service sip refer
fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
sip
bind control source-interface GigabitEthernet0/0/0
bind media source-interface GigabitEthernet0/0/0
no update-callerid
midcall-signaling passthru
no call service stop
!
voice class codec 1
codec preference 1 g711alaw
codec preference 2 g711ulaw
codec preference 3 g729r8
codec preference 4 g729br8
codec preference 5 aacld
codec preference 6 clear-channel
codec preference 7 g722-48
codec preference 8 g722-56
codec preference 9 g722-64
codec preference 10 g723ar53
codec preference 11 g726r16
codec preference 12 g726r24
codec preference 13 g726r32
codec preference 14 g728
codec preference 15 ilbc

voice-card 0/4
no watchdog

license udi pid ISR4321/K9 sn FDO25021H79
license accept end user agreement
diagnostic bootup level minimal
spanning-tree extend system-id

redundancy
mode none

interface GigabitEthernet0/0/0
ip address 10.58.1.18 255.255.255.252
negotiation auto

interface GigabitEthernet0/0/1
ip address 10.100.21.241 255.255.255.0
negotiation auto

interface Service-Engine0/4/0

interface GigabitEthernet0
vrf forwarding Mgmt-intf
no ip address
shutdown
negotiation auto

ip forward-protocol nd
ip ftp source-interface GigabitEthernet0/0/1
ip ftp username admin
ip http server
ip http authentication local
ip http secure-server
ip tftp source-interface GigabitEthernet0/0/1
ip route 0.0.0.0 0.0.0.0 10.58.1.17

control-plane

mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
mgcp profile default

dial-peer voice 101 voip
description to cucm
destination-pattern 222829[345].
session protocol sipv2
session target ipv4:10.100.21.242
voice-class codec 1
voice-class sip bind control source-interface GigabitEthernet0/0/1
voice-class sip bind media source-interface GigabitEthernet0/0/1
dtmf-relay rtp-nte h245-alphanumeric h245-signal cisco-rtp
no vad
!
dial-peer voice 102 voip
description to cucm
destination-pattern 222829[345].
session protocol sipv2
session target ipv4:10.100.21.243
voice-class codec 1
voice-class sip bind control source-interface GigabitEthernet0/0/1
voice-class sip bind media source-interface GigabitEthernet0/0/1
dtmf-relay rtp-nte h245-alphanumeric h245-signal cisco-rtp
no vad
!
dial-peer voice 201 voip
session protocol sipv2
session transport udp
incoming called-number .
voice-class codec 1
no vad
!
dial-peer voice 202 voip
destination-pattern .T
session protocol sipv2
session target ipv4:80.184.252.10:5083
session transport udp
voice-class codec 1
no vad
!
!
sip-ua
connection-reuse

 

I can see under voice service voip, you have binded with gi 0/0/0. and in dial-peer its with gi0/0/1. Are you binding with  the right  interfaces. 

 

Since your RTP streams are not reaching ISP, you need to check from phone subnet if you are able to reach the CUBE IP's. 

 

Whats the reason for adding all codecs in voice class codec 1 , most of the ISP work with g711 A an u Law. Use the codec which your ISP mentioned. 

 

 

 

 



Response Signature


View solution in original post

Thank you Nithin. I have removed gi0/0/0 binding under voice service voip and binded this in PSTN dial peer (202). Issue is resolved after doing this. Is this the correct way to do ?

 

gi0/0/1 is my internal interface which is facing to cucm.

You should for best practice make sure that you have a matching dial peer for the inbound direction for your service provider. My preference is to use the via header to match the inbound dial peer for both the call leg from the service provider and from CM. See this excellent document for details, https://www.cisco.com/c/en/us/support/docs/voice/ip-telephony-voice-over-ip-voip/211306-In-Depth-Explanation-of-Cisco-IOS-and-IO.html

In our standard configuration we’d use separate dial peers per call leg, aka we’d normally use 4 dial peers for this. 2 for the call legs to/from CM, with a server group for the outbound dial peer to just use one for the direction to CM and another 2 for the call legs to/from the service provider.



Response Signature


For better understanding of bind commands Go through the chapter  SIP Binding. 

 

https://www.cisco.com/c/en/us/td/docs/ios-xml/ios/voice/cube/configuration/cube-book/voi-sip-bind.html

 

 



Response Signature


Two things, you have not enabled the Cube function in your configuration, see the supplied link for details, and AFAICT you do not have any routing information for your internal network. I would recommend you to change your default route to point to something that can route internally and set up a host route to the service provider SBC address instead of having the default route pointed to the service provider CPE endpoint as this is not really needed.

https://www.cisco.com/c/en/us/td/docs/ios-xml/ios/voice/cube/configuration/cube-book/voi-cube-overview.html

Apart from this I would strongly recommend you to change the trust statement in voice service voip. Having it set like you do disable the toll fraud protection and that is in general a bad thing.



Response Signature


Create
Recognize Your Peers
Content for Community-Ad