cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3769
Views
2
Helpful
11
Replies
Beginner

[CUCM 4.2 to 7.1] remote site IOS upgrade before CUCM

Hello Everyone,

Hope doing well!

I had to migrate a cluster in 4.2 to 7.1 version. Befor I would like to upgrade the gw of the remote sites to the 12.4(24)T version, and then, some days after, migrate the CUCM. Is there any compatibility matter between CUCM 4.2 and IOS 12.4(24)T? I know that the embedded SRST 7.1 is ok with 4.2 (http://www.cisco.com/en/US/prod/collateral/voicesw/ps6788/vcallcon/ps2169/prod_qas0900aecd8028d113.html), but what about the other features? Maybe wrong question but i would like to be sure

Thanks everyone, have a nice day!

Cheers,

Greg

11 REPLIES 11
Highlighted
Beginner

Re: [CUCM 4.2 to 7.1] remote site IOS upgrade before CUCM

Hi Greg,

You should be fine with that IOS for 7.1.2. Check http://tools.cisco.com/ITDIT/vtgsca/VTGServlet for more details on recommended versions...

Cheers,

Jose

Highlighted
Beginner

Re: [CUCM 4.2 to 7.1] remote site IOS upgrade before CUCM

Hello,

Thanks a lot for your answer... But my question was more about the compatibility between 12(4)24T and CUCM 4.2? The link you provided start at the 5.0 CUCM's versions...

Thanks again,

Gregory

Highlighted
Beginner

Re: [CUCM 4.2 to 7.1] remote site IOS upgrade before CUCM

Hi Greg,

Since CUCM 4,x became EoS/EoL before the 12.4.24.T, I'm don't think that particular compatibility test has been performed. My experience on similar situations tells me that you should be fine in most cases (certainly if you use H.323 as the control protocol) but I'd recommend you test that combination in a lab first and also that you open a case with TAC for further confirmation.

Cheers,

Jose

Highlighted
Cisco Employee

Re: [CUCM 4.2 to 7.1] remote site IOS upgrade before CUCM

Greg and Jose,

Althought Cisco does not backwardly test IOS versions against older versions of CUCM, there should not be an issue with it.  Since SRST functionality is normally isolated from CUCM versions, SRST is not normally an issue.  Additionally, Cisco does not depricate backward compatibility.  So even though you're moving up IOS verisons, it shouldl still support older CUCM versions.

As mentioned by Jose, it's always good to validate this in the lab prior to making a production change, but I would not expect any issues with deploying a newer IOW with an older CUCM version.

Thanks,

Dan Keller

Technical Marketing Engineer

Highlighted
Beginner

Re: [CUCM 4.2 to 7.1] remote site IOS upgrade before CUCM

Hello,

Thank to both of you, that answers fit well for me!

Have a nice day!

Greg

Highlighted
Enthusiast

Re: [CUCM 4.2 to 7.1] remote site IOS upgrade before CUCM

Hi Daniel,

This is an interesting topic, as I see it coming up for discussion quite a bit these days.

Although my angle is normally CUCM version - is there a minimum IOS version required?

In the support matrices, IOS 15.x is listed as the only supported release on the routers for CUCM 7.1(3) and above.

Are you saying this is not the case?

My thoughts are that especially for H.323 and MGCP it would still work.

However the SRST version is also listed, and the other consideration would be SCCP conferencing, transcoding and MTP resources.

So does CUCM 7.1(3) + and IOS 12.4 = a supported configuration?

Cheers,

Tim.

Highlighted
Cisco Employee

Re: [CUCM 4.2 to 7.1] remote site IOS upgrade before CUCM

I will try to repeat what I tought I heard Dan say, but in a slightly different way.

We have not tested CUCM 7.1(3) + and IOS 12.4.  So regardless of stated support, you are taking a slight risk there.

We think that the risk is low and yes TAC will answer the call and do appropriate troubleshooting on this combination.  If on the odd chance that you run into an interop issue between the two, we will have to look at the fix and the development/test effort to fix to determine how we address the issue.

In the end your safest path is to go with fully supported/tested sets.  We realize that this is not always practicle or possible, and hence will support this to the best of our ability, but reailize that we can not guarantee that there will not be an upgrade required to fix some issues.

Highlighted
Cisco Employee

Re: [CUCM 4.2 to 7.1] remote site IOS upgrade before CUCM

To hopefully close the loop on this question, Wade accurately summarized my response.

Thanks,

Dan Keller

Technical Marketing Engineer

Highlighted
Cisco Employee

Re: [CUCM 4.2 to 7.1] remote site IOS upgrade before CUCM

12.4(24)T or 12.4(15)T will work fine with 7.1.3.

A large number of Cisco customers are running CUCM 7.1.x with 12.4T image.

HTH

Saeed

Highlighted

Re: [CUCM 4.2 to 7.1] remote site IOS upgrade before CUCM

Hi Saeed,

I've same question for CUCM 8.0.

I've to migrate from 4.2 to 8.0.

Do you know if IOS 12.4T image works with CUCM 8.0 ?

Thanks in advance

Marco

Highlighted
Cisco Employee

Re: [CUCM 4.2 to 7.1] remote site IOS upgrade before CUCM

Same question, only different version.  Same answer with same guidance/caveats listed above.

CreatePlease to create content