Showing results for 
Search instead for 
Did you mean: 

CUCM 7.x - Weird Issues

Hi Everyone,

I've got a TAC case on a specific issue, but I think there's more general weirdness going on and I'm hoping for some insight.

We currently have CUCM configured with one publisher and one subscriber. We also have UC and CER servers. The CUCM servers are sync'd to LDAP. We virtualized our domain controllers so I had to change the LDAP Directory entries to reflect the new IPs. I discovered later that MWI became sluggish on the phones, and after some digging I fixed it by deleting one of the LDAP directories and readding it. It turns out that simply changing the IPs didn't actually update the connections in the database. I ran "run sql select name,connectedldaphost from directorypluginconfig" and noticed the old IPs were still in the list, even though the directories were changed. Once I deleted one of the directories, all of them suddenly updated.

Fast forward another week: MWI is working fine now, but other odd things have popped up.

1) My ring list is empty on phones now (save for the built-in chirps). I have sniffed a phone with wireshark and I see no tftp requests when the button is pushed. I have confirmed that tftp requests are made for background images when that selection is made, but nothing for ringers. This was previously working and I have not modified Ringlist.xml or .dat.

2) My publisher is no longer showing registrations for phones. The subscriber shows them fine, but they used to show on both (listing the subscriber as the server to which the phones were registered.) Now, phone queries return "unknown" on the publisher.

I'm entertaining the possibility that these items might be related because they appeared at about the same time, but I'm not sure. Does anyone happen to have any insight? Many thanks in advance.

Cisco Employee


1) For the ringlist problem make sure your TFTP option 150 was not removed from the DHCP server. If that's the case readd it and reset the phones.

2) For the registration issue you can try restarting the RIS Data Collector Service. This service is in charge of monitoring the state of the devices and I see the phones work and just don't show the correct status on the PUB.

What's the exact CUCM version you have? If it's a 7.0 you'll probably want to upgrade it to a 7.1




Regards, Tere. If you find this post helpful, please rate! :)
Recognize Your Peers
Content for Community-Ad