cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
2085
Views
6
Helpful
10
Replies
Highlighted
Advocate

CUCM 8.5 to 10.5 - Refresh upgrade

My current 8.5 is already virtualized on c210s.   The upgrade guide is a little fuzzy on which COP files are actually needed.    There is a disksize COP file to change the allocation of the partitions which I get.  But there is also another COP file mentioned in different release notes about the RHEL change during the Refresh:   http://www.cisco.com/web/software/282204704/18582/ciscocm.refresh_upgrade_v1.0.html

Just to confirm, both COP files need to be installed prior to upgrade or is one not required anymore?      Unfortunately, I do not have the luxury of PCD because of limited hardware resources.  8.5 to 10.5 is supported upgrade path inplace per the guide.

Also to add, if the original install did not use an OVA, post upgrade will we get the dreaded "Unaligned Partitions" or will either COP file avoid this?

Thanks!

10 REPLIES 10
Highlighted
Advisor

Hi Tommer,

I advise you to use the OVA template downloaded from Cisco site.

Further,I was referring the link which u have shared , it talks about about upgradation to 8.6 from earlier versions.

Secondly, are u refrring to vdisk expansion cop file to increase size.

regds,

aman

Highlighted
Advocate

Tommer!

I dont think you need the disksize COP file, the only one you would need is the Refresh upgrade COP which needs to be installed prior to the upgrade. You will also need the ciscocm.version3-keys.cop.sgn  cop file since your are going to 10.5.

Unfortunately, if you dont use the OVA, it will give your the Unaligned partitions message. :(

Thanks

Please rate useful posts.
Highlighted
Cisco Employee

Good afternoon,

To answer your concerns, the refresh upgrade file is definitely a requirement.

About the actual upgrade process, you will need to upgrade to any 8.6(2) release first before going to 10.5. The link below lists the versions from which you can perform a direct upgrade:

http://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cucm/compat/matrix/10_x/CUCM_BK_CD1DB914_00_compat_matrix/CUCM_BK_CD1DB914_00_compat_matrix_chapter_01.html#CUCM_RF_U4CE0DAF_00

Also, there is a documentation defect that talks about this, see below:

https://tools.cisco.com/bugsearch/bug/CSCus62385/?reffering_site=dumpcr

Having mentioned this, the plan should be as follows:

1) Install "ciscocm.refresh_upgrade_v1.5.cop.sgn" on all nodes (Starting with the Publisher then, the remaining nodes).
2) Backup current CUCM version the system is running.
3) Upgrade current CUCM version to any 8.6(2) version.
4) Install "ciscocm.version3-keys.cop.sgn" on all nodes (Starting with the Publisher then, the remaining nodes).
5) Install UCOS_10.5.2.10000-5.sgn (on the inactive partition) (Starting with the Publisher then, the remaining nodes).
6) Perform "switch version" starting with the Publisher server. (Starting with the Publisher then, the remaining nodes).
7) Verify cluster replication is good on all nodes once all servers are in CUCM 10.5.2.10000-5.
8) Perform a backup of the system.
9) Download and deploy OVA template "cucm_10.5_vmv8_v1.8.ova" (from Cisco's website) to create new VM's for the cluster.
10) Re-Install CUCM 10.5.2.10000-5 cluster in the newly deployed VM's created using the correct OVA template.
11) Perform a restore on 10.5.2.10000-5 from previous backup taken on step 8.

Since you are upgrading from a non 10.X version, once you upgrade to this version you will get "partitions un-alingned" error because hardware requirements are different for CUCM 8.6 and CUCM 10.5. This is explained on the following document:

http://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cucm/rel_notes/9_1_2/CUCM_BK_C9FFFCD0_00_cucm-release-notes-912/CUCM_BK_C9FFFCD0_00_cucm-release-notes-912_chapter_011.html#CUCM_RF_C48E7BDE_00

That's the reason why I added Step 9, 10 and 11 to this plan.

Hope this information helps,

Marco Rojas.

Highlighted

I have a customer going through the same thing and have some questions.

1. once you load the "ciscocm.refresh_upgrade_v1.5.cop.sgn" file, can you not then upgrade direct from 8.5 to 10.5 without stepping through 8.6?  I thought that was the point of the RU cop file.

2. Since this is an RU don't you need to do the cop files, upgrade, and switch version (the entire procedure) first on the PUB before any SUB will allow upgrade?

thanks,

K

Highlighted

Kasey,

Kindly find some insight for your concerns below:

1) Please take 5 minutes of your time to re-read my post. I made it very clear the reason why upgrade to 8.6 is required. Please check the documentation and defect above.

2) Please be careful with how you address this concern to the customer. Certainly, I would say there is more than one method to do the upgrade. The way I outlined the process above was installing what was needed gradually. Always starting on the Publisher, then moving to the remaining nodes in the cluster. That way, all the servers would have everything ready to only perform the switch version whenever the customer is ready to start running on version 10.5.

The intention of this process is to reduce the downtime.

Last, make sure you let the customer knows a maintenance window is required to carry on with this procedure.

Regards,

Marco Rojas

Highlighted

Hi Rojas,

"ciscocm.refresh_upgrade_v1.5.cop.sgn" mentioned above should be installed on existing 8.5 server ????

 

 

Highlighted

Yep.

Please rate useful posts.
Highlighted

Hi Rojas,

one question: in above step:3

3) Upgrade current CUCM version to any 8.6(2) version.
this upgrade should be in VM or simple upgrade.

my concern is can we restore backup from 10.5 unvirtualized to 10.5 virtualized.

I am really confused.

 

 

Highlighted
Hall of Fame Cisco Employee

It's impossible to go above version 9.x on bare metal, 10.x+ only accepts installation over ESXi.

Therefore, your concern does not apply

my concern is can we restore backup from 10.5 unvirtualized to 10.5 virtualized.

HTH

java

if this helps, please rate
Highlighted

Hi,

it is not 10.5 Unvirtualized.

Once u do the upgrade from 8.x to 10.x and take backup  , u need to build fresh VM using desired ova template  and restore the backup so as to avoid unaligned partitions.

regds,

aman

Content for Community-Ad