cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

428
Views
15
Helpful
5
Replies
johanbonvalet1
Beginner

CUCM PUB does not recognize mixed-mode CLI

Hello everybody,

I have a huge deal:

My client has three cucm: one pub and one sub and one preprod

We did turn the preprod into mixed-mode by the command line utils ctl set-cluster mixed-mode

So we did tje same configuration to the cucm PUB, but this one does not recognize this command.

Although, the cucm sub knows utils ctl set-cluster mixed-mode which is weird because the sub is a replicate from the PUB

this is the error result:

"Executed command unsuccessfully

No valid command enterd"

The cucms are in version 10.5.1.10000-7

What I heard is that we do not need to use CTIClient with token because cucm above version 10.0 are tokenless

And we tried the same thing in our CUCM (without the CTI Client), and it turns into mixed-mode after the command line.

Anyone here could help me with that issue?

thank you

Best Regards

5 REPLIES 5
Manish Gogna
Cisco Employee

Hi,

This command should have been executed on the Pub as per the following link

http://www.cisco.com/c/en/us/support/docs/unified-communications/unified-communications-manager-callmanager/118893-technote-cucm-00.html

Can you verify if the cluster is indeed running in mixed mode after you made the change on sub

  • Navigate to CUCM Admin Page > System > Enterprise Parameters and verify whether the cluster was set to Mixed mode (a value of 1 indicates Mixed mode):



If it indeed is then it is really weird and you should engage TAC.

Manish

Hello Manish,

thank you for your answer, i did not execute this command on the sub, at least i could not.

"this CLI is only applicable for PUB"

The cluster security mode for the PUB is at "0" and LBM Security Mode to "Insecure"

Rob Huffman
Hall of Fame Community Legend

Hi Johan,

I agree with my friend Manish (+5) here that opening a TAC case seems like a prudent step in this case. I can see at least 2 bugs related to CUCM 10.5.1.10000-7 and the mixed-mode cli setup;

https://bst.cloudapps.cisco.com/bugsearch/bug/CSCuq02712

https://bst.cloudapps.cisco.com/bugsearch/bug/CSCup18476

Hi Rob,

Yes those two bugs certainly need to be looked into.

Manish

Hello Rob,

thank you! yes it was because of one of these bugs!

I had disabled these services on the sub: callmanager and to be sure, tftp and ctl provider

Then I entered the command utils ctl set-cluster mixed-mode in the PUB and it worked!

I go back to the sub to enable the three services, and now pub and sub are well in mixed-mode

thank you for this!

Create
Recognize Your Peers
Content for Community-Ad