cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1176
Views
0
Helpful
2
Replies
junior.beatty
Beginner

CUCM Upgrade to 10.5 from 8.5

Just curious, has anybody ugraded their CallManager to 10.5 from 8.5 without using the Prime Collaboration Deployment tool.  I have uploaded the necessary cop files already and have been trying to figure out how to do the upgrade without PCD.  I know I will be asked why not use PCD.  Consultants we have talked to recommended not using PCD for various reasons, mainly lack of familiarity.  If anybody can give me some info on doing this upgrade, both with and without PCD, it would be appreciated.

2 REPLIES 2
Jaime Valencia
Hall of Fame Cisco Employee

The upgrade procedure is basically the same one we've had ever since we moved to Linux, besides from the required COP files, nothing changes.

Have you reviewed the RNs and the CUCM 10.0 upgrade guide on CCO which cover the upgrade, pre-reqs, procedure and changes after the upgrade?????

Even with PCD, the same legwork would be done for any upgrade, PCD would only do the part on which it loads the ISO and upgrades. Any required COPs and the changes to the VM still are a manual procedure.

PCD is the best option when doing a migration, not so much for an upgrade.

HTH

java

if this helps, please rate
Marco Rojas Abarca
Cisco Employee

Junior,

Good question! Below you will find a guide through I created for one of my customers:

The actual upgrade process, you will need to upgrade to any 8.6(2) release first before going to 10.5 The link below lists the versions from which you can perform a direct upgrade:

http://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cucm/compat/matrix/10_x/CUCM_BK_CD1DB914_00_compat_matrix/CUCM_BK_CD1DB914_00_compat_matrix_chapter_01.html#CUCM_RF_U4CE0DAF_00

Also, there is a documentation defect that talks about this, see below:

https://tools.cisco.com/bugsearch/bug/CSCus62385/?reffering_site=dumpcr

Having mentioned this, the plan should be as follows:

1) Install "ciscocm.refresh_upgrade_v1.5.cop.sgn" on all nodes (Starting with the Publisher then, the remaining nodes).
2) Backup current CUCM version the system is running.
3) Upgrade current CUCM version to any 8.6(2) version.
4) Install "ciscocm.version3-keys.cop.sgn" on all nodes (Starting with the Publisher then, the remaining nodes).
5) Install UCOS_10.5.2.10000-5.sgn (on the inactive partition) (Starting with the Publisher then, the remaining nodes).
6) Perform "switch version" starting with the Publisher server. (Starting with the Publisher then, the remaining nodes).
7) Verify cluster replication is good on all nodes once all servers are in CUCM 10.5.2.10000-5.
8) Perform a backup of the system.
9) Download and deploy OVA template "cucm_10.5_vmv8_v1.8.ova" (from Cisco's website) to create new VM's for the cluster.
10) Re-Install CUCM 10.5.2.10000-5 cluster in the newly deployed VM's created using the correct OVA template.
11) Perform a restore on 10.5.2.10000-5 from previous backup taken on step 8.

Since you are upgrading from a non 10.X version, once you upgrade to this version you will get "partitions un-alingned" error because hardware requirements are different for CUCM 8.6 and CUCM 10.5. This is explained on the following document:

http://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cucm/rel_notes/9_1_2/CUCM_BK_C9FFFCD0_00_cucm-release-notes-912/CUCM_BK_C9FFFCD0_00_cucm-release-notes-912_chapter_011.html#CUCM_RF_C48E7BDE_00

That's the reason why I added Step 9, 10 and 11 to this plan.

Hope this information helps,

Regards,

Marco Rojas

Content for Community-Ad

Spotlight Awards 2021