cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
918
Views
0
Helpful
7
Replies
Highlighted

CUCM Version 10.5.1.10000-6 Database communication error

After a painful migration of a cluster consisting of 2 servers (pub and sub) with PCD 10.5.1 with network migration I am getting an error when trying to login to the publisher server (Databse communication error) it was working fine after the migration and in an hour or more it give this error with no changes applied to it after the migration :

 

we followed the threads in this error and we tried to make all the workaround but it did not fix it as we can not even start the  A cisco DP service it keep saying starting then failed to start it and I can not login the CUCM Admin page I could only access the CLI.Any idea how to fix this issue.

 

Regards,

7 REPLIES 7
Highlighted
Cisco Employee

Hi Karim,Please check if any

Hi Karim,

Please check if any IP / hostname / DNS entries have been changed on the server, in a lot of cases it is the issue. if yes, revert the changes and try logging in again. If no such changes were made then the entire migration process needs to be verified.

HTH

Manish

Highlighted
Advisor

In addition to what Manish

Highlighted

We do not have DNS Record and

We do not have DNS Record and we tried to reset the replication with no progress so what we are doing now is re-migrate the cluster again as we are missing one cop file which maybe the one that cause all the issue:  ciscocm.version3-keys.cop.sgn  as per the release notes which is very confusing it I have to install this file as the PDI engineer.(a must to install on cucm 7.1.5 migrating to 10.5 via PCD or even for a jump upgrade).I will keep you updated if it is successful or not.

 

 

 

Highlighted
Hall of Fame Cisco Employee

That's wrong, the new key for

That's wrong, the new key for the 10.x files has nothing to do with a migration, it DOES have to be installed if you're UPGRADING, that's a whole different thing.

The RNs explain that

  • Before upgrading to release 10.5(2), you must download and install the COP file ciscocm.version3-keys.cop.sgn on every node in the cluster prior to upgrading. This Cisco Options Package (COP) file has the RSA keys that are required to validate the upgrade.

In PCD upgrade IS NOT THE SAME AS migration.

The migration is going to do a fresh install of the VMs, then move the info, at no point it requires the version3-keys file.

Jump upgrade methodology is only to 9.1(2), that file is also not required as we didn't change the keys until release 10.x

HTH

java

if this helps, please rate
Highlighted

This was the recommendation

This was the recommendation for the PDI Engineer he insisted on it and he told me that he have a lot of cases with cisco TAC regarding this and he confirmed that I have to install this file which was confusing for  me anyway I did 2 changes that make migration with PCD successful I am not sure which one solve my issue:

 

1- Make sure of the NTP configuration in both ESXi Hosts.

2- Installed the ciscocm.version3-keys.cop.sgn COP File.

 

Now I finally finished my installation using PCD with Network Migration thank you all for the interaction.

Highlighted
Hall of Fame Cisco Employee

Nope, most likely it had

Nope, most likely it had something to do with the NTP config

It's as simple as this: If you're doing a fresh install of 10.x (which is what the migration task does)... do you need the ciscocm.version3-keys.cop.sgn?????? The answer is NO, because that file is used to install the new keys we use to sign the images, and those keys are ONLY checked during an in-place upgrade to validate the image is valid and signed by Cisco.

HTH

java

if this helps, please rate
Highlighted

Hi Jaime:i did not get what

Hi Jaime:

i did not get what you mean exactly ,  if i upgrade from 7.1.3 to 10.0 without using PCD i have to use two files ( Refresh upgrade + ciscocm.version3-keys.cop.sgn ) ?and if using PCD only the refresh upgrade file used ?

i have another question i am upgrading from 4.1 to 7.1.3 then to 10.0

if i use 8.6 OVA to deploy the 7.1 , should i change the network card type or i do this onlyy if i use 10.0 OVA for deploying the 7.1 ?

​and after upgrading from 4.1 to 7.1 i tried to remove the subscriber from servers menu because ii will readdress the the PUB then re add the SUBs with new scheme but i get error about license while try to delete the SUB , could you advise about this error .

thanks ....  

CreatePlease to create content
Content for Community-Ad
Future of Work Virtual Summit Day 5

Cisco COVID-19 Survey