cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

7093
Views
0
Helpful
15
Replies
jeffrey-young
Beginner

CUPC 7 users can find some users but not all

This is a new install.  CUPS 7 w/ CUCM-BE 7.1.5.  I have added two LDAP profiles, one for each location...and each has a different OU.  The users in one OU  can only see users in that OU.  If I simply make one of the LDAP profile's the deffault will this allow users in the different OU's to see each other?

The user's extensions are also not showing up, most of them say "unknown" or display their cell phone number.  Shouldn't this be pulled from CUCM and the IP Phone extensions show up?

THanks in advance for the help.

Jeff

15 REPLIES 15

Hi

If you want all users to see all other users, you would probably want a single LDAP profile that lists both OUs like so:

Ou=xxx,dc=domain1#Ou=yyy,dc=domain1

You may want each set of users to use a local DC, this is still possible - just have two LDAP profiles referring to the local servers, but with both base OUs specified...

Regarding extensions not showing up - you need to see what attribute contains the extension number, and set that attribute on the LDAP profile where the list LDAP attributes is set up.

Regards

Aaron

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!

Good afternoon Aaron,

So this is how it is currently set up, in separate profiles:

OU=IPP-Users,OU=Cedar,DC=domain,DC=local

OU=IPP-Users,OU=Birch,DC=domain,DC=local

And you're saying it should be:

     OU=IPP-Users,OU=Cedar,DC=domain,DC=local#OU=IPP-Users,OU=Birch,DC=domain,DC=local

Is the OU=IPP-Users required in both??  And is the '#' required?

Thank you,

Jeff

Hi

OU=IPP-Users would be required in both unless you want everything under the OU= Birch or OU=Cedar to be searchable rather than just what's under the sub-OU of IPP-Users.

# is the seperator between the two search bases that you want...

Regards

Aaron

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!

I've made the change and I can now search for all users within the organization.

Still having an issue with the "unknown" phone number.  I have gone to Application -> CUPC -> User Settings and have changed the BusinessPhoneNumber to ipPhone

ipPhone is the field in AD (and CUCM) that the 4 digit extension is listed.  How long does this take to update?  Is there a manual sync I can do?

Thanks,
Jeff

Attached is a screen shot of the page...

Hi

That's not synced really - basically the map of attributes gets pulled into CUPC at logon, and then CUPC searches AD using that map when you hit the search button.

So exit CUPC, log in again and try searching..

Aaron

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!

That did it!  Thank you sir.

Now I'm seeing that my user has a softphone, but no other user's have this capability.  I've looked through everything that I know of and things all look to be the same....

As a side note, I show up as "Registered" in CUCM under my UPC device...and no one else does.

Jeff

Hi

Softphone basically needs:

1) A CUPC configured in CCM, with the name UPCxxxx where xxxx is the user's login name; if the login name is more than 12 characters just the first 12 characters should be used, and no punctuation etc.

2) In the CUPC User Settings page (same as the one with the LDAP map) you put in the TFTP server... you must have this done already.

What do you see in 'Server Health' in the softphone section?


Aaron

Please rate helpful posts...

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!

Ah - also the primary extension field on the 'End User' account needs to match the DN on the UPC you have created in CCM.

Regards

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!

Primary extension field matches....and in the same partition

The only difference I see at this point is that I have a deskphone associated to me and the other users do not

Hi

I presume you've exited and re-loaded CUPC on the other PCs? And that you have tried to select softphone mode from the little drop-down menu?

Aaron

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!

That is correct.

I forgot the reload once I won't forget again

Anyhow I'm just not seeing what is wrong......

The softphone simply says "Not Registered".  In the TFTP section it lists the TFTP server but nothing else.  Mine has a UPCxxx.cnf.xml

Create
Recognize Your Peers
Content for Community-Ad