cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1957
Views
0
Helpful
5
Replies
joel
Beginner

CUPC 8.5 no Video

I am running CUPC 8.5 in desk phone mode with a 7965 and a Microsoft LifeCam but NOT getting video. On server health --> Desk phone Video

Server Address:

Server Port:

Server Protocol: CAST

Status: CDP can't detect phone - no phone attached.

Sometimes, the Desk phone video option vanishes on the server health screen.

I am running CUPS onan evaluation license, so I am not able to run on Softphone mode.

This is a Microsoft LifeCam, the driver is installed right, it works with MOC and Gtalk.

Any ideas

:JoeL

2 ACCEPTED SOLUTIONS

Accepted Solutions
bvanturn
Cisco Employee

Hi,

Make sure that the hard phone has video enabled in the cucm configuration and that the pc you are running cupc on is connected to the network via the back of that phone (so not via another network port or via wireless).

View solution in original post

bvanturn
Cisco Employee

Afaik that is also still a requirement for cuva, they need to communicate via CDP so the phone gets to know the presence of cuva and can advertise the video capability accordingly.

You mean 9971 instead of 9975?

For 9971 if it has it own camera then cupc cannot do the video part in desk phone control. In softphone control it does use it own camera. Calling from another video enable cupc to the 9971 with camera plugged does work.

Make sure:

- you have a CSF device created in cucm (so not a cupc device)

- you associated this device in the end user configuration on cucm

- on cup you configured the ccmcip profile for this user

If all is set up ok, on the bottom an check box will apper which you can uncheck to swithc to softphone.

View solution in original post

5 REPLIES 5
bvanturn
Cisco Employee

Hi,

Make sure that the hard phone has video enabled in the cucm configuration and that the pc you are running cupc on is connected to the network via the back of that phone (so not via another network port or via wireless).

View solution in original post

When I plug in directly it works. Thanks. Although I thought they fixed that issue. CUVA does not require this anymore...

Does CUPC do video with 9975?

how do I switch my CUPC to softphone mode. I have everthing setup right.

http://www.cisco.com/en/US/products/ps6837/products_tech_note09186a00808a2b0d.shtml#topic4

bvanturn
Cisco Employee

Afaik that is also still a requirement for cuva, they need to communicate via CDP so the phone gets to know the presence of cuva and can advertise the video capability accordingly.

You mean 9971 instead of 9975?

For 9971 if it has it own camera then cupc cannot do the video part in desk phone control. In softphone control it does use it own camera. Calling from another video enable cupc to the 9971 with camera plugged does work.

Make sure:

- you have a CSF device created in cucm (so not a cupc device)

- you associated this device in the end user configuration on cucm

- on cup you configured the ccmcip profile for this user

If all is set up ok, on the bottom an check box will apper which you can uncheck to swithc to softphone.

View solution in original post

Thanks again... just added the CUCSF device and softphone worked.

not sure what the CUPC device type is for....

you are right, CUVA seems to be the same way, need to be directly connected to do video.

Yes, I mean 9971.

thanks.

:JoeL

one other thing I found the hard way is that 9971 is a class 4 device, so if the PoE switch is not capable of powering the phone and the camera, then you need a power cube 4. Using a power cube 3 and an injector will power the phone, but not the camera.

Content for Community-Ad

Spotlight Awards 2021