cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

2388
Views
5
Helpful
8
Replies
Highlighted
Beginner

CUPC 8 video option greyed out

I am attempting to get the video call working on a CUPC 8 client. The video option is currently greyed out. I have enabled video calls on the phone and the enterprise configuration in the call manager. The camera is working normally. It's a VX-3000 Lifecam. I can see the camera MIC in the CUPC audio options.

Any ideas?

Thanks

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions

CUPC 8 video option greyed out

I see there is no checkbox to the left of "Use my Cisco 7965 for audio" It looks like you need to setup the Client Services Framework device in communications manager.

When I want to go to softphone, I simply uncheck this box, and doublecheck my audio settings in File -> Options. You must be in Softphone mode in order to use video.

Make sure you associate the user with the phone, and the CSF device in user options, as well as set the primary extension.

Jonathan Beardsley CCNA Voice; MCITP Telecom & Network Administrator DECOSIMO

View solution in original post

8 REPLIES 8

CUPC 8 video option greyed out

When you encounter this, are you in Desk Phone Control mode, or Softphone? In order to use the camera, you must be in Soft Phone mode.

In order to use Softphone mode you must create the Client Services Framework device. I discovered this after upgrading CUCM to 8.6 and installing CUPC 8.5.3. We used to use CUPC devices in CUCM. I had to delete those and am building CSF devices where needed. If your device is configured correctly in the CUCM, you will have a checkbox a the bottom of your CUPC screen that says "Use my Cisco 7961 (1148) for Audio" (where 7961 is the model number of the phone, and 1148 is the DN).

Hope this helps.

-Jonathan

Jonathan Beardsley CCNA Voice; MCITP Telecom & Network Administrator DECOSIMO
Beginner

CUPC 8 video option greyed out

Hi Jonathan,

Thanks for the reply. I do see the "Use my Cisco 7965 for audio". I don't think I am able to enter softphone mode for some reason. When I click on the blue highlighted text I get a dialog box prompting me to select my desk phone. All I see is my 7965 desk phone. I am guessing that something is missing in the configuration? I am guessing I should be able to select my softphone?

CUPC 8 video option greyed out

I see there is no checkbox to the left of "Use my Cisco 7965 for audio" It looks like you need to setup the Client Services Framework device in communications manager.

When I want to go to softphone, I simply uncheck this box, and doublecheck my audio settings in File -> Options. You must be in Softphone mode in order to use video.

Make sure you associate the user with the phone, and the CSF device in user options, as well as set the primary extension.

Jonathan Beardsley CCNA Voice; MCITP Telecom & Network Administrator DECOSIMO

View solution in original post

Beginner

CUPC 8 video option greyed out

Thank you Sir. The CSF profile was the missing peice of the equation. I was successfully able to add a CSF profile and make a test call between two users and it is working great.

CUPC 8 video option greyed out

glad you got it working!! I had to learn through TAC after I upgraded CUCM and started using CUPC 8. Was quite confused there until TAC explained.

Jonathan Beardsley CCNA Voice; MCITP Telecom & Network Administrator DECOSIMO

Re: CUPC 8 video option greyed out

Hello,

You need not be in Softphone mode to make video calls using CUPC. It is possible with Deskphone mode also. Starting CUPC 8 , it is made to operate in Deskphone mode by default. So, immediately upon logging into the client, you see the checkbox "Use My Deskphone for Audio" is enabled/checked. If you check the CSF device status in CUCM, it appears "unregistered", as CUPC will operate in only one mode at a time.To use CUPC in Softphone mode, the checkbox for deskphone has to be cleared, UCM now displays CSF as registered.

Coming to the actual issue of Video option grayed out, it is most likely because of two reasons.

a. The desk phone isn't connected to the PC's network port directly.

b. Under CUCM Phone page, 'video capabilities' option isn't enabled.

The above two are the requirements to use CUPC for video calls with Deskphone. i could see from the post that video calls are working fine in softphone mode, wanted to share this info too

-Sankar

Sent from Cisco Technical Support iPad App

Re: CUPC 8 video option greyed out

Awesome!!! Thanks for clearing that up! I am going to check that out right now! so much to the CUCM system. Its really wonderful to find new features and how they work!

Jonathan Beardsley CCNA Voice; MCITP Telecom & Network Administrator DECOSIMO
Beginner

CUPC 8 video option greyed out

Hi:  We have CUPC 8.5.4 and my PC is directly connected to the phone.  I cannot place a video call with the hardphone in use, even though it is connected to my PC and video is enabled.  When I place a call, the switch at the bottom to switch from video to audio is greyed out.

BTW, this used to work with the old Cisco video software and a UC540.

CreatePlease to create content
Content for Community-Ad
FusionCharts will render here