cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

1631
Views
5
Helpful
3
Replies
Igor Lukic
Collaborator

CUPS 8.6.1 on VMware Workstation 7.1.2 - After reboot of host, CUPS is unreachable

Hi,

after installing CUPS 8.6.1.10000-34 in VMware Workstation 7.1.2 build-301548 and eventually rebooting the host, CUPS is not reachable via IP anymore, i.e. ping from physical NIC of the host to virtual NIC of the CUPS VM fails (Destination Host Unreachable). This also applies vice versa, as well as to HTTP/HTTPS, SSH traffic, etc.

Before the reboot of the host, there were no issues. The reboot had to be done, due to system updates.

The suprising fact is, that the CUPS can ping the CUCM (8.6.2.20000-2, also running on the same host and VMware Workstation), but no other machine.

In order to disqualify firewall issues, I turned off the host's firewall, as well as the iptables firewall of the CUPS. However the issue still persisted.

Did anyone run in the same problem? So far the only solution was to reinstall CUPS and not to turn off the host...which is not really acceptable, even in a test environment.

Thanks a lot in advance for your help!

Kind regards

Igor Lukic

1 ACCEPTED SOLUTION

Accepted Solutions
Mike Lydick
Beginner

Try login to the platform administration "cli". Set the gateway ip address, it can be set to the same address. I have VM that will be able to arp the gateway until I do a "set network gateway {ip address}". After loading them I just set the gateway again and I am able to get to them.

I believe this due to the use of a Microsoft Loopback Adapter, if that fits your scenario.

If you are not using a loopback you may need to adjust the network configuration or VMworkstation to use a specific physical interface instead of automatic selection.

View solution in original post

3 REPLIES 3
Mike Lydick
Beginner

Try login to the platform administration "cli". Set the gateway ip address, it can be set to the same address. I have VM that will be able to arp the gateway until I do a "set network gateway {ip address}". After loading them I just set the gateway again and I am able to get to them.

I believe this due to the use of a Microsoft Loopback Adapter, if that fits your scenario.

If you are not using a loopback you may need to adjust the network configuration or VMworkstation to use a specific physical interface instead of automatic selection.

View solution in original post

Hi Mike,

thanks a lot for such a fast post!!! Setting the gateway address with "set network gateway {ip address}" helped resolve the problem.

Kind regards,

Igor

The usual problem is that the Cisco OS comes with the WMware drivers for ESXi and not Workstation. As a result the NIC does not come up correctly. Anything that takes down the NIC and brings it up again (such as changing the gateway address) will work until the next time you reboot.

Update the WMware driver in your CUPS

With the CUPS running in WMware use VM/Install WMware tools.

Then on the CLI of CUPS enter: utils vmtools upgrade

You can also check which versions of the WMware driver is installed with: utils vmtools status

Graham

Create
Recognize Your Peers
Content for Community-Ad