Showing results for 
Search instead for 
Did you mean: 

CUPS/CUCM: 9.0.1, Jabber 9.2.3 + UDS: Mixing of two contacts profile


We have an issue when our user are searching a contact with the same userid beginning of another contact in Cisco Jabber.

We have two LDAP users with the same userid beginning:


Userid 1= test

Userid 2=testpde

When we are looking for "test" in Cisco Jabber, the first time, it displays  the both contact. But if we display their profiles, it's a mix between Lastname and firstname of user1 and user2. The second time, it displays only one contact.

  • We have checked the xml return of CUCM: https://<CUCM@>:8443/cucm-uds/users?max=21&start=0&name=test

. We have the two users with good information.

  • We have tried with a Jabber alternative client and it's the same

We have tried with

  • two local users = Ok
  • One local user and one ldap user = NOK
  • two ldap user = NOK

So, it seems the bug is localized on the IM & Presence server

Our environment is:


Cisco Jabber for Windows: 9.2.3

LDAP synchronization from Active Directory with samaccountname=userid

Directory Server Type for Cisco Jabber: UDS

Thank you very much if you can help us

Best regards



So, it seems the bug is localized on the IM & Presence server

I doubt that. Based on your excellent discription it seems likely that the bug is in Jabber itself, not any of the server infrastructure. The IM&P server is not directly involved in a UDS query; the client makes the API call to the CUCM URL you list above.

The client has a local cache which stores contact details. This is emptied when the application quits. My guess is that Jabber is storing one of the results to the cache (likely the exact match) and stops doing a UDS query. You could test this theory by exiting the application entirely, which should clear the cache, and trying it again.

The 9.2(4) client has FCS so you could download and try that. If it persists it's likely time for a TAC case to get a defect filed.

Please remember to rate helpful responses and identify helpful or correct answers.


Thank you very much Jonathan for your answer,

I have already clean all local cache and try to exit.

I have tried with cisco jabber 9.2.(4) but it's the same

I have concluded that it's the Im & Presence Server because, I used a free Jabber client and I added the Userid: test. The contact detail got from IM & Presence server was not good and was the same than Cisco Jabber.

Have you already seen this kind of issue ? Do yuou think the version 9.1.2 could solve my issue ?


As Jonathan noted, UDS is from CUCM, not CUPS, so CUPS isn't your issue.  I discovered that we're hitting the same issue this morning with our similar environment.  I confirmed UDS is returning the correct results, but Jabber is mixing up the usernames if they match or have any overlap.  I opened a case with TAC, as this is clearly a client-side bug.

I'm testing on 9.2.5.


Hello Paul,

We have found that this bug was due to UDS version in CUCM 9.0.1. A case is opened on this issue:

We have upgraded in version 9.1.2 and the issue is not present.

Best regards



It seems odd that this would be a UDS bug since if I query UDS directly in the web browser, I get the results I would expect.  I may switch us to LDAP integration to work around it/see if this bug is truly what we're hitting.

Content for Community-Ad