cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
10817
Views
9
Helpful
41
Replies
Highlighted
Beginner

Deskphone disabled on CUPC release 8.x

Deskphone disabled on CUPC release 8.x

Hello All,

We have a CUPS release 8 that runs fine on CUPC release 7.x. Yesterday we upgraded the CUPC client to 8.x and now the deskphone feature is greyed out. Chat and all other features are working except the deskphone.

When we test this with CUPC 7 it works at the same time with the same user accounts. Please assist on this.

When I check the Server health the notification is " failed to connect to ccmcip authentication server"

Is this related to the Deskphone ?

Is there any additional configuration that needs to be done on CUPS for CUPC 8.x other than what was done for CUPC 7.x

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Per the log, your certificate on CUCM was expired.  You should regenerate the Tomcat cert.

1) Log into CUCM OS Administration page

2) Security > Certificate Management.  Click "Find" to list all certs.

3) Click on "tomcat.pem"

4) Click on "Regenerate"

5) On command line, type "utils service restart Cisco Tomcat"

Michael

View solution in original post

41 REPLIES 41
Highlighted
Beginner

Screen shots of the client is attached

Highlighted

CUPC 8 uses CCMCIP service on CUCM to retrieve the "controlled device".

Please make sure you configured CCMCIP address correctly from CUPS > Application > Cisco Unified Personal Communicator.

I recommend you take a look at http://www.lulu.com/content/5552336.  It covers CUPS 8 and CUPC 8 configuration.

Thanks!

Michael

http://htluo.blogspot.com

Highlighted

Thanks Mike, Lemme check this quickly and get back..

Highlighted

Hello

I configured the CCMCIP Settings, however still the Deskphone is greyed out.. Please check my screenshot

Highlighted

You need to kill cucsf.exe from task manager to reload the config.

Michael

http://htluo.blogspot.com

Highlighted

Dear Mike,

I am sorry to say I did terminate this process but the same result. Only the Deskphone is still greyed out.. Do you see any other reasons why this is happening. The funniest part is CUPC 7 works so well with the same user ids..

Highlighted

If CUPC7 works fine but CUPC8 doesn't, it has to be CCMCIP issue.  What error message you got on CUPC8?

Michael

Highlighted

The error message is

" Device initialization error has occured. Failed to connect to ccmcip authentication server [1201]"

I know there is something wrong with the CCMCIP settings but cant identify what and I am not sure if the CCMCIP settings that I gave was correct. Screenshot of CCMCIP settings was attached in the previous post.

Another point I noted is, In CUPC 7 also if I check the server health status the phone configuration is down. But still deskphone feature works in 7.x may be because it is failing over to a backup config residing locally.

Highlighted

Create or Modify the following registry key

  • HKEY_CURRENT_USER\Software\Cisco Systems, Inc.\Client Services  Framework\AdminData\CcmcipServerValidation
  • Type  : String / REG_SZ
  • Value : 0

After that, kill cucsf.exe from Task Manager.

Details: http://www.cisco.com/en/US/docs/voice_ip_comm/cucimoc/7_1/english/integrat/guide/config_clients.html#wp1054938

Michael

http://htluo.blogspot.com

Highlighted

HI

I made the changes above and no luck.. I am attaching the problem report here. Could you please verify this and let me know If you find any issues.

Highlighted

How did you get the report?  It should be a single big zip file on your desktop other than three small files.

Michael

Highlighted

Thanks for the reply mike.

Here u go...

Highlighted

Per the log, it's still the CCMCIP certificate issue.

Could you export your registry hive HKEY_CURRENT_USER/Software/Cisco Systems, Inc./AdminData/ and upload here?

Thanks!

Michael

Highlighted

I got It.. Please find the registry settings attached..

Thanks

Content for Community-Ad