cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1556
Views
15
Helpful
10
Replies
Beginner

Enabling Mix-mode on CUCM 11.5.1SU4

Hey everyone, I've been having some trouble with a new deployment and I'm guessing I'm just missing something but for some reason I cannot get Mix-Mode to turn on in the CLI for CUCM. 

 

I'm running CUCM 11.5.1SU4 with the proper encryption license uploaded on PLM but whenever I run the utils ctl set-cluster mixed-mode the terminal just freezes and I cant enter a "Y" to enable it. 


If anyone has an idea let me know. 

 

Thanks,

Matt

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Cisco Employee

Re: Enabling Mix-mode on CUCM 11.5.1SU4

That's really all you need to do in regards to the actual process of enabling mixed-mode.

https://youtu.be/0FDABxcBLy0

I'd try to restart the server and try after that.

HTH

java

if this helps, please rate
10 REPLIES 10
Hall of Fame Cisco Employee

Re: Enabling Mix-mode on CUCM 11.5.1SU4

That's really all you need to do in regards to the actual process of enabling mixed-mode.

https://youtu.be/0FDABxcBLy0

I'd try to restart the server and try after that.

HTH

java

if this helps, please rate
Beginner

Re: Enabling Mix-mode on CUCM 11.5.1SU4

Jaime, great video as always, followed your CMS one few month back and it was extremely helpful. 

 

It's certainly a weird error I'm getting here. I've done this before on a 11.5.1SU2 cluster 6 months ago and hit no issues. The only thing I can think of off the top of my head is that it has no other 11.5 license on it yet. Got the encryption one first and figured I'd just get it together. 

 

I've tried through putty and Vsphere console and both just hang at the This operation will set the cluster to Mixed mode. Do you want to continue? (y/n): step and I cannot enter "y" or anything else for that matter. The only I can do is click enter (as shown in the attached picture) to bring up a duplicate line.

 

I've let it go for over an hour so I figured your sped up part of that wasn't that long. 

 

Hall of Fame Cisco Employee

Re: Enabling Mix-mode on CUCM 11.5.1SU4

No, that is definitely not something that goes for an hour, it might vary depending on load, but for my lab it was around 5 minutes, or less.

 

Do you have CA signed certs? or self-signed?

HTH

java

if this helps, please rate
Beginner

Re: Enabling Mix-mode on CUCM 11.5.1SU4

Call Manager/Tomcat are signed by an Internal CA with CAPF still using the self-signed cert. All Call Manager/Tomcat/CAPF - Trust certs have my root CA trusted. 

 

It's strange that I cant even type a "n" like I made a mistake and want to back out. Basically seems like it locks after I type the command. 

Beginner

Re: Enabling Mix-mode on CUCM 11.5.1SU4

So a little unconventional but I ran it again but I was frustrated so decided to hit Enter and Y back to back a couple times and watched for about 20 minutes the came back and it appears to have worked. 

 

I'm going to assume it's something resource based as it truly kept sitting there for an hour. In any event it's working now. 

Hall of Fame Cisco Employee

Re: Enabling Mix-mode on CUCM 11.5.1SU4

That's weird, I'd look at resource usage and IO wait in your server to confirm if that's really the case.

HTH

java

if this helps, please rate
Participant

Re: Enabling Mix-mode on CUCM 11.5.1SU4

Just had the same behavior on 11.5(1)SU6. Tried slowly pressing Y then Enter in case it was a keyboard latency issue, since Ctrl+C would eventually quit the command after a few minutes' wait. Your button mash trick finally got it running for me.

admin:
admin:utils ctl set-cluster mixed-mode
This operation will set the cluster to Mixed mode. Auto-registration is enabled on at least one CM node. Do you want to continue? (y/n):
This operation will set the cluster to Mixed mode. Auto-registration is enabled on at least one CM node. Do you want to continue? (y/n):
This operation will set the cluster to Mixed mode. Auto-registration is enabled on at least one CM node. Do you want to continue? (y/n):

Control-C pressed

admin:utils ctl set-cluster mixed-mode
This operation will set the cluster to Mixed mode. Auto-registration is enabled on at least one CM node. Do you want to continue? (y/n):
This operation will set the cluster to Mixed mode. Auto-registration is enabled on at least one CM node. Do you want to continue? (y/n):
This operation will set the cluster to Mixed mode. Auto-registration is enabled on at least one CM node. Do you want to continue? (y/n):
This operation will set the cluster to Mixed mode. Auto-registration is enabled on at least one CM node. Do you want to continue? (y/n):

Moving Cluster to Mixed Mode
Cluster set to Mixed Mode
Please Restart Cisco Tftp, Cisco CallManager and Cisco CTIManager services on all nodes in the cluster that run these services.
Beginner

Re: Enabling Mix-mode on CUCM 11.5.1SU4

Hi Jaime,

The video is unavailable.

https://youtu.be/0FDABxcBLy0

 

Regards,

Shinas

Hall of Fame Cisco Employee

Re: Enabling Mix-mode on CUCM 11.5.1SU4

YT shutdown my channel since November, still working out the new home for the videos, in the meantime, you can review the documentation from CCO on enabling mixed mode.

HTH

java

if this helps, please rate
Highlighted
Beginner

Re: Enabling Mix-mode on CUCM 11.5.1SU4

Hi

I also faced this issue yesterday when I tried to configure mixed mode on CUCM 11.5.1SU5. Then I restarted the node and tried again and it worked fine.

 

 

Regards,

Shinas

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards