Showing results for 
Search instead for 
Did you mean: 
Frequent Contributor

Expressway-c cannot connect to IMP


I have upgraded Expressway C&E from 8.2 to 8.8.2 (the latest). After upgrade the Expressway has a connection with the CUCM, but not anymore with IMP. In the GUI from Expressway-C and checking the "IMP and Presence nodes" I see the status

Inactive: (Remote host is reachable but connection is not established. Either refresh this page, or check the credentials.)

I have deleted the node and added it again, but each time I see this message. When I give a wrong password I get the message wrong password, so some communication is established.

Anyone has seen this?

CUCM version

IMP version

Any help would be apreciated


Cisco Employee

Hi JH,

Hi JH,

In version 8.8, there is a new module cvs.verifier which is doing more struct checks on the certificate.  In order to discover successfully a CUCM/IM&P cluster when using self signed certificates, certificate of each node of the cluster MUST be added to the trust store of Expressway. If there is one missing certificate, discovery will fail for all nodes.

You may verify this and see if it helps.


Frequent Contributor

Hello Manish,

Hello Manish,

I downloaded the tomcat certificate from the IMP server and uploaded it to the trusted store of Expressway-C. From the log-files from Expressway-C I can see there is an issue with the certificate, some messages regarding "handshake"

The issue is that the CUCM is discovered correctly

Maybe a regenerate of the IMP certificate?




Hi ,,

Hi ,,

I have the same exact issue, any update regarding this please.

Frequent Contributor

we execute the following

we execute the following command on Expressway-C

xConfiguration XCP TLS Certificate CVS EnableCvs: Off

No idea what it does, but it solved the problem

Re: we execute the following

Thanks, It Worked for me.


The issue was resolved when I

The issue was resolved when I added the XMPP certificate of the IMP on the expressway 


As to add to this topic: i

As to add to this topic: i was seeing the same behaviour after having upgraded the IM&P node from 10.5.1 to (while using X8.8.3 on Expressway-C/E)

Restarting the XCP Router services on the IM&P node resolved the matter for me.

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards