cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
1309
Views
15
Helpful
13
Replies
Highlighted
Beginner

How do I disable Music on Hold?

Hi,

 

I'm quite new to voice and collaboration.

 

I would like to know how to definitively disable music on hold.

 

I set the Run Flag to NO on the Music on Hold Server.

 

It worked for a few days, and now the music is back

 

Please help!

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

I am astounded that MoH works with all servers in the cluster having the Run Flag set to "No". But, okeedoke.

Rath, I think, has the right idea but his logic is backwards. To block access to the MoH servers, put all of them in an MoH_MRG, but do not put that MRG into any MRGLs. Resources that are not in an MRG are freely available to all devices. But as soon as you put resources into an MRG, the MRG must be in the device's MRGL in order for the device to use the resource. I have been successful at blocking access to the software conference bridges using this method.

Maren

View solution in original post

13 REPLIES 13
Highlighted
VIP Collaborator

Each server that is running the IP Voice Media Streaming App Service has its own instance of MoH available. Turning off MoH on one server does not turn it off on all servers. Have you logged on to each server individually and set the Run Flag to "No" for MoH on the server?

Maren

Highlighted

Hi Maren,

 

Yes, i set run flag to "No" on both subscribers.

Highlighted
VIP Collaborator

Hi there

 

Try creating an MRGL with MRG which doesn’t have any MOH servers. Assign that MRGL to all phones and test it.

 

Also there is an alternative to upload a silence.wav file as MOH file and push it to all phones. That works as well.

 

Hope this Helps 

Cheers

Rath!

 

***Please rate helpful posts***

Highlighted

Hey Rath,

Would this be the same as removing the MOH servers from the existing MRG, or would i need to create another one?

Thanks,

Sam
Highlighted

Just for testing create a new one and apply on a couple of phones and see that works

Hope this helps
Cheers
Rath!

***Please rate helpful posts***
Highlighted

Hello Sam,

I don't think that will work if you remove all MOH source form MRGL and assigned phone/DP. I tested and it didn't work for me.

I believe the best way to avoid MOH is to upload a silent file on the server as MOH audio source in all of your server.

 

Under Media Resources --> Music On Hold Server Audio Source.

 

Regards,

Shalid 

Please remember to rate useful posts, by clicking on the stars below.

Highlighted

I am astounded that MoH works with all servers in the cluster having the Run Flag set to "No". But, okeedoke.

Rath, I think, has the right idea but his logic is backwards. To block access to the MoH servers, put all of them in an MoH_MRG, but do not put that MRG into any MRGLs. Resources that are not in an MRG are freely available to all devices. But as soon as you put resources into an MRG, the MRG must be in the device's MRGL in order for the device to use the resource. I have been successful at blocking access to the software conference bridges using this method.

Maren

View solution in original post

Highlighted

Hi Maren, It is not my original thread, but I am interested to see how it works. I had created a test MRGL and assigned no MRG to the test MRGL. applied this to the phone as well as test device pool. I do not have any unassigned MOH or other media resources, where I have added all the unused media resources to separate MRG [MRG_unused] and MRGL_unused. I made a call from PSTN to my IP phone --> MOH works sample audio from IP phone to PSTN --> MOH works with sample audio I am not sure if I miss anything here... Regards, Shalid
Highlighted

I just stood this up in my lab and it works exactly as I described:

  • Create MoH_MRG
  • Add all MoH resources to the MRG
  • Create a No_MoH_MRGL and do not add the MoH_MRG to it.
  • Assign the No_MoH_MRGL to the phones and to the PSTN SIP Trunk

With this, I do not hear MoH on held calls between phones or to/from the PSTN regardless of whether the internal phone puts the call on hold or the PSTN phone puts the call on hold.

Additionally, when I assigned the All_MRLG to the phones and to the trunk I did hear MoH, but when I then turned the Run Flag to No on both of my servers I stopped hearing MoH again.

As an additional test (after turning the Run Flag back to Yes), I assigned the No_MoH_MRLG to the phones, but assigned the All_MoH to the SIP trunk. This means that the phones do not have access to MoH resources, but the SIP PSTN trunk does:

  • Calls to the PSTN where the internal phone puts the call on hold, the PSTN phone gets MoH because the SIP trunk has access to MoH resources.
  • Calls to the PSTN where the PSTN phone puts the call on hold, the internal phone does not get MoH because the phone does not have access to MoH resources. It did hear the beeps, though, as it should in that situation.

So, if you are hearing MoH on PSTN calls check the MRGL associated with the PSTN gateway/trunk.

That said, I am running 11.5 in my lab at the moment and not 12.5. But I would be very surprised if the behavior has changed in the new version as that would fundamentally change media resource architecture.

Maren

Highlighted

Thanks for the explanation. SIP trunk did the work !!!! Overlooked into it. My bad.. Regards, Shalid
Highlighted

@samkungu

If you have set the Run Flag to "No" on both of your Subscribers and you are still hearing MoH, then there is another MoH source in your cluster. You mention the Subscribers, have you checked your Publisher?

And read my test steps above. What I have written there is how media resource allocation should work.

Maren

Highlighted

Hi Maren,

 

I followed your instructions and now can no longer hear MoH, thanks for the help.

 

Thanks,

 

Sam

Highlighted

Hi Marin

if i want to disable moh for certain users but not all users will the same apply?