cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
11955
Views
25
Helpful
35
Replies
Highlighted
Beginner

IM and Presence 10.5 Installation Issue

Hi All,

I have successfully installed and configured CUCM 10.5.2.10000-5 , but I proceed to install the IM&P server 10.5.2.1000-9 on the same node, the prompt error. "This is not the First Node in the cluster"

This is IM and Presence Server version 10.5.2.1000-9, I have tried delete the VM in ESXi Host and rebuild the VM using OVA template, added this IMP Server in my CUCM (System --> Server), but still the same isse.

 

Does anyone know what is the problem with this and how to solve it?

35 REPLIES 35
Highlighted
Hall of Fame Cisco Employee

Have you verified that there is nothing blocking connectivity?

Did you properly added it as an IM&P node??

Have you tried rebooting the PUB and then trying to install the node?

Do you have proper DNS resolution?

HTH

java

if this helps, please rate
Highlighted

Have you verified that there is nothing blocking connectivity?

connectivity is OK.

Did you properly added it as an IM&P node??

CUCM (System --> Server)add "CUCM IM&P node".

Have you tried rebooting the PUB and then trying to install the node?

CUCM is reboot.

Do you have proper DNS resolution?

DNS resolution OK.

 

Highlighted

Hi,

In addition to tips by Jaime,can u try entering only hostname in CUCM for IM & P Pub instead of using FQDN , if u have done that way?

 

regds,

aman

Highlighted
Engager

Your error does not say "This is not the first node" it says the node you are trying to add does not exist in the publisher's database.

 

Make sure the hostname you entered in the IM&P installer is exactly the same as that in CCMAdmin,

 

GTG

Please rate all helpful posts.
Highlighted
Beginner

"This is not the First Node in the cluster"

 

If you are receiving this message while doing the install wizard of the application, this is not an error, but is in fact just part of the process.  In CUCM/IMP 10.5, all of the IMP servers are subscribers to the CUCM publisher.  So when you add the first (or only) node that is IMP node, you will need to point it to the CUCM publisher and enter the hostname, IP address and cluster security password for this CUCM publisher into the wizard as part of the configuration wizard process.  I hope this helps.

Highlighted

Hi,

I have installed IM&P 10.5.1.10000-9 but the admin page is not coming up. Earlier I was able to access CLI through Putty but now it's not working. I have already added it to CUCM before installtion. (10.5.1.10000-7). When I take console of IM&P and run command "utils ntp status", it shows IM&P at stratum 4, will this cause any issue. I located it in the bug CSCus73014 (https://bst.cloudapps.cisco.com/bugsearch/bug/CSCus73014/?referring_site=bugquickviewredir). But I am not sure why I was able to access CLI earlier. Can someone please provide workaround for this?

Thanks
Rakhi
Highlighted
Beginner

Thank you very much, I'm install ok.

I did not modify any configuration,only reinstall IM&P.

Highlighted

Hi Song Yi, can you tell me what helped you exactly to install this IM&P, as i am also facing the same issue.
Thanks
Highlighted
Beginner

I had upgraded my CUCM1(Pub) to 10.5.2.10000-5.

The BE6K came with CUCM 10.5.1.10000-7.

I next (a few days after I upgraded CUCM to 10.5.2.10000-5) decided to install IM&P with what came with the BE6K which was 10.5.1.10000-9.

I forgot to add the IMP1 to the CUCM1 and of course it could not find the 'First Node in the configuration'. 

I had to abort that initial install, then add the IMP1 to the CUCM1 and then delete the entire VM and deploy OVF and build from the Bootable IMP 10.5.1.10000-9 and opt for the 'patch upgrade'.

Didn't work.

I deleted the IMP1 VM again.

Deleted the entry under servers on CUCM1, rebooted CUCM1.

Tried again - didn't work. Gave up with the patch upgrade option.

Deleted IMP1 VM again and it still didn't work.

Finally (hours and hours later).

I used UltraISO to make the IMP 10.5.2.20000-1 .iso bootable (by adding a .bif) and you know what?!

The IMP1 install worked! Phew.

The Cisco documentation on the IMP 10.5 installation and troubleshooting is abysmal. They could have at least come up with a friendly prompt to remind you to add the IMP1 server to the CUCM1 pub (started in 10.x), surely? Oh no, not that clued in to the actual end-user/tech tech deployment experience and reducing time, effort and possible TAC help install support calls.

The Cisco installation doc for IM&P 10.5 is merged with CUCM docs - you would have thought it would make it easier to 'find' and figure out? Wrong!

Anyway, the installation doc states that Major Release.VersionNumbers 'are compatible'. Meaning 10.5(1) 'is compatible' with 10.5(2), because the numbers to the immediate left of the '.' and to the immediate right - are the same.
After this episode - my verdict on the reality of this is: 'poppycock'. That's English for 'wot a loadarubbish', which is also English for Codswollop, which is also English for 'nah, that isn't in fact the case'.

Hope this helps some poor soul out there and avoids what I have just had to go through (mostly in MY time). Now for that fresh pot of tea that has been hard-earned and is richly deserved.

:)

ChrisO

Highlighted
Hall of Fame Cisco Employee

The RNs for 10.5(2) clearly state that IM&P 10.5(2) is only compatible with CUCM 10.5(2)

HTH

java

if this helps, please rate
Highlighted

Yup, you are correct. I tried installing with bootable 10.5(1) using the 'Patch Upgrade' option to 10.5(2a), but for whatever reason it could not find (or would not find for whatever reason?) the .iso, either via the DVD on datastore or on my sFTP server (which I know works).

Hence my workaround to make the patch upgrade .iso 'bootable' in the end.

:-)

 

10.5(2) Relnotes for IM&P:

http://bit.ly/1yXZh3C

 


Note
 

You must upgrade Cisco Unified Communications Manager to Release 10.5(2) before you upgrade the IM and Presence Service nodes.


If you want to upgrade IM and Presence Service from Release 10.5(1) (or earlier) to 10.5(2), you must also upgrade Cisco Unified Communications Manager to Release 10.5(2).

Similarly, if you upgrade Cisco Unified Communications Manager from Release 10.5(1) (or earlier) to 10.5(2), you must also upgrade IM and Presence Service to Release 10.5(2).

IM and Presence Service Release 10.5(2) is compatible only with Cisco Unified Communications Manager Release 10.5(2).

Highlighted

Hi Cogden,

  I've an issue like you.

CUCM publisher in 10.5.2.10000-5, but Bootable DVD of the IM&presence server is in version 10.1.

 

I've tried to make bootable iso of the IM&Presence 10.5.2.2000 but when booting stop immediatly wich checksum error.

 

What is going wrong?

 

I can'r wait for the original media from Cisco.

 

Can you help me?

 

Highlighted

See my Word notes on how to make a non-bootable, bootable. Acknowledgement to 'James'. The snapshot jpgs are mine though.

You need to install UltraISO for this though.

Chris

Highlighted

Chris, you save me the life! Thank you very much. Works great. 

Content for Community-Ad