cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

489
Views
60
Helpful
11
Replies
arouna.kikone1
Beginner

inbound call issue

Hello Everyone,

Please, i need your help!!!

 

I have a 12.0.1 cucm with an E1 / PR1 gateway. I manage to send the calls to the outside but the calls coming from the outside do not succeed. the "debug isdn q931" command shows me the correct calling number but the called number is incomplete. only the last 7 numbers called appear instead of all 10 digits so that calls are unsuccessful. Can you help me solve this problem?

 

.......................................

 

j'ai un cucm 12.0.1 avec une passerelle E1/PR1. j'arrive a émettre les appels vers l’extérieur mais les appels venant de l'extérieur n'aboutissent pas.
la commande "debug isdn q931" me montre le numéro appelant correct mais le numéro appelé est incomplet. seulement les 7 derniers numéro appelé apparaissent au lieu de tout les 10 chiffres ce qui fait que les appels n'aboutissent pas.
Pouvez vous m'aider a résoudre a ce problème?

 

debug log:

Calling Party Number i = 0x0081, '0757662216'
Plan:Unknown, Type:Unknown
Called Party Number i = 0xA1, '2'
Plan:ISDN, Type:National
High Layer Compat i = 0x9181
Jul 26 17:58:10.384: ISDN Se0/1/0:15 Q931: TX -> SE
VOICEGATEWAY#TUP_ACK pd = 8 callref = 0x8F06
Channel ID i = 0xA98383
Exclusive, Channel 3
Jul 26 17:58:10.396: ISDN Se0/1/0:15 Q931: RX <- INFORMATION pd = 8 callref = 0x0F06
Called Party Number i = 0xA1, '0252728'
Plan:ISDN, Type:National

11 REPLIES 11
Nithin Eluvathingal
VIP Advisor

Its not mandatory that ISP send full digit as called Number to your PRI. If you need to see full digit as your called number contact your ISP

 

 

I assume that you might be using some translation rules  to strip extra digits or to translate the DID to match your extension. In that case, change the translations rules to match the called number.

 

 

To provide the best solution, please share with us the gateway configuration. or provide us below details.

 

  • Which protocol you use for gateway
  • Whats your internal extension series
  • is there any translation involved to land the DID on extensions.

 

 

 



Response Signature


Sadav Ansari
Participant

Share your complete debug isdn q931 output with disconnection cause code.

Also your gateway protocol and gateway configuration.

 

Pls vote all useful post!!

Pls rate if its “Helpful”. If this answered your question pls click “Accept as Solution”.

Roger Kallberg
VIP Advisor

You need to create a translation of the called number to fit your needs. Where you do this depends on what control protocol you use for your gateway. If it’s SIP or H.323 you can do it directly in the gateway with voice translation rule(s) and if it’s MGCP you would do it with either translation pattern(s) in CM, theses need to be visible in the incoming CSS of the gateway, or simply set the number of digits to keep on the gateway configuration element in CM. What you do depends on what you’d need to do with the called number, ie modify it in a more complex manner or simply keep a few of the digits of the incoming called number.

See this document for details on how to configure voice translation rules in the gateway.
https://www.cisco.com/c/en/us/support/docs/voice/call-routing-dial-plans/61083-voice-transla-rules.html



Response Signature


arouna.kikone1
Beginner

@Sadav Ansari @Nithin Eluvathingal @Roger Kallberg 

The internal extension is:

5xx

6xx

7xx

ISP T2 number is  2720252500

See below my gateway configuration

 

isdn switch-type primary-qsig
!
!
!
!
!
!
!
!
!
!
!
!
voice-card 0/1
dsp services dspfarm
no watchdog
!
voice-card 0/2
no watchdog
!
license udi pid ISR4321/K9 sn FDOxxxxxxxx
!
spanning-tree extend system-id
!
username admin privilege 15 secret 5 $1$nfW1$g4iQTbGP52/pksvaTUtjG/
!
redundancy
mode none
!
controller E1 0/1/0
framing no-crc4
pri-group timeslots 1-31 service mgcp
!
!
vlan internal allocation policy ascending
!
!
!
!
!
!
interface GigabitEthernet0/0/0
ip address 10.155.xx.254 255.255.255.0
negotiation auto
!
interface GigabitEthernet0/0/1
no ip address
shutdown
negotiation auto
!
interface Service-Engine0/1/0
!
interface Serial0/1/0:15
encapsulation hdlc
isdn switch-type primary-qsig
isdn incoming-voice voice
isdn bind-l3 ccm-manager
!
interface Service-Engine0/2/0
!
interface GigabitEthernet0
vrf forwarding Mgmt-intf
no ip address
shutdown
negotiation auto
!
interface Vlan1
no ip address
shutdown
!
ip forward-protocol nd
no ip http server
no ip http secure-server
ip tftp source-interface GigabitEthernet0
!
!
!
!
!
control-plane
!
!
voice-port 0/1/0:15
!
voice-port 0/2/0
!
voice-port 0/2/1
!
voice-port 0/2/2
!
voice-port 0/2/3
!
!
!
!
!
mgcp
mgcp call-agent 10.155.xx.252 service-type mgcp version 0.1
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
!
ccm-manager redundant-host 10.xx.15.253
ccm-manager mgcp
ccm-manager config server 10.155.xx.252
ccm-manager config
!
telephony-service
max-conferences 8 gain -6
transfer-system full-consult

 

As you are using 3 digit extension, for inbound call with 0252728  call to hit on extension 728, you need the below configuration.

Note:- Use proper CSS based on your deployment.

 

CUCM>>DEVICE>>GATEWAY>>FInd your gateway and apply the below config.

 

Capture.PNG

 

If you are not using last three digits of your DID as your extension, we need to apply translation on CUCM. Please confirm..

 

 



Response Signature


@Nithin Eluvathingal 

i confirm that I'm using the last three digit of my DID as my extension.

The above config will resolve your issue.

 

 



Response Signature


thank you for your various help.

I will apply your recommendations and I will get back to you later

I forgot to mention one thing, after making changes on gateway CUCM page,  Issues no mgcp and mgcp from gateway CLI. 



Response Signature


The solution as suggested by @Nithin Eluvathingal should be what you’d need to implement to achieve your described outcome.

Remember to reset the gateway in the CM webUI to activate the changes.



Response Signature


Apply configuration as @Nithin Eluvathingal suggested and reset your Gateway to take change effect.

 

Pls share your output once done.

 

Pls rate if its “Helpful”. If this answered your question pls click “Accept as Solution”.

Create
Recognize Your Peers
Content for Community-Ad