Showing results for 
Search instead for 
Did you mean: 
Walkthrough Wednesdays

IP Communicator one way audio issue


I have an issue with remote users not able to use Cisco IP communicator when connected to the VPN, after research I found the Cisco IP Communicator tool that needs to be ran in the Publisher server, my question is how do upload the file in to the server and how do I run it ?


I tried using the OS administration; Software Upgrades, TFTP file Management, but this does not tell me the location where the file is going to be, not sure if this is the correct way to upload the file, or should I use the CM Administration option Bulk administration /upload files


I'm running CUCM Ver.

Cisco IP Communicator Ver.







When logged in via VPN ping all your Call Manager servers and also IP phones at different locations.


Your VPN may be restricted to what subnets you have access to, hence being able to establish the call as most VPNs would have access to centralised servers but not branch locations. Hence the one way audio.


I agree with heathrw.


1. Check VPN connectivity. You must be able to ping from client to CUCM servers.

2. You must be sure that rtp traffic can go between clients. Check rtp ports on firewall.

3. You can try to use Trusted Relay Point to proxy traffic via CUCM/MTP. Check 

Be ready

Thanks every one for the replays, sorry I was out of the office last week so I was not able to respond,


Here is the scenario in a more detailed way

User connected to the VPN tunnel are able to ping the headquarters network and services, I'm able to ping the FTP server and IP communicator is able to register the device in Call Manager, however when a call is placed only one way audio is available, I'm not able to listen the person I called but he is able to her me, I'm using a check point Firewall as the VPN server, I checked on their website and all the settings are confirmed to be correct.

On the Cisco side I found an article about this issue which recommend to run the IP communicator tool, so my question was how to run the tool, I have download the file but not sure how to upload it and run it in Call Manager.


I would like to upload the tool and run it to see if that resolves the issue, attached are a couple of screen captures showing the device registered and the TRP option on.






I would confirm your MTP or Transcoder is configured, registered and allocated as a trusted relay point, along with the configuration of the media resource groups.


Make sure that the VPN has access to all the CUCM IP addresses, TRP IP Segment. As a test I would even add an IP Phone subnet for a single location and test direct point to point calls. 


Please add the link to the article on the CIPC tool. 



Hi Heathrw

I Have checked and tested MTP and is all ok, also tested point to point calls and it works when directly connected, still no go for VPN, do you know how to upload the IP Communicator tools to call manager ?

according to the below article this might resolve the issue.

Audio IP address auto detection problems



Hi Luis,

Looking at the doco the CIPC administration tools appears to be for pre CCM 5.x as the getIP.asp is a dead give away (.asp files being windows IIS).


Without more research not sure how you can get the tools going. But did a quick search on getIP.asp on the community and get a bunch of hits, so maybe worth checking out.

Thanks for the info, I have circled back to the firewall where all the fingers are pointing at this point since I tested with a Cisco ASA 5510 and 2 way audio works for remote users so Check point is on the loop and is working on the issue right now, I will keep the post upgraded as I know more.



Sound like network connectivity is the issue if it works when there is no VPN.

Make sure your VPN user can talk to the IP phones as well as your CUCM as your RTP will go point to point on a connected call!


Hope that helps!


Support Staff

All, this one threw me for a loop too until I discovered the problem. 


With VPN client connected and IP Communicator running, right-click on IP Communicator, choose Preferences > Audio > Network.  Make sure the radio button for "Audio IP Address" is set to "Detect Automatically."  Also verify that the name of the adapter you see (greyed out) to the right of "Use this adapter's address:" is "Cisco AnyConnect Secure Mobility Client Virtual Miniport."  Select OK, then OK.  Close the IP Communicator program and restart it.  Presto... two-way audio.


This is an incipid problem because there are so many other possible causes that seem like a better place to look.  But if your IP Communicator client has 2-way audio from a laptop while directly connected to the network (in the office) but not via VPN, this an important thing to check...




I'm still working on this, it has been close to a year now and no luck on resolving the issue, I have a case open with cisco TAC, we have captured logs using RTMT and wireshark, issue still under investigation, checkpoint is waiting the results of Cisco because the were not able to find anything wrong on the firewall config, apparently not to many many people have cisco phones and check point firewalls, we don't see more posts on this issue, I will upgrade when we make some progress



Content for Community-Ad

Spotlight Awards 2021