cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
461
Views
0
Helpful
0
Replies
Highlighted
Beginner

Jabber MRA cannot login

We have been experiencing issues with remote Jabber clients not being able to sign in.

We have Expressway-C and Expressway-E separated by ASA with all firewall rules in place.

* Expressway 8.2.1, Jabber for Windows 9.7.4

* both servers show Traversal Zones as active

* internal sign-in works without issues

* all required external SRV records are in place:

_collab-edge._tls.expuk.company-external.com

86400

IN SRV

10

10

8443

uk-expe-01.expuk.company-external.com

 

_sips._tcp.expuk.company-external.com

86400

IN SRV

10

10

5061

uk-expe-01.expuk.company-external.com

 

* all required internal SRV records are in place:

_cisco-phone-http                (SRV),[10][10][8443]        uk-cucm-01.company-intrnal.net

_cisco-uds                           (SRV),[10][10][8443]        uk-cucm-01.company-intrnal.net

_cuplogin                            (SRV),[10][10][8443]         uk-cups-01.company-intrnal.net

_sip                                      (SRV),[10][10][5060]      uk-cucm-01.company-intrnal.net

_sips                                    (SRV),[10][10][5061]       uk-cucm-01.company-intrnal.net

Jabber starts, connects to edge server and pulls  initial config. Then it requests UDS servers and Expressway-E throws error 404:

017-01-31T20:28:27+00:00 traffic_server[12742]: UTCTime="2017-01-31 20:28:27,583" Module="network.http.trafficserver" Level="DEBUG": Detail="Sending Response" Txn-id="11873" Dst-ip="201.29.37.82" Dst-port="49861"
HTTPMSG:
|HTTP/1.1 403 Forbidden
Date: Tue, 31 Jan 2017 20:28:27 GMT
Server: CE_C
Content-Length: 0
Age: 0
Connection: keep-alive

|
2017-01-31T20:28:27+00:00 traffic_server[12742]: UTCTime="2017-01-31 20:28:27,583" Module="network.http.trafficserver" Level="INFO": Detail="Sending Response" Txn-id="11873" Dst-ip="201.29.37.82" Dst-port="49861" Msg="HTTP/1.1 403 Forbidden"
2017-01-31T20:28:27+00:00 traffic_server[12742]: UTCTime="2017-01-31 20:28:27,556" Module="network.http.trafficserver" Level="DEBUG": Detail="Sending Request" Txn-id="11873" Dst-ip="127.0.0.1" Dst-port="32634" Tunnel-dst-host="uk-expc-01"
HTTPMSG:
|GET http://vcs_control.expuk.company-external.com:8443/ZXhwdWsuc3RyYXRlZ3lhbmFseXRpY3MuY29tL2h0dHBzL1VLLUNVQ00tMDEvODQ0Mw/cucm-uds/servers HTTP/1.1
Host: vcs_control.expuk.company-external.com:8443
Accept: */*
Cookie: X-Auth=76a9e7ca-5573-48cd-9081-e0186425d2fd
User-Agent: Jabber-Win-760
X-Forwarded-For: 201.29.37.82
Via: https/1.1 vcs[AC12640E] (ATS)

Exressway-C has corresponding entries:

2017-01-31T20:28:27+00:00 traffic_server[3869]: UTCTime="2017-01-31 20:28:27,590" Module="network.http.trafficserver" Level="DEBUG": Detail="Sending Response" Txn-id="23619" Dst-ip="127.0.0.1" Dst-port="45590"
HTTPMSG:
|HTTP/1.1 403 Forbidden
Date: Tue, 31 Jan 2017 20:28:27 GMT
Connection: close
Server: CE_C
Content-Length: 0

|

2017-01-31T20:28:27+00:00 traffic_server[3869]: UTCTime="2017-01-31 20:28:27,590" Module="network.http.trafficserver" Level="INFO": Detail="Sending Response" Txn-id="23619" Dst-ip="127.0.0.1" Dst-port="45590" Msg="HTTP/1.1 403 Forbidden"
2017-01-31T20:28:27+00:00 traffic_server[3869]: UTCTime="2017-01-31 20:28:27,566" Module="network.http.trafficserver" Level="DEBUG": Detail="Receive Request" Txn-id="23619" Src-ip="127.0.0.1" Src-port="45590" Last-via-addr="172.18.100.14"
HTTPMSG:
|GET http://vcs_control.expuk.company-external.com:8443/ZXhwdWsuc3RyYXRlZ3lhbmFseXRpY3MuY29tL2h0dHBzL1VLLUNVQ00tMDEvODQ0Mw/cucm-uds/servers HTTP/1.1
Host: vcs_control.expuk.company-external.com:8443
Accept: */*
Cookie: X-Auth=76a9e7ca-5573-48cd-9081-e0186425d2fd
User-Agent: Jabber-Win-760
X-Forwarded-For: 201.37.29.82
Via: https/1.1 vcs[AC12640E] (ATS)

Anyone got any ideas? Any other logs I can check to look for reasons behind error 404?

I have attached full logs from Expressway-E, Expressway-C and remote Jabber client during remote sign-in.

Thanks

Tom

0 REPLIES 0