cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
97248
Views
8
Helpful
61
Replies
Highlighted
Beginner

Migrate CUCM 6.x to CUCM 9.x

Hi,

I need migrate CUCM 6.x (8500 DLU - 1000 IP Telep.) to CUCM 9.x. Can i Directly migrate 6.x -> 9.x or need first migrate 6.x -> 8.x and then migrate to 9.x?

Need more additional licenses?

NameCatalog NumDescriptionUnit
Price
Final
Price
Qty
Voice and IP Communications
R-UCL-UCM-LIC-K9R-UCL-UCM-LIC-K9Top Level SKU For 9.x User License - Electronic Delivery0,000,001
Software
CCX-90-CMBUNDLE-K9CCX-90-CMBUNDLE-K9CCX 9.0 Promo Bundle available only with NEW CUCM or BE6000IncludedIncluded1
IME-PAK-K9IME-PAK-K9Auto-expanding PAK for IME 9.0IncludedIncluded1
UCSS-UCM-PAKUCSS-UCM-PAKInclude PAK Auto-expanding UCSS PAK for CUCMIncludedIncluded1
CUCM-VERS-9.0CUCM-VERS-9.0CUCM  Software Version 9.00,000,001
IME-VERS-9.0-K9IME-VERS-9.0-K9IME  9.0 Server Software0,000,001
MIG-CUCM-USR-BMIG-CUCM-USR-BMigration to UC Manager Enhanced - 1K - 10K Users9,009,001.000
UCSS-UCM-ENH-B-3-1UCSS-UCM-ENH-B-3-1UC Manager Enh UCSS 1K to 10K users - 1 user - 3 years29,0029,001.000
Services
CON-ESW-MIGCUC03CON-ESW-MIGCUC03ESSENTIAL SW Migration to UC Manager Enhanced6,006,001.000
61 REPLIES 61
Highlighted
Advisor

There is no direct hop from 6 to 9, it is a multi step process. Check the tables here

http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/compat/ccmcompmatr1.pdf

Thanks

Srini

Highlighted

Actually, if you are on a 6.1(4) or 6.1(5) version of CUCM, then you can directly upgrade to 9.0(1).  But I think there may be more to this question than just "can I get from here to there?".  Are you going to be virtualizing?  Is your current MCS platform supported by 9.0?  Is your MCS platform supported in bridged mode in 9.0?  Are you planning on changing physical servers along the way?

Because of changes in licensing (from DLU to ELM), there are implications that must be considered before upgrading.   My team is working on supplementary upgrade documentation on how to get from any version to 9.0 in both a virtual and non-virtual. Although the document is not complete at this time, we are rather far along with the steps.  So if you provide the details on what version you are coming from, what server model you are deployed on and if you plan on virtualizing or moving to another, I can provide you a reader's digest version that can help with migration. 

As for the DLU to ELM migration, I can't comment, but make sure that all you PAK's are installed prior to starting your upgrade. 

Thanks,

Dan Keller

Technical Marketing Engineer

Highlighted

Yes sorry I assumed an earlier 6.1 version

Srini

Highlighted

Daniel, I'll be happy if you can share with me your document as I'm planning to migrate one of my customer to 6.1(5) to 9.0(1) using CUWL STD (ussing DLU's previously), 2x UCS C220 to virtulaize CUCM, Unity Connection and Presence.

Thanks,

Sylvain

Highlighted

Hi Sylvain,

We have just been through a similar process for a customer here in UK, taking a customer from CUCM 6.1(5) on physical MCS servers up to 8.6(2) on virtual UCS C220 series.  We read various upgrade guides and followed some of the suggestions mentioned on the support forum, but initially hit problems when trying to get to CUCM 8.x which we then overcame as follows:-

There is one thing that is mentioned only occasionally on the support forums but is most important - do not move to the virtual platform until you have got to version 8.0(x) or above.    Even though lower versions may work on VM, you will have issues when trying to upgrade through to v8.x or above if you try to go to the VM platform too early (such as 'invalid hardware' messages and possibly database validity errors).  Trying to move to VM based platform too early starts off looking OK and you may think you will save time as the systems are much faster, but you will hit non-recoverable issues especially when moving upwards from v6.x or v7.x to v8.x and above.

What we did (and this then worked first time for us) was

  • Upgrade the customers physical server from 6.1(5) up to 8.5(1) - as far as we could go on their model of server and following the compatability matrix. 
  • Take a DRS backup at that version.  
  • Install 8.5(1) on the UCS C series
  • Restore the 8.5(1) customer data to that new UCS C series
  • Followed a standard upgrade process to 8.6(2a)

David.

Highlighted

There will be 2 documented upgrade paths to get from a pre 8.x physical MCS to 9.x virtual.  The path that David outlined is one of them.  This will be to migrate to 8.0, virtualize, then upgrade to 9.x will be one path.  The other will be direct upgrades to 9.x for servers that are supported or can be upgraded in bridged mode. 

One very important step that was left out on David's procedure was after the restore in 8.5(1) in VM, you must rehost your licenses.   If not, then when you get to CUCM 9.0, you will not have any valid licensing moved forward and you will not be able to automatically migrate your existing licenses into the ELM. 

Thanks,

Dan Keller

Technical Marketing Engineer

Highlighted

What about customers that are changing hardware or virtulising and want to migrate rather than upgrade? I have a customer that is going from MCS running 6.1(5) to VMWare and as they only have 176 users think the easiest way is to do a parrell installation and use BAT to export and then import devices.

Highlighted

Stuart,

This upgrade path is also valid, but there is no documentation on how to do this because a manual move of data from the physical to virtual is completely independent of the versions.  The reason is that the new CUCM install is a new installation with an empty database.  All data will be imported or manually entered.  In this case, the migration process will not include the automatic migration of licenses.

For this type of "upgrade", you will need to order the correct upgrade kit and ELM licenses, then contact licensing to get the correct ELM license file for the target CUCM version. 

Thanks,

Dan Keller

Technical Marketing Engineer

Highlighted

Hi Dan,

If you could kindly send the document on the upgrade procedures?

Highlighted

Unfortunately, the document has not been finalized.  We are having the Cisco documentation folks finalize it this week.  I expect the document to be posted next week. 

Thanks,

Dan Keller

Technical Marketing Engineer

Highlighted

Dan,

Will they consist of time tables or what the duration of the upgrades would take?

Highlighted

Hi Daniel,

Is the document ready?

Highlighted

Highlighted

Looks to me like this is not a Cisco Licensing supported upgrade?

I thought this would have been what is required to license the new box?

1

585150646

R-UCL-UCM-LIC-K9

Top Level SKU For 9.x User License - Electronic Delivery

1

90640949OD

1

585150671

MIG-CUCM-USR-A

Migration to UC Manager Enhanced - Less than 1K Users

176

90640949OD

HI Stuart – This upgrade path you are doing is NOT supported…I am not saying that you cannot do it but the way you are upgrading is not TAC supported as BAT is not a backup solution.

The way you should be upgrading is to see what is the newest version of call manager supported by your current hardware. If that version is supported on VMWARE as well (8.0(2)) and above then you can do a restore on VMware then upgrade to the latest 9.1. If your hardware does not support any VMware release or bridged upgrade to a VMware release you can talk to your account team on borrowing a loaner server to do the upgrade.

Adel